summaryrefslogtreecommitdiff
path: root/math/py-libpoly
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-04-14 01:28:39 -0700
committerYuri Victorovich <yuri@FreeBSD.org>2021-04-14 01:37:20 -0700
commit195f2e27fd72d73db192acb3fc752f6ed6c67ace (patch)
tree93c0617280a8bc1e548d7b1a7e50b18e671b1c28 /math/py-libpoly
parent443956782647f139ae333e79016c125d5af32f48 (diff)
downloadfreebsd-ports-195f2e27fd72d73db192acb3fc752f6ed6c67ace.zip
math/py-libpoly: Update 0.1.8 -> 0.1.9
Reported by: portscout
Diffstat (limited to 'math/py-libpoly')
-rw-r--r--math/py-libpoly/Makefile2
-rw-r--r--math/py-libpoly/distinfo6
-rw-r--r--math/py-libpoly/files/patch-CMakeLists.txt18
3 files changed, 16 insertions, 10 deletions
diff --git a/math/py-libpoly/Makefile b/math/py-libpoly/Makefile
index d4a2745692a2..bbf9d346fe89 100644
--- a/math/py-libpoly/Makefile
+++ b/math/py-libpoly/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libpoly
DISTVERSIONPREFIX= v
-DISTVERSION= 0.1.8
+DISTVERSION= 0.1.9
CATEGORIES= math
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/math/py-libpoly/distinfo b/math/py-libpoly/distinfo
index cfe835165aba..e590078207ac 100644
--- a/math/py-libpoly/distinfo
+++ b/math/py-libpoly/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1586113047
-SHA256 (SRI-CSL-libpoly-v0.1.8_GH0.tar.gz) = 23935b1767ca2da067035c9b219a3637a39f1d9b3a8f93e3ffe8433a0362f5d4
-SIZE (SRI-CSL-libpoly-v0.1.8_GH0.tar.gz) = 506947
+TIMESTAMP = 1618388219
+SHA256 (SRI-CSL-libpoly-v0.1.9_GH0.tar.gz) = e17a012015d351b690c7c7a8b54f1ad140eee783eca0df2b25e20676d15f353d
+SIZE (SRI-CSL-libpoly-v0.1.9_GH0.tar.gz) = 614179
diff --git a/math/py-libpoly/files/patch-CMakeLists.txt b/math/py-libpoly/files/patch-CMakeLists.txt
index 7f5bb64a65d0..d2ba6e85d001 100644
--- a/math/py-libpoly/files/patch-CMakeLists.txt
+++ b/math/py-libpoly/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2018-07-21 08:36:33 UTC
+--- CMakeLists.txt.orig 2021-04-12 16:09:58 UTC
+++ CMakeLists.txt
-@@ -50,7 +50,7 @@ if(HAVE_OPEN_MEMSTREAM)
+@@ -58,7 +58,7 @@ if(HAVE_OPEN_MEMSTREAM)
endif()
# Configure the library source
@@ -9,11 +9,17 @@
# Configure the headers
add_subdirectory(include)
-@@ -61,6 +61,6 @@ if(LIBPOLY_BUILD_PYTHON_API)
+@@ -72,11 +72,11 @@ if(LIBPOLY_BUILD_PYTHON_API)
add_subdirectory(python)
- # Configure the tests
-- add_subdirectory(test)
-+ #add_subdirectory(test)
+ # Configure the Python tests
+- add_subdirectory(test/python)
++ #add_subdirectory(test/python)
endif()
+
+ # Configure the C++ tests
+ enable_testing()
+-add_subdirectory(test/polyxx)
++#add_subdirectory(test/polyxx)
+