summaryrefslogtreecommitdiff
path: root/math/py-amply
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-11-14 17:49:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-11-14 17:49:42 +0000
commit87d279f583624adc991a536ab127640e9c82730c (patch)
treeb6db88cd0630d404563b35cf542c4f52be9a20ec /math/py-amply
parent74c5b9bdfbd45c2354d76b717403579be5693756 (diff)
downloadfreebsd-ports-87d279f583624adc991a536ab127640e9c82730c.zip
New port: math/py-amply: Load and manipulate AMPL data as Python data structures
Diffstat (limited to 'math/py-amply')
-rw-r--r--math/py-amply/Makefile22
-rw-r--r--math/py-amply/distinfo3
-rw-r--r--math/py-amply/pkg-descr9
3 files changed, 34 insertions, 0 deletions
diff --git a/math/py-amply/Makefile b/math/py-amply/Makefile
new file mode 100644
index 000000000000..8fce386e2357
--- /dev/null
+++ b/math/py-amply/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= amply
+DISTVERSION= 0.1.4
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Load and manipulate AMPL data as Python data structures
+
+LICENSE= EPL
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>0:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>0:devel/py-pyparsing@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/math/py-amply/distinfo b/math/py-amply/distinfo
new file mode 100644
index 000000000000..7041cd3446a0
--- /dev/null
+++ b/math/py-amply/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1605375802
+SHA256 (amply-0.1.4.tar.gz) = cb12dcb49d16b168c02be128a1527ecde50211e4bd94af76ff4e67707f5a2d38
+SIZE (amply-0.1.4.tar.gz) = 28182
diff --git a/math/py-amply/pkg-descr b/math/py-amply/pkg-descr
new file mode 100644
index 000000000000..3fa32f10f360
--- /dev/null
+++ b/math/py-amply/pkg-descr
@@ -0,0 +1,9 @@
+Amply allows you to load and manipulate AMPL data as Python data structures.
+
+Amply only supports a specific subset of the AMPL syntax:
+* set declarations
+* set data statements
+* parameter declarations
+* parameter data statements
+
+WWW: https://github.com/willu47/amply