summaryrefslogtreecommitdiff
path: root/math/octave-forge-io
diff options
context:
space:
mode:
authorStephen Montgomery-Smith <stephen@FreeBSD.org>2011-11-21 01:17:40 +0000
committerStephen Montgomery-Smith <stephen@FreeBSD.org>2011-11-21 01:17:40 +0000
commitdf56e1f431553fe11f5a8e45d94d71e5bc584ad4 (patch)
treea49ff5cb6b00ab4e248704a358294b0151f9ee4f /math/octave-forge-io
parentd9b2767be3eb8223e3bebb0529ddd1d8771bba4a (diff)
downloadfreebsd-ports-df56e1f431553fe11f5a8e45d94d71e5bc584ad4.zip
- Cosmetic change to Makefile. Use the variable OCTSRC to describe where the
contents of the package are stored. This should make it easier if other people take over maintainership of the octave-forge-* ports. Feature safe: yes
Diffstat (limited to 'math/octave-forge-io')
-rw-r--r--math/octave-forge-io/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/math/octave-forge-io/Makefile b/math/octave-forge-io/Makefile
index 0ba5d2bf60b8..894a25941b99 100644
--- a/math/octave-forge-io/Makefile
+++ b/math/octave-forge-io/Makefile
@@ -12,6 +12,10 @@ CATEGORIES= math
MAINTAINER= stephen@FreeBSD.org
COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+# OCTSRC is the name of the directory of the package.
+# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
+OCTSRC= ${OCTAVE_PKGNAME}
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/Mk/bsd.octave.mk"
do-build:
@@ -19,6 +23,6 @@ do-build:
post-build:
${RM} -f ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTAVE_PKGNAME}
+ cd ${WRKDIR} && ${TAR} cfz ${DISTNAME}.tar.gz ${OCTSRC}
.include <bsd.port.post.mk>