summaryrefslogtreecommitdiff
path: root/math/gh-bc/Makefile
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2021-08-09 19:09:30 +0200
committerStefan Eßer <se@FreeBSD.org>2021-08-09 19:44:01 +0200
commit94a34f976b05bb8b3f2d9eeb4e55c167e4f34179 (patch)
treef4201f28ed313ea636ba67c40d5f1c1ed832552a /math/gh-bc/Makefile
parent4462befa783217d4be1ff290c1bfe6cb0a376462 (diff)
downloadfreebsd-ports-94a34f976b05bb8b3f2d9eeb4e55c167e4f34179.zip
math/gh-bc: update to version 5.0.0
This is a new major release with a number of changes and extensions: - Limited the number of temporary numbers and made the space for them static so that allocating more space for them cannot fail. - Allowed integers with non-zero scale to be used with power, places, and shift operators. - Added greatest common divisor and least common multiple to lib2.bc. - Made bc and dc UTF-8 capable. - Added the ability for users to have bc and dc quit on SIGINT. - Added the ability for users to disable prompt and TTY mode by environment variables. - Added the ability for users to redefine keywords. - Added dc's modular exponentiation and divmod to bc. - Added the ability to assign strings to variables and array elements and pass them to functions in bc. - Added dc's asciify command and stream printing to bc. - Added bitwise and, or, xor, left shift, right shift, reverse, left rotate, right rotate, and mod functions to lib2.bc. - Added the functions s2u(x) and s2un(x,n), to lib2.bc.
Diffstat (limited to 'math/gh-bc/Makefile')
-rw-r--r--math/gh-bc/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/math/gh-bc/Makefile b/math/gh-bc/Makefile
index 606f7db891b4..91e6d0f56434 100644
--- a/math/gh-bc/Makefile
+++ b/math/gh-bc/Makefile
@@ -1,5 +1,5 @@
PORTNAME= bc
-PORTVERSION= 4.0.2
+PORTVERSION= 5.0.0
CATEGORIES= math lang
PKGNAMEPREFIX= gh-
@@ -10,21 +10,22 @@ LICENSE= BSD2CLAUSE MIT
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= compiler
+USES= compiler:c11
USE_GITHUB= yes
GH_ACCOUNT= gavinhoward
-HAS_CONFIGURE= yes
+HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.sh
-CONFIGURE_ARGS= -G
+CONFIGURE_ARGS= -G
+CFLAGS+= -Dstatic_assert=_Static_assert
.include <bsd.port.pre.mk>
-.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
-CFLAGS+= --std=c99
-.endif
+#.if ${CHOSEN_COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
+#CFLAGS+= --std=c99
+#.endif
-CONFLICTS_INSTALL= gnubc-[0-9]*
+CONFLICTS_INSTALL= gnubc
pre-build:
${INSTALL_SCRIPT} ${WRKSRC}/gen/strgen.sh ${WRKSRC}/gen/strgen
@@ -35,7 +36,7 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/manuals/bc.1 ${STAGEDIR}${MANPREFIX}/share/man/man1
${INSTALL_MAN} ${WRKSRC}/manuals/dc.1 ${STAGEDIR}${MANPREFIX}/share/man/man1
${MKDIR} ${STAGEDIR}${PREFIX}/share/nls/C
- ${WRKSRC}/locale_install.sh ${STAGEDIR}${PREFIX}/share/nls/%L/%N.cat ${PORTNAME}
+ ${WRKSRC}/scripts/locale_install.sh ${STAGEDIR}${PREFIX}/share/nls/%L/%N.cat ${PORTNAME}
${MV} ${STAGEDIR}${PREFIX}/share/nls/en_US/bc.cat ${STAGEDIR}${PREFIX}/share/nls/C/
${RMDIR} ${STAGEDIR}${PREFIX}/share/nls/en_US