summaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2020-04-23 15:32:29 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2020-04-23 15:32:29 +0000
commit5abe8902a53b7bfd7ab482ec3f59229cdc2e812d (patch)
treedaa44b3bcefdd28f130988ddbc1a68139417194d /mail
parentc108a6700f69ec335f794e2b36e9077f81facda9 (diff)
downloadfreebsd-ports-5abe8902a53b7bfd7ab482ec3f59229cdc2e812d.zip
lang/rust: Update to 1.43.0
- Add workaround to fix build when CC/CXX have "clang" in them [1] - Respect AR to fix build with external toolchains [2] - Force rebuild all consumers to catch regressions early Changes: https://blog.rust-lang.org/2020/04/23/Rust-1.43.0.html PR: 238556 [1], 245583 [2] Reported by: Matthias Apitz <guru@unixarea.de> [1], Greg V <greg@unrelenting.technology> [2] Tested by: mikael, pkubaj, tobik With hat: rust Differential Revision: https://reviews.freebsd.org/D24521
Diffstat (limited to 'mail')
-rw-r--r--mail/thunderbird/Makefile1
-rw-r--r--mail/thunderbird/files/patch-bug158096361
2 files changed, 62 insertions, 0 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index b755e35cbdca..677d5685b86a 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -3,6 +3,7 @@
PORTNAME= thunderbird
DISTVERSION= 68.7.0
+PORTREVISION= 1
CATEGORIES= mail news net-im
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/files/patch-bug1580963 b/mail/thunderbird/files/patch-bug1580963
new file mode 100644
index 000000000000..214c3d8f25c9
--- /dev/null
+++ b/mail/thunderbird/files/patch-bug1580963
@@ -0,0 +1,61 @@
+From 7617a0e6fe2bb7afab6ffda49fc8cd9eca2f035b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Emilio=20Cobos=20=C3=81lvarez?= <emilio@crisal.io>
+Date: Thu, 12 Sep 2019 21:09:27 +0000
+Subject: [PATCH] Bug 1580963 - Cherry-pick some servo changes from a rustc
+ upgrade.
+
+This cherry-picks from Servo commit 98e4a53b724.
+
+Differential Revision: https://phabricator.services.mozilla.com/D45738
+
+--HG--
+extra : moz-landing-system : lando
+---
+ .../style/stylesheets/viewport_rule.rs | 23 +++++++++++++------
+ 1 file changed, 16 insertions(+), 7 deletions(-)
+
+diff --git a/servo/components/style/stylesheets/viewport_rule.rs b/servo/components/style/stylesheets/viewport_rule.rs
+index 8cc858f7a7f69..7d0881e3336a9 100644
+--- servo/components/style/stylesheets/viewport_rule.rs
++++ servo/components/style/stylesheets/viewport_rule.rs
+@@ -291,15 +291,18 @@ impl<'a, 'b, 'i> DeclarationParser<'i> for ViewportRuleParser<'a, 'b> {
+ ) -> Result<Vec<ViewportDescriptorDeclaration>, ParseError<'i>> {
+ macro_rules! declaration {
+ ($declaration:ident($parse:expr)) => {
+- declaration!($declaration(value: try!($parse(input)),
+- important: input.try(parse_important).is_ok()))
++ declaration!($declaration {
++ value: $parse(input)?,
++ important: input.try(parse_important).is_ok(),
++ })
+ };
+- ($declaration:ident(value: $value:expr, important: $important:expr)) => {
++ ($declaration:ident { value: $value:expr, important: $important:expr, }) => {
+ ViewportDescriptorDeclaration::new(
+ self.context.stylesheet_origin,
+ ViewportDescriptor::$declaration($value),
+- $important)
+- }
++ $important,
++ )
++ };
+ }
+
+ macro_rules! ok {
+@@ -311,8 +314,14 @@ impl<'a, 'b, 'i> DeclarationParser<'i> for ViewportRuleParser<'a, 'b> {
+ let important = input.try(parse_important).is_ok();
+
+ Ok(vec![
+- declaration!($min(value: shorthand.0, important: important)),
+- declaration!($max(value: shorthand.1, important: important)),
++ declaration!($min {
++ value: shorthand.0,
++ important: important,
++ }),
++ declaration!($max {
++ value: shorthand.1,
++ important: important,
++ }),
+ ])
+ }};
+ }