summaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorDerek Schrock <dereks@lifeofadishwasher.com>2023-05-13 16:14:46 -0400
committerRobert Clausecker <fuz@FreeBSD.org>2023-05-18 10:19:52 +0200
commit37e65e1ec393e94d95f9285501fb9208d475c0cf (patch)
treeea5da3312d23a3dc2118bc515b9504d7afd184b4 /mail
parent821da01d84be82012562864432790d115510c892 (diff)
downloadfreebsd-ports-37e65e1ec393e94d95f9285501fb9208d475c0cf.zip
mail/mutt: Fix SASL option to not always disable SASL
With 60ba31d73e SASL_NONE_CONFIGURE_WITH however with it unchecked --without-sasl was added. Always disabling sasl. Use OPT_CONFIGURE_OFF and OPT_CONFIGURE_ON to make sure --without-sasl isn't added when SASL_NONE is unchecked. PR: 271395 Approved by: kh@panix.com (maintainer)
Diffstat (limited to 'mail')
-rw-r--r--mail/mutt/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/mail/mutt/Makefile b/mail/mutt/Makefile
index 2dd624b27c0f..bf9a5d68b059 100644
--- a/mail/mutt/Makefile
+++ b/mail/mutt/Makefile
@@ -1,6 +1,6 @@
PORTNAME= mutt
DISTVERSION= 2.2.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES+= mail
MASTER_SITES= ftp://ftp.mutt.org/pub/mutt/ \
https://bitbucket.org/mutt/mutt/downloads/ \
@@ -181,7 +181,8 @@ SASL_CYRUS_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
SASL_CYRUS_CONFIGURE_WITH= sasl=${LOCALBASE}
SASL_GSASL_LIB_DEPENDS= libgsasl.so:security/libgsasl
SASL_GSASL_CONFIGURE_WITH= gsasl=${LOCALBASE}
-SASL_NONE_CONFIGURE_WITH= sasl=no
+SASL_NONE_CONFIGURE_ON= --with-sasl=no
+SASL_NONE_CONFIGURE_OFF=
# Handle ncurses/ncurses-port/slang
SLANG_LIB_DEPENDS= libslang.so:devel/libslang2