summaryrefslogtreecommitdiff
path: root/mail
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2006-01-22 13:26:41 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2006-01-22 13:26:41 +0000
commit3218f7f15c14e1373a980dfc274463db69bbfca0 (patch)
treea9f7e05bac631ed21e0834cf306f3dd4f58cbc5a /mail
parent0e37db4c7ab9bf9c2db82f78dd2250e392e81a63 (diff)
downloadfreebsd-ports-3218f7f15c14e1373a980dfc274463db69bbfca0.zip
- Add checks to make sure a database backend has been chosen.
- Fix INDEX build when WITHOUT_MYSQL is defined. Reported by: kris
Diffstat (limited to 'mail')
-rw-r--r--mail/roundcube/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/mail/roundcube/Makefile b/mail/roundcube/Makefile
index cb95d9b18462..f9ad81182392 100644
--- a/mail/roundcube/Makefile
+++ b/mail/roundcube/Makefile
@@ -45,6 +45,10 @@ OPTIONS+= SQLITE "Use SQLite backend" off
.include <bsd.port.pre.mk>
+.if defined(WITHOUT_MYSQL) && !defined(WITH_PGSQL) && !defined(WITH_SQLITE)
+IGNORE= needs a database backend
+.endif
+
.if !defined(WITHOUT_MYSQL)
USE_PHP+= mysql
.endif
@@ -57,6 +61,9 @@ USE_PHP+= pgsql
USE_PHP+= sqlite
.endif
+# Avoid INDEX breakage when WITHOUT_MYSQL is defined.
+USE_PHP?= yes
+
.include "${PORTSDIR}/Mk/bsd.php.mk"
do-install: