summaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
commitd09ed096c44ca516f3e4922e292b4afabd03ff11 (patch)
tree8472e59ca02578120ca7b8bc5e2af50d2954440e /lang
parent31a195fb72446a7d02336b8fa1b9c1e0032f95cb (diff)
downloadfreebsd-ports-d09ed096c44ca516f3e4922e292b4afabd03ff11.zip
*/*: Replace USE_GCC=any with USE_GCC=yes
USE_GCC=any has been equivalent to USE_GCC=yes in most cases (such as i386 and amd64 since 12.x and depending on configuration 11.x, most newer installations on other platforms, and 13.x across the board). Since commit 96c17633d90386b5bcf8 Mk/bsd.gcc.mk is treating them as different spellings of the same, so continue the deorbiting of the USE_GCC=any form and simply replace it with USE_GCC=yes. This should not make any functional difference at all. Discussed with: mat, linimon, pkubaj
Diffstat (limited to 'lang')
-rw-r--r--lang/clisp/Makefile2
-rw-r--r--lang/gforth/Makefile2
-rw-r--r--lang/mlton/Makefile2
-rw-r--r--lang/oo2c/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/lang/clisp/Makefile b/lang/clisp/Makefile
index ba855179a6cb..d87be5d8f86c 100644
--- a/lang/clisp/Makefile
+++ b/lang/clisp/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libffcall.so:devel/libffcall \
libsigsegv.so:devel/libsigsegv
USES= compiler gettext ghostscript gnome iconv localbase:ldflags
-USE_GCC= any
+USE_GCC= yes
USE_GITLAB= yes
GL_ACCOUNT= gnu-clisp
diff --git a/lang/gforth/Makefile b/lang/gforth/Makefile
index c21b37935b8a..2b2f188b06d8 100644
--- a/lang/gforth/Makefile
+++ b/lang/gforth/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libavcall.so:devel/libffcall \
libltdl.so:devel/libltdl
USES= gmake libtool:build localbase makeinfo
-USE_GCC= any
+USE_GCC= yes
USE_LDCONFIG= ${PREFIX}/lib/gforth/${PORTVERSION}/libcc-named
GNU_CONFIGURE= yes
diff --git a/lang/mlton/Makefile b/lang/mlton/Makefile
index 68b9afaa069d..407e3d7cf258 100644
--- a/lang/mlton/Makefile
+++ b/lang/mlton/Makefile
@@ -32,7 +32,7 @@ MINGW32_DESC= Add the mingw32 target (requires wine)
MAKE_JOBS_UNSAFE= yes
USES= gmake shebangfix
-USE_GCC= any
+USE_GCC= yes
.include <bsd.port.options.mk>
diff --git a/lang/oo2c/Makefile b/lang/oo2c/Makefile
index bc7cb9a51926..4b29a85cb3df 100644
--- a/lang/oo2c/Makefile
+++ b/lang/oo2c/Makefile
@@ -22,7 +22,7 @@ USES= gmake libtool:build localbase:ldflags tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_CSTD= gnu89
-USE_GCC= any
+USE_GCC= yes
OPTIONS_DEFINE= DOCS THREADS
OPTIONS_SUB= yes