summaryrefslogtreecommitdiff
path: root/lang/php81
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-21 10:38:37 -0600
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-01-25 11:54:07 -0600
commit40843b1ccb8f70cca82dd115a71a46ae2a97a450 (patch)
treeeab403c2779e9e34988645d31bb779a42ff3be86 /lang/php81
parent455187b1323a74758a56578b37760fd554a9144a (diff)
downloadfreebsd-ports-40843b1ccb8f70cca82dd115a71a46ae2a97a450.zip
Mk/Uses/apache.mk: Refactor after removal of older versions
apache22 and apache25 had been removed a long time ago however the apache.mk file has never been refactored and is out of sync from the file Mk/bsd.default-versions.mk. These changes refactors the removals of the older versions. In addition: - Move some keywords like USE_APACHE, USE_APACHE_BUILD, USE_APACHE_RUN from SANITY_DEPRECATED to SANITY_UNSUPPORTED - Remove apache versions from ports Makefiles as currently there is only one available version in the tree. However the version checks are still valid and should work flawlessly whenever a new version is added. For example USES=apache:2.2+ are simply replaced with USES=apache. As currently there are no other versions available for test this could not be checked on it's own ground. - Update FOO_USE=APACHE=yes to FOO_USES=apache - Remove trailing whitespaces Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D38113
Diffstat (limited to 'lang/php81')
-rw-r--r--lang/php81/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/lang/php81/Makefile b/lang/php81/Makefile
index 5e7c20d97ab1..af232eed7af0 100644
--- a/lang/php81/Makefile
+++ b/lang/php81/Makefile
@@ -96,8 +96,7 @@ CONFIGURE_ARGS+= --without-pcre-jit
.endif
.if defined(PKGNAMEPREFIX)
-USES+= apache:2.2+
-.include "${PORTSDIR}/Mk/Uses/apache.mk"
+USES+= apache
.if ${PORT_OPTIONS:MAP2FILTER}
CONFIGURE_ARGS+= --with-apxs2filter=${APXS}
.else