summaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-05-13 17:38:33 +0000
committerJohn Marino <marino@FreeBSD.org>2015-05-13 17:38:33 +0000
commitf2296ae8cde4232845e5a21d1e7b4ccc5d554f79 (patch)
treeda4de71e63ef32cb3e46d632052d888788803835 /lang/ocaml
parent762ebb524445f3f61304a3fbd6facee5836f23e0 (diff)
downloadfreebsd-ports-f2296ae8cde4232845e5a21d1e7b4ccc5d554f79.zip
lang/ocaml: Tweak PROFILE handling to support DragonFly
This changes a conditional statement to an equivalent variation. An internal transformation of DPorts was getting confused by this construct. Discussed with: Michael Gruenewald (maintainer)
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 57faf35150c3..bdac81fd0a67 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -94,7 +94,7 @@ CONFIGURE_ARGS+=-no-graph
OCAML_ARCH= ${ARCH:S/x86_64/amd64/:S/powerpc/power/:S/armv6/arm/}
-.if defined(NO_PROFILE) || ${OCAML_ARCH} == power || ${OCAML_ARCH} == amd64
+.if defined(NO_PROFILE) || ${OCAML_ARCH:Mpower} || ${OCAML_ARCH:Mamd64}
PLIST_SUB+= PROF="@comment "
.else
PLIST_SUB+= PROF=""