summaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-06-10 23:40:37 +0000
committerJohn Marino <marino@FreeBSD.org>2014-06-10 23:40:37 +0000
commite3a36981008ddc3996493067792b1a6219f690d2 (patch)
tree58b048698d64e52aed57ff59dab0978d87c07267 /lang/ocaml
parent93d2f551b6704bf4c3e0e6dadd530819a8362bd1 (diff)
downloadfreebsd-ports-e3a36981008ddc3996493067792b1a6219f690d2.zip
lang/ocaml: Remove DEF_OPT option (non-default option)
The option reacts poorly with ocamlp4, and phasing out DEF_OPT completely will prevent a lot of breakage with ports that also interact with ocamlp4. PR: 189176 Submitted by: Anil Madhavapeddy Prepared by: maintainer (Michael Gruenewald)
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile19
-rw-r--r--lang/ocaml/files/patch-camlp4-man_Makefile8
2 files changed, 6 insertions, 21 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 796d4bbf61b3..19ddc4d82703 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -4,7 +4,7 @@
# for committer: bump PORTREVISION for math/facile whenever ocaml gets updated
PORTNAME= ocaml
PORTVERSION= 4.01.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= http://caml.inria.fr/pub/distrib/${DISTNAME:R}/ \
${MASTER_SITE_GENTOO}
@@ -37,12 +37,10 @@ CONFIGURE_ARGS= -verbose -prefix "${PREFIX}" \
-aspp "${CC} -c" \
-partialld "${LD} -r"
-OPTIONS_DEFINE= X11 TK THREADS OPT_DEF DOCS
+OPTIONS_DEFINE= X11 TK THREADS DOCS
OPTIONS_DEFAULT=X11 TK THREADS
-OPT_DEF_DESC= Use system-optimized binaries by default
TK_DESC= LablTk library (requires X11 support)
CMP_LIB_DESC= Install compiler libraries
-OPT_DEF_DESC= Use system-optimizes binaries by default
PORTDOCS= htmlman ${DOCSDISTNAME}-refman.ps.gz \
${DOCSDISTNAME}-refman.pdf
@@ -200,17 +198,4 @@ post-install:
# Fix permissions for ld.conf
@${CHMOD} 644 ${STAGEDIR}${PREFIX}/lib/ocaml/ld.conf
-# Do we want .opt version of tools to be the default ?
-.if ${PORT_OPTIONS:MOPT_DEF}
-. for module in ${MODOPT}
-# First, we save bytecode version
- ${MV} ${STAGEDIR}${PREFIX}/bin/${module} ${STAGEDIR}${PREFIX}/bin/${module}.byte
-
-# Next make .opt version be the default one (via link)
- ${LN} ${STAGEDIR}${PREFIX}/bin/${module}.opt ${STAGEDIR}${PREFIX}/bin/${module}
- @${ECHO_CMD} "bin/${module}.byte" >> ${TMPPLIST}
- @${ECHO_CMD} "@exec ${LN} %D/${module}.opt %D/${module}" >> ${TMPPLIST}
-. endfor
-.endif
-
.include <bsd.port.post.mk>
diff --git a/lang/ocaml/files/patch-camlp4-man_Makefile b/lang/ocaml/files/patch-camlp4-man_Makefile
index 9caeb9e4e3ae..60ce1a1f3611 100644
--- a/lang/ocaml/files/patch-camlp4-man_Makefile
+++ b/lang/ocaml/files/patch-camlp4-man_Makefile
@@ -1,6 +1,6 @@
---- camlp4/man/Makefile.orig 2010-11-04 21:04:51.000000000 +0800
-+++ camlp4/man/Makefile 2010-11-04 21:05:14.000000000 +0800
-@@ -3,7 +3,6 @@
+--- camlp4/man/Makefile.orig 2012-07-17 11:31:12.000000000 -0400
++++ camlp4/man/Makefile 2013-11-21 03:16:26.000000000 -0500
+@@ -14,7 +14,6 @@
include ../config/Makefile.cnf
TARGET=camlp4.1
@@ -8,7 +8,7 @@
include ../config/Makefile.base
-@@ -11,10 +10,6 @@
+@@ -22,10 +21,6 @@
if test -n '$(MANDIR)'; then \
$(MKDIR) $(MANDIR)/man1 ; \
cp $(TARGET) $(MANDIR)/man1/. ; \