summaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-25 12:58:33 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-25 12:58:33 +0000
commitd945d5ea982deadca9e8b17c2e7f4f928fe6d9ee (patch)
treeb03cfdc045d4887da1bbcf9872d0180f879152a5 /lang/ocaml
parent3580698ace693e3fa8ae6efd6422c8ffe0baf00b (diff)
downloadfreebsd-ports-d945d5ea982deadca9e8b17c2e7f4f928fe6d9ee.zip
lang category: Remove $PTHREAD_LIBS
Note: ecl did not pass check-plist (pre-existing), PR 198897 submitted. approved by: PTHREAD blanket
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 507a2361e19b..f4ea0bc107c7 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -71,11 +71,9 @@ CONFIGURE_ARGS+= -as "${AS} ${ASFLAGS}"
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
-THR_CPP= ${PTHREAD_CFLAGS}
-THR_LD= ${PTHREAD_LIBS}
+THR_LD= -lpthread
.else
PLIST_SUB+= THREADS="@comment "
-THR_CPP= #empty
THR_LD= #empty
CONFIGURE_ARGS+=-no-pthread
.endif
@@ -102,7 +100,7 @@ IGNORE=requires X11 support to build TK bindings
USES+= tk:84+
PLIST_SUB+= TK=""
CONFIGURE_ARGS+= -tkdefs \
- "-I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR} ${THR_CPP}" \
+ "-I${TCL_INCLUDEDIR} -I${TK_INCLUDEDIR}" \
-tklibs "-L${LOCALBASE}/lib -ltk${TK_VER:S|.||} \
-ltcl${TCL_VER:S|.||} ${THR_LD}"
.else
@@ -159,8 +157,8 @@ post-patch:
post-configure:
# CFLAGS safeness
@${REINPLACE_CMD} -E \
- -e 's|(BYTECCCOMPOPTS[ \t]*=.*)|\1 ${CFLAGS} ${THR_CPP}|' \
- -e 's|(NATIVECCCOMPOPTS[ \t]*=.*)|\1 ${CFLAGS} ${THR_CPP}|' \
+ -e 's|(BYTECCCOMPOPTS[ \t]*=.*)|\1 ${CFLAGS}|' \
+ -e 's|(NATIVECCCOMPOPTS[ \t]*=.*)|\1 ${CFLAGS}|' \
-e '/^PTHREAD_LINK/s,-pthread,${THR_LD},g' \
${WRKSRC}/config/Makefile