summaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2016-03-24 20:55:15 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2016-03-24 20:55:15 +0000
commitc80bd713b0c7cf531998437687162bd2743b4fb1 (patch)
tree1c7d8b3ca6315acc51ac82cb822ea7df7d0bba36 /lang/ocaml
parentaceddd804320587fa4208c48da1dffa0aac547b5 (diff)
downloadfreebsd-ports-c80bd713b0c7cf531998437687162bd2743b4fb1.zip
Fix packaging on armv6 by enabling profiling libraries.
PR: 206615 Submitted by: mikael.urankar at gmail.com Approved by: michipili at gmail.com (maintainer)
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile4
-rw-r--r--lang/ocaml/files/patch-configure16
2 files changed, 12 insertions, 8 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index ac3f534236cf..eb84b25016e1 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -98,8 +98,8 @@ CONFIGURE_ARGS+=-no-graph
OCAML_ARCH= ${ARCH:S/x86_64/amd64/:S/powerpc/power/:S/armv6/arm/}
-.if defined(NO_PROFILE) || ${OCAML_ARCH:Mpower} || ${OCAML_ARCH:Mamd64} \
- || ${OCAML_ARCH:Marm}
+.if defined(NO_PROFILE) || ${OCAML_ARCH:Mpower} || ${OCAML_ARCH:Mamd64}
+
PLIST_SUB+= PROF="@comment "
.else
PLIST_SUB+= PROF=""
diff --git a/lang/ocaml/files/patch-configure b/lang/ocaml/files/patch-configure
index 4898e5f92533..e0295b61bd8c 100644
--- a/lang/ocaml/files/patch-configure
+++ b/lang/ocaml/files/patch-configure
@@ -114,7 +114,7 @@
*,freebsd) as="${TOOLPREF}as"
aspp="${TOOLPREF}cc -c";;
amd64,*|arm,*|arm64,*|i386,*|power,bsd*|sparc,*)
-@@ -955,6 +961,7 @@ case "$arch,$system" in
+@@ -955,9 +961,11 @@ case "$arch,$system" in
case "$nativecc" in gcc*) ;; *) cc_profile='-xpg';; esac;;
amd64,linux) profiling='prof';;
amd64,openbsd) profiling='prof';;
@@ -122,7 +122,11 @@
amd64,freebsd) profiling='prof';;
amd64,netbsd) profiling='prof';;
amd64,gnu) profiling='prof';;
-@@ -1415,6 +1422,8 @@ if test "$pthread_wanted" = "yes"; then
++ arm,freebsd) profiling='prof';;
+ arm,linux*) profiling='prof';;
+ power,elf) profiling='prof';;
+ power,bsd*) profiling='prof';;
+@@ -1415,6 +1423,8 @@ if test "$pthread_wanted" = "yes"; then
case "$target" in
*-*-solaris*) pthread_link="-lpthread -lposix4"
pthread_caml_link="-cclib -lpthread -cclib -lposix4";;
@@ -131,7 +135,7 @@
*-*-freebsd*) pthread_link="-pthread"
pthread_caml_link="-cclib -pthread";;
*-*-openbsd*) pthread_link="-pthread"
-@@ -1431,7 +1440,7 @@ if test "$pthread_wanted" = "yes"; then
+@@ -1431,7 +1441,7 @@ if test "$pthread_wanted" = "yes"; then
bytecccompopts="$bytecccompopts -D_REENTRANT"
nativecccompopts="$nativecccompopts -D_REENTRANT"
case "$target" in
@@ -140,7 +144,7 @@
bytecccompopts="$bytecccompopts -D_THREAD_SAFE"
nativecccompopts="$nativecccompopts -D_THREAD_SAFE";;
*-*-openbsd*)
-@@ -1601,6 +1610,7 @@ if test "$x11_include" = "not found"; th
+@@ -1601,6 +1611,7 @@ if test "$x11_include" = "not found"; th
else
x11_libs="-L$dir"
case "$target" in
@@ -148,7 +152,7 @@
*-kfreebsd*-gnu) x11_link="-L$dir -lX11";;
*-*-*bsd*) x11_link="-R$dir -L$dir -lX11";;
*) x11_link="-L$dir -lX11";;
-@@ -1644,10 +1654,10 @@ echo "X11_LINK=$x11_link" >> Makefile
+@@ -1644,10 +1655,10 @@ echo "X11_LINK=$x11_link" >> Makefile
# Look for BFD library
if sh ./hasgot -DPACKAGE=ocaml -i bfd.h && \
@@ -161,7 +165,7 @@
else
wrn "BFD library not found, 'objinfo' will be unable to display info on .cmxs files."
echo "LIBBFD_LINK=" >> Makefile
-@@ -1686,12 +1696,6 @@ if $no_naked_pointers; then
+@@ -1686,12 +1697,6 @@ if $no_naked_pointers; then
echo "#define NO_NAKED_POINTERS" >> m.h
fi