summaryrefslogtreecommitdiff
path: root/lang/ocaml
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-12 09:09:55 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-07-12 09:09:55 +0000
commit1d95700733a09b6eb0095218f86fba0cb7b8ab69 (patch)
tree947a5779b15ad72132bd3b6c4bfa17f2ffc83d49 /lang/ocaml
parent971f14ce95bbd570b9aa5e2b8e062e9879ace54f (diff)
downloadfreebsd-ports-1d95700733a09b6eb0095218f86fba0cb7b8ab69.zip
lang/ocaml: fix on powerpc64
powerpc64 needs to be put to configure script to be recognized. PR: 238788 Approved by: michipili@gmail.com (maintainer timeout), tcberner (mat) Differential Revision: https://reviews.freebsd.org/D20891
Diffstat (limited to 'lang/ocaml')
-rw-r--r--lang/ocaml/Makefile3
-rw-r--r--lang/ocaml/files/patch-configure12
2 files changed, 8 insertions, 7 deletions
diff --git a/lang/ocaml/Makefile b/lang/ocaml/Makefile
index 6df22421a560..343547e767c5 100644
--- a/lang/ocaml/Makefile
+++ b/lang/ocaml/Makefile
@@ -20,12 +20,11 @@ LICENSE_PERMS_QPL10= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
BROKEN_aarch64= Does not build: sh: as: not found
BROKEN_armv7= Does not build: hasgot.c: undefined reference to `tgetent'
-BROKEN_powerpc64= Does not build: error: too few arguments to function gethostbyname_r
BROKEN_sparc64= No rule to make target 'none.o', needed by 'libasmrun.a'
BROKEN_mips64= No ASM support
BROKEN_mips= No ASM support
-USES= cpe gmake tar:xz
+USES= cpe compiler:c11 gmake tar:xz
USE_LDCONFIG= yes
CPE_VENDOR= inria
HAS_CONFIGURE= yes
diff --git a/lang/ocaml/files/patch-configure b/lang/ocaml/files/patch-configure
index 03e99ed87e18..7fbf89721503 100644
--- a/lang/ocaml/files/patch-configure
+++ b/lang/ocaml/files/patch-configure
@@ -25,15 +25,17 @@
esac
fi
-@@ -921,6 +923,7 @@ case "$target" in
+@@ -921,6 +923,9 @@ case "$target" in
powerpc*-*-linux*) arch=power;
if $arch64; then model=ppc64; else model=ppc; fi
system=elf;;
-+ powerpc-*-freebsd*) arch=power; model=ppc; system=bsd_elf;;
++ powerpc*-*-freebsd*) arch=power;
++ if $arch64; then model=ppc64; else model=ppc; fi
++ system=bsd_elf;;
powerpc-*-netbsd*) arch=power; model=ppc; system=elf;;
powerpc-*-openbsd*) arch=power; model=ppc; system=bsd_elf;;
s390x*-*-linux*) arch=s390x; model=z10; system=elf;;
-@@ -946,6 +949,7 @@ case "$target" in
+@@ -946,6 +951,7 @@ case "$target" in
x86_64-*-darwin*) arch=amd64; system=macosx;;
x86_64-*-mingw*) arch=amd64; system=mingw;;
aarch64-*-linux*) arch=arm64; system=linux;;
@@ -41,7 +43,7 @@
x86_64-*-cygwin*) arch=amd64; system=cygwin;;
esac
-@@ -1051,10 +1055,12 @@ case "$arch,$system" in
+@@ -1051,10 +1057,12 @@ case "$arch,$system" in
case "$nativecc" in gcc*) ;; *) cc_profile='-xpg';; esac;;
amd64,linux) profiling='true';;
amd64,openbsd) profiling='true';;
@@ -54,7 +56,7 @@
arm,linux*) profiling='true';;
power,elf) profiling='true';;
power,bsd*) profiling='true';;
-@@ -2029,7 +2035,7 @@ MKLIB=${TOOLPREF}ar rc \$(1) \$(2); ${TOOLPREF}ranlib
+@@ -2029,7 +2037,7 @@ MKLIB=${TOOLPREF}ar rc \$(1) \$(2); ${TOOLPREF}ranlib
#ml Printf.sprintf "${TOOLPREF}ar rc %s %s %s; ${TOOLPREF}ranlib %s"
#ml out opts files out;;
EOF