summaryrefslogtreecommitdiff
path: root/lang/mono
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2017-04-21 10:02:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2017-04-21 10:02:27 +0000
commitf51091ad5956e3a411b095aef4fd3b11d62dc2c2 (patch)
treee1a584f33191eb6dd5c6578b6b3c6130b3637c27 /lang/mono
parentf450275829895d5bc7b05b5c23e6deffc3c35b34 (diff)
downloadfreebsd-ports-f51091ad5956e3a411b095aef4fd3b11d62dc2c2.zip
- Fix shebangs
- Fix bin/rc in lang/go since we dont have it in base or a port to support it - While in lang/go remove WRKSRC for SHEBANG_FILES - Bump PORTREVISION for package change
Diffstat (limited to 'lang/mono')
-rw-r--r--lang/mono/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 1cf92e35d525..6cb5e52a6e32 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mono
PORTVERSION= 4.6.2.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= http://download.mono-project.com/sources/${PORTNAME}/
@@ -17,12 +17,14 @@ BUILD_DEPENDS= p5-XML-Parser>=0:textproc/p5-XML-Parser \
bash:shells/bash
LIB_DEPENDS= libinotify.so:devel/libinotify
-USES= bison compiler:c11 cpe gettext gmake iconv libtool pathfix perl5 tar:bzip2
+USES= bison compiler:c11 cpe gettext gmake iconv libtool pathfix \
+ perl5 python:run shebangfix tar:bzip2
USE_GNOME= glib20
USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/mono-${PORTVERSION:R}
+SHEBANG_FILES= scripts/mono-heapviz
CONFIGURE_ARGS= --disable-dtrace
CONFIGURE_ENV= ac_cv_header_sys_inotify_h=no