summaryrefslogtreecommitdiff
path: root/lang/gcc48
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2018-07-22 09:57:25 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2018-07-22 09:57:25 +0000
commitb25b5a01c79ea1cc4b902f439995e6530c255141 (patch)
tree26a367b46650ad7043e3ea1144b0c170e1cdbfb4 /lang/gcc48
parent71cf78acd76cf19a289f8bef7daa505bc300620c (diff)
downloadfreebsd-ports-b25b5a01c79ea1cc4b902f439995e6530c255141.zip
Simplify the setting of CFLAGS where /g is not necessary when substituting
a Makefile variable (since this takes place for every word in the variable, not just once).
Diffstat (limited to 'lang/gcc48')
-rw-r--r--lang/gcc48/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/lang/gcc48/Makefile b/lang/gcc48/Makefile
index fdb696fe99e1..2b2ea70ba984 100644
--- a/lang/gcc48/Makefile
+++ b/lang/gcc48/Makefile
@@ -61,7 +61,7 @@ CONFIGURE_ENV+= UNAME_m="powerpc64"
.if ${ARCH} == armv6
# Override sys.mk including -O in CFLAGS which breaks libgomp building.
-CFLAGS:= ${CFLAGS:S/-O/-O2/g}
+CFLAGS:= ${CFLAGS:S/-O/-O2/}
. if ${COMPILER_TYPE} == clang
. if empty(PORT_OPTIONS:MBOOTSTRAP)
MAKE_ARGS+=CXXFLAGS=-fbracket-depth=512