summaryrefslogtreecommitdiff
path: root/lang/basic256
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-07-15 16:32:22 +0200
committerStefan Eßer <se@FreeBSD.org>2022-07-15 16:36:23 +0200
commite62703a4ead4b64033f6f5ded7b6dc4a8a060d54 (patch)
tree9cc1b2a4b0ab2a8406292bae9ca3fe49707600b0 /lang/basic256
parent4635b27d97a60fe794686a61a82db73cb3cc7b44 (diff)
downloadfreebsd-ports-e62703a4ead4b64033f6f5ded7b6dc4a8a060d54.zip
lang/basic256: update to depend on espeak-ng instead of espeak
Approved by: portmgr (implicit)
Diffstat (limited to 'lang/basic256')
-rw-r--r--lang/basic256/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/lang/basic256/Makefile b/lang/basic256/Makefile
index 4f473d85796b..208d70bf9f5e 100644
--- a/lang/basic256/Makefile
+++ b/lang/basic256/Makefile
@@ -1,6 +1,6 @@
PORTNAME= basic256
PORTVERSION= 2.0.0.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang
MASTER_SITES= SF/kidbasic/
DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
@@ -10,9 +10,9 @@ COMMENT= Easy to use BASIC language and IDE for education
LICENSE= GPLv2
-BUILD_DEPENDS= espeak:audio/espeak \
- sqlite3:databases/sqlite3 \
- flex:textproc/flex
+BUILD_DEPENDS= flex:textproc/flex \
+ sqlite3:databases/sqlite3
+LIB_DEPENDS= libespeak-ng.so:audio/espeak-ng
USES= bison compiler:c++11-lib dos2unix gl qmake qt:5 sdl
DOS2UNIX_FILES= BASIC256.pro Interpreter.cpp
@@ -22,8 +22,11 @@ USE_SDL= sdl mixer
QMAKE_ARGS+= LOCALBASE="${LOCALBASE}"
QMAKE_SOURCE_PATH= BASIC256.pro
-MAKE_JOBS_UNSAFE= yes
+#MAKE_JOBS_UNSAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/basic256
+
.include <bsd.port.mk>