summaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2015-07-05 00:45:08 +0000
committerGreg Lewis <glewis@FreeBSD.org>2015-07-05 00:45:08 +0000
commit2722598f719cb419d42a2c6a3165d55159912882 (patch)
tree802d3d68d7b7d708a7aa99ade1762b661f501c04 /java
parentd5b14ed39b905a592ce6b5993147dfb01a02c6e0 (diff)
downloadfreebsd-ports-2722598f719cb419d42a2c6a3165d55159912882.zip
. The test target wants jtreg binaries to be found one directory up. Allow
that to be the case.
Diffstat (limited to 'java')
-rw-r--r--java/openjdk8/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index a04a0b8f1f50..c6cf55cff544 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -221,6 +221,9 @@ post-extract:
${WRKSRC}/nashorn/test/script/jfx/kaleidoscope/golden/bsd.png
@${CP} ${FILESDIR}/nashorn-test-script-jfx-spread-golden-bsd.png \
${WRKSRC}/nashorn/test/script/jfx/spread/golden/bsd.png
+.if ${PORT_OPTIONS:MTEST}
+ @${LN} -sf ${WRKDIR}/jtreg/linux/bin ${WRKDIR}/jtreg/
+.endif
post-patch:
@${FIND} ${WRKSRC} -name '*.orig' -delete