summaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-08-04 05:51:16 +0000
committerJohn Marino <marino@FreeBSD.org>2016-08-04 05:51:16 +0000
commit77e07ef19e571af541ad0b0e718811dc262c757e (patch)
tree3c752967ad81355e864110771a6cc23e47b6c002 /japanese
parent76205ead734ad9aa9880a538024e613eb3eb5547 (diff)
downloadfreebsd-ports-77e07ef19e571af541ad0b0e718811dc262c757e.zip
japanese/libtomoe-gtk: fix illegal placement of USES
USES must be defined before any inclusions like <options> or <pre>, otherwise they can't get registered as run dependencies. The presence of USES=python after <pre> was trying to build+run dependency on python conditionally based on the presence of an installed file. Since the condition can't be moved up due to the LOCALBASE variable, I've moved python up but changed it to USES+=python:build so that python will never be registered as a run dependency, but it will be available if required for building. The alternative is register python as a run dependency in every case because the port can't stay how it is. I picked the more conservative option I think. Approved by: just-fix-it
Diffstat (limited to 'japanese')
-rw-r--r--japanese/libtomoe-gtk/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/japanese/libtomoe-gtk/Makefile b/japanese/libtomoe-gtk/Makefile
index f4a5d5d3d0d8..6970b438c1c4 100644
--- a/japanese/libtomoe-gtk/Makefile
+++ b/japanese/libtomoe-gtk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= libtomoe-gtk
PORTVERSION= 0.6.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= japanese
MASTER_SITES= SF/tomoe/tomoe-gtk/tomoe-gtk-${PORTVERSION}
DISTNAME= tomoe-gtk-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
@@ -14,7 +14,7 @@ COMMENT= TOMOE GTK+ library
LIB_DEPENDS= libtomoe.so:japanese/tomoe
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig
+USES= gmake libtool pathfix pkgconfig python:build
USE_GNOME= gtk20
USE_LDCONFIG= yes
@@ -31,7 +31,6 @@ PLIST_SUB+= GUCHARMAP="@comment "
#.endif
.if exists(${LOCALBASE}/libdata/pkgconfig/pytomoe.pc)
-USES+= python
CONFIGURE_ENV+= PYTHON_VERSION=${PYTHON_VERSION:S;python;;} \
pyexecdir=${PYTHON_SITELIBDIR}
PLIST_SUB+= PYTHON=""