summaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-12-28 23:02:12 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-12-28 23:02:12 +0000
commitaa7a6c429ea62d972467d6755fa7a6f52256b452 (patch)
tree3c451883d3bd4d2ffe401b2b6aee58825505d145 /irc
parentc3b3e6a10d663bc2672cdd4bf46943046d03ecba (diff)
downloadfreebsd-ports-aa7a6c429ea62d972467d6755fa7a6f52256b452.zip
Drop python 2.7 support from a few ports
With hat: portmgr
Diffstat (limited to 'irc')
-rw-r--r--irc/py-fishcrypt/Makefile2
-rw-r--r--irc/py-irc/Makefile2
-rw-r--r--irc/py-limnoria/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/irc/py-fishcrypt/Makefile b/irc/py-fishcrypt/Makefile
index 66ad2a34a90a..7536d3bec762 100644
--- a/irc/py-fishcrypt/Makefile
+++ b/irc/py-fishcrypt/Makefile
@@ -19,7 +19,7 @@ GH_ACCOUNT= fladd
GH_PROJECT= py-${PORTNAME}
GH_TAGNAME= 43554b1a
-USES= dos2unix python:run shebangfix
+USES= dos2unix python:3.6+,run shebangfix
USE_PYTHON= flavors
SHEBANG_FILES= fishcrypt.py
NO_BUILD= yes
diff --git a/irc/py-irc/Makefile b/irc/py-irc/Makefile
index 9d98e915f171..9c24c7fd1864 100644
--- a/irc/py-irc/Makefile
+++ b/irc/py-irc/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hgtools>0:devel/py-hgtools@${PY_FLAVOR} \
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools_scm>0:devel/py-setuptools_scm@${PY_FLAVOR}
-USES= python shebangfix
+USES= python:3.6+ shebangfix
USE_PYTHON= distutils autoplist
NO_ARCH= yes
SHEBANG_FILES= irc/*.py scripts/*.py
diff --git a/irc/py-limnoria/Makefile b/irc/py-limnoria/Makefile
index 81379cada1ed..0b82abf58895 100644
--- a/irc/py-limnoria/Makefile
+++ b/irc/py-limnoria/Makefile
@@ -18,7 +18,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser@${PY_F
${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR}
-USES= python # 2.6+
+USES= python:3.6+ # 2.6+
USE_GITHUB= yes
USE_PYTHON= autoplist concurrent distutils