summaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 02:44:22 +0200
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 02:48:20 +0200
commit95274bf4f99c71fc056013d966aec239161dfd74 (patch)
treebc1e95977678cb5b6b00b33e333b28161885e706 /irc
parentdbe06d2da8c38d9d058f7939a7c6af36a2c0f1c7 (diff)
downloadfreebsd-ports-95274bf4f99c71fc056013d966aec239161dfd74.zip
*/*: Fix build with llvm16 on 13.2-STABLE
As like as HEAD(14.0-RELEASE) llvm16 was merged in base for 13.2-STABLE with the OSVERSION 1302507. - Utilize USE_CXXSTD=c++14 or similar solution where applicable - Update conditionals to addtionally check for OSVERSION greater than 1302507 and less than 1400000 Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'irc')
-rw-r--r--irc/bitchx/Makefile2
-rw-r--r--irc/scrollz/Makefile5
2 files changed, 3 insertions, 4 deletions
diff --git a/irc/bitchx/Makefile b/irc/bitchx/Makefile
index 45c71ac286d5..ce71b9320344 100644
--- a/irc/bitchx/Makefile
+++ b/irc/bitchx/Makefile
@@ -48,7 +48,7 @@ PLUGIN_LIST= abot acro arcfour autocycle blowfish cavlink cdrom encrypt \
.include <bsd.port.options.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
diff --git a/irc/scrollz/Makefile b/irc/scrollz/Makefile
index ff31780f816d..ec5c0b7a511a 100644
--- a/irc/scrollz/Makefile
+++ b/irc/scrollz/Makefile
@@ -41,11 +41,10 @@ UTF8_CONFIGURE_ENABLE= utf8
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400079 || ( ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=int-conversion
-.endif
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 )
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
+.endif
.if !empty(ICONV_LIB)
CONFIGURE_ENV+=ac_cv_func_iconv_open=yes