summaryrefslogtreecommitdiff
path: root/irc
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-06-15 00:00:28 +0200
committerRene Ladan <rene@FreeBSD.org>2023-06-27 21:34:34 +0200
commit3d9a815d9c5acbb71f4bb07738bdeab4879feacb (patch)
treeeb093f22197a2c68a88dd2372ec1922c3f6d3c10 /irc
parentc58ef91e06e8edc4fd8579837f1453b562da3fbb (diff)
downloadfreebsd-ports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.zip
all: remove explicit versions in USES=python for "3.x+"
The logic in USES=python will automatically convert this to 3.8+ by itself. Adjust two ports that only had Python 3.7 mentioned but build fine on Python 3.8 too. finance/quickfix: mark BROKEN with PYTHON libtool: compile: c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++ -DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable -Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi -Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings -Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x -MT _quickfix_la-QuickfixPython.lo -MD -MP -MF .deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp -fPIC -DPIC -o .libs/_quickfix_la-QuickfixPython.o warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean '-Wno-uninitialized'? [-Wunknown-warning-option] QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found ^~~~~~~~~~ 1 warning and 1 error generated. Reviewed by: portmgr, vishwin, yuri Differential Revision: <https://reviews.freebsd.org/D40568>
Diffstat (limited to 'irc')
-rw-r--r--irc/hexchat/Makefile2
-rw-r--r--irc/py-irc/Makefile2
-rw-r--r--irc/py-limnoria/Makefile2
-rw-r--r--irc/py-sopel/Makefile2
-rw-r--r--irc/znc/Makefile2
5 files changed, 5 insertions, 5 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index 8c71d7c0cb85..04a373677304 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libproxy.so:net/libproxy \
RUN_DEPENDS= ${LOCALBASE}/share/xml/iso-codes/iso_639.xml:misc/iso-codes
USES= compiler:c++11-lang cpe desktop-file-utils gettext-tools gnome \
- libtool localbase meson ninja pkgconfig python:3.5+ shebangfix \
+ libtool localbase meson ninja pkgconfig python shebangfix \
ssl tar:xz xorg
CPE_VENDOR= ${PORTNAME}_project
SHEBANG_FILES= meson_post_install.py \
diff --git a/irc/py-irc/Makefile b/irc/py-irc/Makefile
index 2906ad26eb50..acc248a27175 100644
--- a/irc/py-irc/Makefile
+++ b/irc/py-irc/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jaraco.functools>=1.20:devel/py-jaraco.funct
${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tempora>=1.6:devel/py-tempora@${PY_FLAVOR}
-USES= python:3.7+ shebangfix
+USES= python shebangfix
USE_PYTHON= autoplist distutils pytest
SHEBANG_FILES= irc/*.py scripts/*.py
diff --git a/irc/py-limnoria/Makefile b/irc/py-limnoria/Makefile
index 8f120dad3476..312e873c7900 100644
--- a/irc/py-limnoria/Makefile
+++ b/irc/py-limnoria/Makefile
@@ -17,7 +17,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=0:textproc/py-feedparser@${PY_F
${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR}
-USES= cpe python:3.6+
+USES= cpe python
CPE_VENDOR= ${PORTNAME}_project
USE_GITHUB= yes
GH_ACCOUNT= ProgVal
diff --git a/irc/py-sopel/Makefile b/irc/py-sopel/Makefile
index a083e5d21d19..d9d985da2f0c 100644
--- a/irc/py-sopel/Makefile
+++ b/irc/py-sopel/Makefile
@@ -26,7 +26,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py-dnspython@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}xmltodict>=0.12:devel/py-xmltodict@${PY_FLAVOR}
-USES= python:3.8+
+USES= python
USE_PYTHON= autoplist distutils
USE_RC_SUBR= sopel
diff --git a/irc/znc/Makefile b/irc/znc/Makefile
index f4773f257581..a1c260dc45dc 100644
--- a/irc/znc/Makefile
+++ b/irc/znc/Makefile
@@ -16,7 +16,7 @@ WWW= https://wiki.znc.in/ZNC
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= compiler:c++11-lib cpe cmake:run iconv pathfix pkgconfig python:3.5+
+USES= compiler:c++11-lib cpe cmake:run iconv pathfix pkgconfig python
USE_RC_SUBR= znc