summaryrefslogtreecommitdiff
path: root/irc/weechat/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2016-01-16 14:20:15 +0000
committerPawel Pekala <pawel@FreeBSD.org>2016-01-16 14:20:15 +0000
commitcda7492eb9c2ff08ce9c553ccd567da5c840a7f8 (patch)
treecc6334dfd048e08649e92c1d018cd98bd14bf494 /irc/weechat/Makefile
parenta38f734e65a59d0ac3f820c7ecdd129cc9c93b2f (diff)
downloadfreebsd-ports-cda7492eb9c2ff08ce9c553ccd567da5c840a7f8.zip
- Switch to USES=execinfo localbase
- USES=localbase conversion fixes detection of libexecinfo on FreeBSD 10+ PR: 205760 Submitted by: myself Approved by: maintainer timeout
Diffstat (limited to 'irc/weechat/Makefile')
-rw-r--r--irc/weechat/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index fcde6f72fdfb..d7bc4509a685 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -14,10 +14,9 @@ LICENSE= GPLv3
CONFLICTS= weechat-devel-[0-9]*
USE_LDCONFIG= yes
-USES= cmake iconv ncurses tar:bzip2
+USES= cmake iconv localbase ncurses tar:bzip2
CMAKE_ARGS+= -DENABLE_GUILE=no \
-DICONV_INCLUDE_PATH=${ICONV_INCLUDE_PATH}
-CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
LIB_DEPENDS+= libcurl.so:ftp/curl \
libgcrypt.so:security/libgcrypt
@@ -40,7 +39,7 @@ RUBY_DESC= Ruby scripting language support
ASPELL_CMAKE_OFF= -DENABLE_ASPELL=no
ASPELL_LIB_DEPENDS= libaspell.so:textproc/aspell
-BACKTRACE_LIB_DEPENDS= libexecinfo.so:devel/libexecinfo
+BACKTRACE_USES= execinfo
CA_BUNDLE_CMAKE_ON= -DCA_FILE=${LOCALBASE}/share/certs/ca-root-nss.crt
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss