summaryrefslogtreecommitdiff
path: root/irc/weechat/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2016-01-12 17:39:03 +0000
committerRenato Botelho <garga@FreeBSD.org>2016-01-12 17:39:03 +0000
commit90c4c950e9e5f5eaa5ed3c9af65b5e82033f7cf2 (patch)
treeabdf3c53f61069501dc5a8ea02836e267c43f6b6 /irc/weechat/Makefile
parent2cdd0b0a51e3a5ad9fc40e8700852e112ad126f9 (diff)
downloadfreebsd-ports-90c4c950e9e5f5eaa5ed3c9af65b5e82033f7cf2.zip
Update irc/weechat to 1.4
Diffstat (limited to 'irc/weechat/Makefile')
-rw-r--r--irc/weechat/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/irc/weechat/Makefile b/irc/weechat/Makefile
index d22edd7b8506..fcde6f72fdfb 100644
--- a/irc/weechat/Makefile
+++ b/irc/weechat/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= weechat
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= irc
MASTER_SITES= http://weechat.org/files/src/
@@ -19,8 +19,8 @@ CMAKE_ARGS+= -DENABLE_GUILE=no \
-DICONV_INCLUDE_PATH=${ICONV_INCLUDE_PATH}
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-LIB_DEPENDS+= libcurl.so:${PORTSDIR}/ftp/curl \
- libgcrypt.so:${PORTSDIR}/security/libgcrypt
+LIB_DEPENDS+= libcurl.so:ftp/curl \
+ libgcrypt.so:security/libgcrypt
OPTIONS_DEFINE= RUBY PYTHON PERL TCL LUA JAVASCRIPT CHARSET BACKTRACE ASPELL \
GNUTLS CA_BUNDLE NLS ICON MANPAGES DOCS
@@ -38,12 +38,12 @@ PYTHON_DESC= Python scripting language support
RUBY_DESC= Ruby scripting language support
ASPELL_CMAKE_OFF= -DENABLE_ASPELL=no
-ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
+ASPELL_LIB_DEPENDS= libaspell.so:textproc/aspell
-BACKTRACE_LIB_DEPENDS= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
+BACKTRACE_LIB_DEPENDS= libexecinfo.so:devel/libexecinfo
CA_BUNDLE_CMAKE_ON= -DCA_FILE=${LOCALBASE}/share/certs/ca-root-nss.crt
-CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss
+CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
CHARSET_CMAKE_OFF= -DENABLE_CHARSET=no
@@ -51,11 +51,11 @@ DOCS_CMAKE_ON= -DENABLE_DOC=yes
JAVASCRIPT_CMAKE_OFF= -DENABLE_JAVASCRIPT=no
JAVASCRIPT_CMAKE_ON= -DENABLE_JAVASCRIPT=yes
-JAVASCRIPT_LIB_DEPENDS= libv8.so:${PORTSDIR}/lang/v8
+JAVASCRIPT_LIB_DEPENDS= libv8.so:lang/v8
GNUTLS_CMAKE_OFF= -DENABLE_GNUTLS=no
GNUTLS_USES= pkgconfig
-GNUTLS_LIB_DEPENDS= libgnutls.so.28:${PORTSDIR}/security/gnutls
+GNUTLS_LIB_DEPENDS= libgnutls.so.28:security/gnutls
LUA_CMAKE_OFF= -DENABLE_LUA=no
LUA_CMAKE_ON= -DBSD_LUA_LIBDIR=${LUA_LIBDIR} \
@@ -90,10 +90,10 @@ TCL_USES= tcl:85+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS} || ${PORT_OPTIONS:MMANPAGES}
-BUILD_DEPENDS+= xsltproc:${PORTSDIR}/textproc/libxslt \
- docbook-xsl>=0:${PORTSDIR}/textproc/docbook-xsl \
- asciidoc:${PORTSDIR}/textproc/asciidoc \
- source-highlight>=3.1.5:${PORTSDIR}/textproc/source-highlight
+BUILD_DEPENDS+= xsltproc:textproc/libxslt \
+ docbook-xsl>=0:textproc/docbook-xsl \
+ asciidoc:textproc/asciidoc \
+ source-highlight>=3.1.5:textproc/source-highlight
.endif
post-patch: