summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-06-16 16:05:28 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-06-16 16:05:28 +0000
commite19903f0aea4d3e3b020dfeb7917e5da969abe6f (patch)
treeaf3dcd22e084ce9821b354f102726fb6b290181e /graphics
parenta8386f0b2645ad78a65832daf838a5a141c4e907 (diff)
downloadfreebsd-ports-e19903f0aea4d3e3b020dfeb7917e5da969abe6f.zip
Clean up LIB_DEPENDS
Diffstat (limited to 'graphics')
-rw-r--r--graphics/aeskulap/Makefile2
-rw-r--r--graphics/dcmtk/Makefile2
-rw-r--r--graphics/electricsheep/Makefile2
-rw-r--r--graphics/flif/Makefile2
-rw-r--r--graphics/libheif/Makefile2
-rw-r--r--graphics/luminance-qt5/Makefile2
-rw-r--r--graphics/magnum-extras/Makefile2
-rw-r--r--graphics/magnum-plugins/Makefile2
-rw-r--r--graphics/open3d/Makefile2
-rw-r--r--graphics/vv/Makefile2
-rw-r--r--graphics/yafaray/Makefile2
11 files changed, 11 insertions, 11 deletions
diff --git a/graphics/aeskulap/Makefile b/graphics/aeskulap/Makefile
index 70c1ac0e63cd..3226c979c021 100644
--- a/graphics/aeskulap/Makefile
+++ b/graphics/aeskulap/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libdcmimage.so:graphics/dcmtk \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libglademm-2.4.so:devel/libglademm24 \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= compiler:c++11-lang autoreconf desktop-file-utils gettext \
diff --git a/graphics/dcmtk/Makefile b/graphics/dcmtk/Makefile
index ade8b4fa0d8c..aef0640b6b03 100644
--- a/graphics/dcmtk/Makefile
+++ b/graphics/dcmtk/Makefile
@@ -14,7 +14,7 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libicuuc.so:devel/icu \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= compiler:c++11-lang cmake gnome jpeg ssl
diff --git a/graphics/electricsheep/Makefile b/graphics/electricsheep/Makefile
index 52057aecc421..719d0be97a9f 100644
--- a/graphics/electricsheep/Makefile
+++ b/graphics/electricsheep/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libavcodec.so:multimedia/ffmpeg \
libGLee.so:graphics/glee \
libgtop-2.0.so:devel/libgtop \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtinyxml.so:textproc/tinyxml
RUN_DEPENDS= flam3-animate:graphics/flam3
diff --git a/graphics/flif/Makefile b/graphics/flif/Makefile
index 672a860128d6..90c13cc37948 100644
--- a/graphics/flif/Makefile
+++ b/graphics/flif/Makefile
@@ -12,7 +12,7 @@ COMMENT= Free Lossless Image Format
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/../LICENSE_Apache2
-LIB_DEPENDS= libpng16.so:graphics/png
+LIB_DEPENDS= libpng.so:graphics/png
USES= cmake compiler:c++11-lang gettext-runtime gnome localbase:ldflags pkgconfig sdl shared-mime-info
USE_GITHUB= yes
diff --git a/graphics/libheif/Makefile b/graphics/libheif/Makefile
index 61bc98126e29..884ff1cdb323 100644
--- a/graphics/libheif/Makefile
+++ b/graphics/libheif/Makefile
@@ -50,7 +50,7 @@ LIB_DEPENDS+= libde265.so:multimedia/libde265
.endif
.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= libpng16.so:graphics/png
+LIB_DEPENDS+= libpng.so:graphics/png
.endif
.if ${PORT_OPTIONS:MX265}
diff --git a/graphics/luminance-qt5/Makefile b/graphics/luminance-qt5/Makefile
index ac23600f36e2..be8730a1e59d 100644
--- a/graphics/luminance-qt5/Makefile
+++ b/graphics/luminance-qt5/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libgsl.so:math/gsl \
libexiv2.so:graphics/exiv2 \
liblcms2.so:graphics/lcms2 \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libIlmImf.so:graphics/openexr \
libboost_date_time.so:devel/boost-libs
diff --git a/graphics/magnum-extras/Makefile b/graphics/magnum-extras/Makefile
index d1bb7ca80484..dcc8f3ee17e4 100644
--- a/graphics/magnum-extras/Makefile
+++ b/graphics/magnum-extras/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libassimp.so:multimedia/assimp \
libfreetype.so:print/freetype2 \
libIL.so:graphics/devil \
libMagnum.so:graphics/magnum \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= cmake compiler:c++14-lang gl
USE_GITHUB= yes
diff --git a/graphics/magnum-plugins/Makefile b/graphics/magnum-plugins/Makefile
index 1f3eb5b1772d..537ac2123d00 100644
--- a/graphics/magnum-plugins/Makefile
+++ b/graphics/magnum-plugins/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libassimp.so:multimedia/assimp \
libfreetype.so:print/freetype2 \
libIL.so:graphics/devil \
libMagnum.so:graphics/magnum \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= cmake compiler:c++14-lang gl jpeg openal
USE_GITHUB= yes
diff --git a/graphics/open3d/Makefile b/graphics/open3d/Makefile
index 67dd77085348..27fed48fef2e 100644
--- a/graphics/open3d/Makefile
+++ b/graphics/open3d/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/../LICENSE
LIB_DEPENDS= libglfw.so:graphics/glfw \
libjsoncpp.so:devel/jsoncpp \
- libpng16.so:graphics/png
+ libpng.so:graphics/png
USES= cmake compiler:c++14-lang eigen:3 jpeg localbase:ldflags pkgconfig
USE_GITHUB= yes
diff --git a/graphics/vv/Makefile b/graphics/vv/Makefile
index 86fe32ec8dd1..f473a7761a85 100644
--- a/graphics/vv/Makefile
+++ b/graphics/vv/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libexpat.so:textproc/expat2 \
libgdcmCommon.so:devel/gdcm \
libhdf5_cpp.so:science/hdf5 \
libITKLabelMap-4.13.so:science/InsightToolkit \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libsz.so:science/szip \
libtiff.so:graphics/tiff \
libvtkIOSQL-8.1.so:math/vtk8
diff --git a/graphics/yafaray/Makefile b/graphics/yafaray/Makefile
index ff2411e58d87..e272bb25c18b 100644
--- a/graphics/yafaray/Makefile
+++ b/graphics/yafaray/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libIlmImf.so:graphics/openexr \
libopencv_photo.so:graphics/opencv \
libopencv_core.so:graphics/opencv-core \
- libpng16.so:graphics/png \
+ libpng.so:graphics/png \
libtiff.so:graphics/tiff
USES= cmake gnome jpeg