summaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2019-06-08 15:59:46 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2019-06-08 15:59:46 +0000
commitbb5cf6c4f3c10d3eff9b5891aa38093e483e4a60 (patch)
tree0dd599c3bd3c385b989cd2ccb511ac9a39bb8c32 /graphics
parent4bafa67ea0cfc5c54e5d698ef3aeaff8cd3115ad (diff)
downloadfreebsd-ports-bb5cf6c4f3c10d3eff9b5891aa38093e483e4a60.zip
Address some portlint warnings in the Linux infrastructure ports.
Eliminate LINUXNAME from port Makefiles. This was just a helper variable without special meaning outside port Makefiles but several developers have copied it to new ports where it was then unused, apparently thinking that it did have some special meaning.
Diffstat (limited to 'graphics')
-rw-r--r--graphics/linux-c6-cairo/Makefile3
-rw-r--r--graphics/linux-c6-dri/Makefile17
-rw-r--r--graphics/linux-c6-gdk-pixbuf2/Makefile3
-rw-r--r--graphics/linux-c6-glx-utils/Makefile3
-rw-r--r--graphics/linux-c6-jasper/Makefile7
-rw-r--r--graphics/linux-c6-jpeg/Makefile8
-rw-r--r--graphics/linux-c6-png/Makefile3
-rw-r--r--graphics/linux-c6-sdl_image/Makefile8
-rw-r--r--graphics/linux-c6-sdl_ttf/Makefile8
-rw-r--r--graphics/linux-c6-tiff/Makefile3
-rw-r--r--graphics/linux-c7-cairo/Makefile6
-rw-r--r--graphics/linux-c7-dri/Makefile17
-rw-r--r--graphics/linux-c7-gdk-pixbuf2/Makefile6
-rw-r--r--graphics/linux-c7-glx-utils/Makefile7
-rw-r--r--graphics/linux-c7-graphite2/Makefile3
-rw-r--r--graphics/linux-c7-jasper/Makefile9
-rw-r--r--graphics/linux-c7-jbigkit/Makefile9
-rw-r--r--graphics/linux-c7-jpeg/Makefile11
-rw-r--r--graphics/linux-c7-libglvnd/Makefile11
-rw-r--r--graphics/linux-c7-png/Makefile6
-rw-r--r--graphics/linux-c7-sdl_image/Makefile12
-rw-r--r--graphics/linux-c7-sdl_ttf/Makefile12
-rw-r--r--graphics/linux-c7-tiff/Makefile6
-rw-r--r--graphics/linux-c7-wayland/Makefile12
24 files changed, 102 insertions, 88 deletions
diff --git a/graphics/linux-c6-cairo/Makefile b/graphics/linux-c6-cairo/Makefile
index d5a03114bc92..e0620253db6c 100644
--- a/graphics/linux-c6-cairo/Makefile
+++ b/graphics/linux-c6-cairo/Makefile
@@ -10,12 +10,13 @@ CATEGORIES= graphics linux
MAINTAINER= emulation@FreeBSD.org
COMMENT= Vector graphics library Cairo (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
USES= linux:c6
USE_LDCONFIG= yes
USE_LINUX= fontconfig pixman png xorglibs
USE_LINUX_RPM= yes
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c6-dri/Makefile b/graphics/linux-c6-dri/Makefile
index a7d7809ef6c3..cedfd80dbf0a 100644
--- a/graphics/linux-c6-dri/Makefile
+++ b/graphics/linux-c6-dri/Makefile
@@ -6,6 +6,15 @@ PORTVERSION= 11.0.7
DISTVERSIONSUFFIX= -4.el6
PORTREVISION= 5
CATEGORIES= graphics linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Mesa libGL runtime libraries (Linux CentOS ${LINUX_DIST_VER})
+
+USES= linux:c6
+USE_LDCONFIG= yes
+USE_LINUX= expat libelf libpciaccess xorglibs
+USE_LINUX_RPM= yes
+
LIB_DISTNAMES= mesa-libGL-${DISTVERSIONFULL} \
mesa-libGLU-${DISTVERSIONFULL} \
mesa-dri-drivers-${DISTVERSIONFULL} \
@@ -17,14 +26,6 @@ SRC_DISTFILES= mesa-${DISTVERSIONFULL}${SRC_SUFX}:SOURCE \
libdrm-2.4.65-2.el6${SRC_SUFX}:SOURCE \
freeglut-2.6.0-1.el6${SRC_SUFX}:SOURCE
-MAINTAINER= emulation@FreeBSD.org
-COMMENT= Mesa libGL runtime libraries (Linux CentOS ${LINUX_DIST_VER})
-
-USES= linux:c6
-USE_LDCONFIG= yes
-USE_LINUX= expat libelf libpciaccess xorglibs
-USE_LINUX_RPM= yes
-
post-install:
@${RM} ${STAGEDIR}${PREFIX}/usr/lib/libGL.so.1
@${RM} ${STAGEDIR}${PREFIX}/usr/lib64/libGL.so.1
diff --git a/graphics/linux-c6-gdk-pixbuf2/Makefile b/graphics/linux-c6-gdk-pixbuf2/Makefile
index f4d892820e01..5ab799bb096b 100644
--- a/graphics/linux-c6-gdk-pixbuf2/Makefile
+++ b/graphics/linux-c6-gdk-pixbuf2/Makefile
@@ -10,12 +10,13 @@ CATEGORIES= graphics linux
MAINTAINER= emulation@FreeBSD.org
COMMENT= Graphic library for GTK+ (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
USES= linux:c6
USE_LDCONFIG= yes
USE_LINUX= jasper jpeg png tiff xorglibs
USE_LINUX_RPM= yes
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
diff --git a/graphics/linux-c6-glx-utils/Makefile b/graphics/linux-c6-glx-utils/Makefile
index d96b8b52be02..458d598548fa 100644
--- a/graphics/linux-c6-glx-utils/Makefile
+++ b/graphics/linux-c6-glx-utils/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 11.0.7
DISTVERSIONSUFFIX= -4.el6
PORTREVISION= 3
CATEGORIES= graphics linux
-SRC_DISTFILES= mesa-${DISTVERSIONFULL}${SRC_SUFX}:SOURCE
MAINTAINER= emulation@FreeBSD.org
COMMENT= Mesa GLX utilities (Linux CentOS ${LINUX_DIST_VER})
@@ -16,4 +15,6 @@ USE_LDCONFIG= yes
USE_LINUX= dri xorglibs
USE_LINUX_RPM= nolib
+SRC_DISTFILES= mesa-${DISTVERSIONFULL}${SRC_SUFX}:SOURCE
+
.include <bsd.port.mk>
diff --git a/graphics/linux-c6-jasper/Makefile b/graphics/linux-c6-jasper/Makefile
index 7752e990c764..df2844c3e5bc 100644
--- a/graphics/linux-c6-jasper/Makefile
+++ b/graphics/linux-c6-jasper/Makefile
@@ -6,16 +6,17 @@ DISTVERSIONSUFFIX= -22.el6
PORTREVISION= 5
CATEGORIES= graphics linux
PKGNAMESUFFIX= -libs
-LIB_DISTNAMES= ${LINUXNAME}-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= JPEG-2000 reference implementation (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-LINUXNAME= ${PORTNAME}${PKGNAMESUFFIX}
USES= linux:c6
USE_LDCONFIG= yes
USE_LINUX= jpeg
USE_LINUX_RPM= yes
+LIB_DISTNAMES= ${PORTNAME}${PKGNAMESUFFIX}-${DISTVERSIONFULL}
+
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
.include <bsd.port.mk>
diff --git a/graphics/linux-c6-jpeg/Makefile b/graphics/linux-c6-jpeg/Makefile
index 5ce6fb7f50c3..4c6cab44a0aa 100644
--- a/graphics/linux-c6-jpeg/Makefile
+++ b/graphics/linux-c6-jpeg/Makefile
@@ -6,18 +6,18 @@ PORTVERSION= 1.2.1
DISTVERSIONSUFFIX= -3.el6_5
PORTREVISION= 3
CATEGORIES= graphics linux
-DISTNAME= ${LINUXNAME}-${DISTVERSIONFULL}
+DISTNAME= libjpeg-turbo-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= SIMD-accelerated JPEG codec (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../${PORTNAME}-turbo/pkg-descr
-DOCSDIR= ${PREFIX}/usr/share/doc/${LINUXNAME}-${PORTVERSION}
-LINUXNAME= libjpeg-turbo
USES= linux:c6
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
+DESCR= ${.CURDIR}/../${PORTNAME}-turbo/pkg-descr
+DOCSDIR= ${PREFIX}/usr/share/doc/libjpeg-turbo-${PORTVERSION}
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c6-png/Makefile b/graphics/linux-c6-png/Makefile
index 737628dba119..2112da57f650 100644
--- a/graphics/linux-c6-png/Makefile
+++ b/graphics/linux-c6-png/Makefile
@@ -10,11 +10,12 @@ CATEGORIES= graphics linux
MAINTAINER= emulation@FreeBSD.org
COMMENT= Library for manipulating PNG images (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../png/pkg-descr
USES= linux:c6
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
+DESCR= ${.CURDIR}/../png/pkg-descr
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c6-sdl_image/Makefile b/graphics/linux-c6-sdl_image/Makefile
index bce72abaa94a..0a489f7c13ca 100644
--- a/graphics/linux-c6-sdl_image/Makefile
+++ b/graphics/linux-c6-sdl_image/Makefile
@@ -7,19 +7,19 @@ DISTVERSIONSUFFIX= -9.el6
PORTREVISION= 5
CATEGORIES= graphics linux
MASTER_SITES= EPEL/s
-DISTNAME= ${LINUXNAME}-${DISTVERSIONFULL}
+DISTNAME= SDL_image-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Simple library to load images as SDL interfaces (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-DOCSDIR= ${PREFIX}/usr/share/doc/${LINUXNAME}-${PORTVERSION}
-LINUXNAME= SDL_image
USES= linux:c6
USE_LDCONFIG= yes
USE_LINUX= jpeg png sdl12 tiff
USE_LINUX_RPM= yes
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DOCSDIR= ${PREFIX}/usr/share/doc/SDL_image-${PORTVERSION}
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c6-sdl_ttf/Makefile b/graphics/linux-c6-sdl_ttf/Makefile
index 920257831ce0..93901f6bc618 100644
--- a/graphics/linux-c6-sdl_ttf/Makefile
+++ b/graphics/linux-c6-sdl_ttf/Makefile
@@ -7,19 +7,19 @@ DISTVERSIONSUFFIX= -6.el6
PORTREVISION= 4
CATEGORIES= graphics linux
MASTER_SITES= EPEL/s
-DISTNAME= ${LINUXNAME}-${DISTVERSIONFULL}
+DISTNAME= SDL_ttf-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Simple library to load True Type Fonts as SDL interfaces (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-DOCSDIR= ${PREFIX}/usr/share/doc/${LINUXNAME}-${PORTVERSION}
-LINUXNAME= SDL_ttf
USES= linux:c6
USE_LDCONFIG= yes
USE_LINUX= jpeg png sdl12 tiff
USE_LINUX_RPM= yes
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DOCSDIR= ${PREFIX}/usr/share/doc/SDL_ttf-${PORTVERSION}
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c6-tiff/Makefile b/graphics/linux-c6-tiff/Makefile
index 9fc6520534c8..20483cb5602b 100644
--- a/graphics/linux-c6-tiff/Makefile
+++ b/graphics/linux-c6-tiff/Makefile
@@ -12,12 +12,13 @@ COMMENT= Tools and library routines for working with TIFF images (Linux CentOS $
LICENSE= BSD3CLAUSE
-DESCR= ${.CURDIR}/../tiff/pkg-descr
USES= linux:c6
USE_LDCONFIG= yes
USE_LINUX= jpeg
USE_LINUX_RPM= yes
+DESCR= ${.CURDIR}/../tiff/pkg-descr
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-cairo/Makefile b/graphics/linux-c7-cairo/Makefile
index d4ea07a7a115..c6d88279e592 100644
--- a/graphics/linux-c7-cairo/Makefile
+++ b/graphics/linux-c7-cairo/Makefile
@@ -9,14 +9,14 @@ CATEGORIES= graphics linux
MAINTAINER= emulation@FreeBSD.org
COMMENT= Vector graphics library Cairo (Linux CentOS ${LINUX_DIST_VER})
-CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
-
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX= dri fontconfig pixman png xorglibs
USE_LINUX_RPM= yes
+CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-dri/Makefile b/graphics/linux-c7-dri/Makefile
index 9949033fabae..2d9275e89e44 100644
--- a/graphics/linux-c7-dri/Makefile
+++ b/graphics/linux-c7-dri/Makefile
@@ -5,6 +5,15 @@ PORTNAME= dri
PORTVERSION= 18.0.5
DISTVERSIONSUFFIX= -4.el7_6
CATEGORIES= graphics linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Mesa libGL runtime libraries (Linux CentOS ${LINUX_DIST_VER})
+
+USES= linux:c7
+USE_LDCONFIG= yes
+USE_LINUX= expat libelf libglvnd libpciaccess wayland xorglibs
+USE_LINUX_RPM= yes
+
LIB_DISTNAMES= freeglut-3.0.0-8.el7 \
libdrm-2.4.91-3.el7 \
llvm-private-6.0.1-2.el7 \
@@ -28,16 +37,8 @@ SRC_DISTFILES= freeglut-3.0.0-8.el7${SRC_SUFX}:SOURCE \
mesa-${DISTVERSIONFULL}${SRC_SUFX}:SOURCE \
mesa-libGLU-9.0.0-4.el7${SRC_SUFX}:SOURCE
-MAINTAINER= emulation@FreeBSD.org
-COMMENT= Mesa libGL runtime libraries (Linux CentOS ${LINUX_DIST_VER})
-
CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
-USES= linux:c7
-USE_LDCONFIG= yes
-USE_LINUX= expat libelf libglvnd libpciaccess wayland xorglibs
-USE_LINUX_RPM= yes
-
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
diff --git a/graphics/linux-c7-gdk-pixbuf2/Makefile b/graphics/linux-c7-gdk-pixbuf2/Makefile
index fba3dff5f08b..7275e9dab274 100644
--- a/graphics/linux-c7-gdk-pixbuf2/Makefile
+++ b/graphics/linux-c7-gdk-pixbuf2/Makefile
@@ -9,14 +9,14 @@ CATEGORIES= graphics linux
MAINTAINER= emulation@FreeBSD.org
COMMENT= Graphic library for GTK+ (Linux CentOS ${LINUX_DIST_VER})
-CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
-
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX= jasper jpeg png tiff xorglibs
USE_LINUX_RPM= yes
+CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
diff --git a/graphics/linux-c7-glx-utils/Makefile b/graphics/linux-c7-glx-utils/Makefile
index 2d2cfd62c147..632c153c8dfe 100644
--- a/graphics/linux-c7-glx-utils/Makefile
+++ b/graphics/linux-c7-glx-utils/Makefile
@@ -5,16 +5,17 @@ PORTNAME= glx-utils
PORTVERSION= 8.3.0
DISTVERSIONSUFFIX= -10.el7
CATEGORIES= graphics linux
-SRC_DISTFILES= mesa-demos-${DISTVERSIONFULL}${SRC_SUFX}:SOURCE
MAINTAINER= emulation@FreeBSD.org
COMMENT= Mesa GLX utilities (Linux CentOS ${LINUX_DIST_VER})
-CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
-
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX= dri xorglibs
USE_LINUX_RPM= nolib
+SRC_DISTFILES= mesa-demos-${DISTVERSIONFULL}${SRC_SUFX}:SOURCE
+
+CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
+
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-graphite2/Makefile b/graphics/linux-c7-graphite2/Makefile
index c809f9b6f71c..ce7dbcf31f11 100644
--- a/graphics/linux-c7-graphite2/Makefile
+++ b/graphics/linux-c7-graphite2/Makefile
@@ -9,11 +9,12 @@ CATEGORIES= graphics linux
MAINTAINER= emulation@FreeBSD.org
COMMENT= Rendering capabilities for complex non-Roman writing systems (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-jasper/Makefile b/graphics/linux-c7-jasper/Makefile
index a5e22ba8fa6e..258d9cfd41fc 100644
--- a/graphics/linux-c7-jasper/Makefile
+++ b/graphics/linux-c7-jasper/Makefile
@@ -7,19 +7,20 @@ DISTVERSIONSUFFIX= -33.el7
PORTREVISION= 5
CATEGORIES= graphics linux
PKGNAMESUFFIX= -libs
-LIB_DISTNAMES= ${LINUXNAME}-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= JPEG-2000 reference implementation (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-DOCSDIR= ${PREFIX}/usr/share/doc/${LINUXNAME}-${PORTVERSION}
-LINUXNAME= ${PORTNAME}${PKGNAMESUFFIX}
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX= jpeg
USE_LINUX_RPM= yes
+LIB_DISTNAMES= ${PORTNAME}${PKGNAMESUFFIX}-${DISTVERSIONFULL}
+
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-jbigkit/Makefile b/graphics/linux-c7-jbigkit/Makefile
index 21bbd5766560..18270098a6cd 100644
--- a/graphics/linux-c7-jbigkit/Makefile
+++ b/graphics/linux-c7-jbigkit/Makefile
@@ -7,18 +7,19 @@ DISTVERSIONSUFFIX= -11.el7
PORTREVISION= 2
CATEGORIES= graphics linux
PKGNAMESUFFIX= -libs
-LIB_DISTNAMES= ${LINUXNAME}-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Lossless compression for bi-level images (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-DOCSDIR= ${PREFIX}/usr/share/doc/${LINUXNAME}-${PORTVERSION}
-LINUXNAME= ${PORTNAME}${PKGNAMESUFFIX}
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
+LIB_DISTNAMES= ${PORTNAME}${PKGNAMESUFFIX}-${DISTVERSIONFULL}
+
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DOCSDIR= ${PREFIX}/usr/share/doc/${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-jpeg/Makefile b/graphics/linux-c7-jpeg/Makefile
index 9289129f47e2..de0624db7d69 100644
--- a/graphics/linux-c7-jpeg/Makefile
+++ b/graphics/linux-c7-jpeg/Makefile
@@ -6,20 +6,19 @@ PORTVERSION= 1.2.90
DISTVERSIONSUFFIX= -6.el7
PORTREVISION= 3
CATEGORIES= graphics linux
-DISTNAME= ${LINUXNAME}-${DISTVERSIONFULL}
+DISTNAME= libjpeg-turbo-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= SIMD-accelerated JPEG codec (Linux CentOS ${LINUX_DIST_VER})
-CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
-
-DESCR= ${.CURDIR}/../${PORTNAME}-turbo/pkg-descr
-DOCSDIR= ${PREFIX}/usr/share/doc/${LINUXNAME}-${PORTVERSION}
-LINUXNAME= libjpeg-turbo
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
+CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
+DESCR= ${.CURDIR}/../${PORTNAME}-turbo/pkg-descr
+DOCSDIR= ${PREFIX}/usr/share/doc/libjpeg-turbo-${PORTVERSION}
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-libglvnd/Makefile b/graphics/linux-c7-libglvnd/Makefile
index 603c8ef43214..56ed76c4dfc7 100644
--- a/graphics/linux-c7-libglvnd/Makefile
+++ b/graphics/linux-c7-libglvnd/Makefile
@@ -4,11 +4,6 @@ PORTNAME= libglvnd
PORTVERSION= 1.0.1
DISTVERSIONSUFFIX= -0.8.git5baa1e5.el7
CATEGORIES= graphics linux
-LIB_DISTNAMES= libglvnd-${DISTVERSIONFULL} \
- libglvnd-egl-${DISTVERSIONFULL} \
- libglvnd-gles-${DISTVERSIONFULL} \
- libglvnd-glx-${DISTVERSIONFULL} \
- libglvnd-opengl-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= GL Vendor-Neutral Dispatch library (Linux CentOS ${LINUX_DIST_VER})
@@ -18,6 +13,12 @@ USE_LDCONFIG= yes
USE_LINUX= xorglibs
USE_LINUX_RPM= yes
+LIB_DISTNAMES= libglvnd-${DISTVERSIONFULL} \
+ libglvnd-egl-${DISTVERSIONFULL} \
+ libglvnd-gles-${DISTVERSIONFULL} \
+ libglvnd-glx-${DISTVERSIONFULL} \
+ libglvnd-opengl-${DISTVERSIONFULL}
+
OPTIONS_DEFINE= DOCS
post-install:
diff --git a/graphics/linux-c7-png/Makefile b/graphics/linux-c7-png/Makefile
index b53321d2d3a0..9612eb5c587f 100644
--- a/graphics/linux-c7-png/Makefile
+++ b/graphics/linux-c7-png/Makefile
@@ -15,13 +15,13 @@ LICENSE_NAME= libpng license
LICENSE_FILE= ${WRKSRC}/usr/share/doc/${PORTNAME}-${PORTVERSION}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
-
-DESCR= ${.CURDIR}/../png/pkg-descr
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
+CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
+DESCR= ${.CURDIR}/../png/pkg-descr
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-sdl_image/Makefile b/graphics/linux-c7-sdl_image/Makefile
index 585b2c5d9ae1..18b284c36422 100644
--- a/graphics/linux-c7-sdl_image/Makefile
+++ b/graphics/linux-c7-sdl_image/Makefile
@@ -7,22 +7,22 @@ DISTVERSIONSUFFIX= -11.el7
PORTREVISION= 2
CATEGORIES= graphics linux
MASTER_SITES= EPEL7/s
-DISTNAME= ${LINUXNAME}-${DISTVERSIONFULL}
+DISTNAME= SDL_image-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Simple library to load images as SDL interfaces (Linux CentOS ${LINUX_DIST_VER})
-CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
-
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-DOCSDIR= ${PREFIX}/usr/share/doc/${LINUXNAME}-${PORTVERSION}
-LINUXNAME= SDL_image
ONLY_FOR_ARCHS= amd64
+
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX= jpeg png sdl12 tiff
USE_LINUX_RPM= yes
+CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DOCSDIR= ${PREFIX}/usr/share/doc/SDL_image-${PORTVERSION}
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-sdl_ttf/Makefile b/graphics/linux-c7-sdl_ttf/Makefile
index 1692b747bfab..c6be73b5d91c 100644
--- a/graphics/linux-c7-sdl_ttf/Makefile
+++ b/graphics/linux-c7-sdl_ttf/Makefile
@@ -7,22 +7,22 @@ DISTVERSIONSUFFIX= -6.el7
PORTREVISION= 2
CATEGORIES= graphics linux
MASTER_SITES= EPEL7/s
-DISTNAME= ${LINUXNAME}-${DISTVERSIONFULL}
+DISTNAME= SDL_ttf-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Simple library to load True Type Fonts as SDL interfaces (Linux CentOS ${LINUX_DIST_VER})
-CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
-
-DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
-DOCSDIR= ${PREFIX}/usr/share/doc/${LINUXNAME}-${PORTVERSION}
-LINUXNAME= SDL_ttf
ONLY_FOR_ARCHS= amd64
+
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX= jpeg png sdl12 tiff
USE_LINUX_RPM= yes
+CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+DOCSDIR= ${PREFIX}/usr/share/doc/SDL_ttf-${PORTVERSION}
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-tiff/Makefile b/graphics/linux-c7-tiff/Makefile
index 35418a40cf00..12fbd32da7bc 100644
--- a/graphics/linux-c7-tiff/Makefile
+++ b/graphics/linux-c7-tiff/Makefile
@@ -10,14 +10,14 @@ CATEGORIES= graphics linux
MAINTAINER= emulation@FreeBSD.org
COMMENT= Library routines for working with TIFF images (Linux CentOS ${LINUX_DIST_VER})
-CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
-
-DESCR= ${.CURDIR}/../tiff/pkg-descr
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX= jbigkit jpeg
USE_LINUX_RPM= yes
+CONFLICTS= linux-c6-${PORTNAME}-[0-9]*
+DESCR= ${.CURDIR}/../tiff/pkg-descr
+
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
diff --git a/graphics/linux-c7-wayland/Makefile b/graphics/linux-c7-wayland/Makefile
index 47f48f21519d..7084957bd21b 100644
--- a/graphics/linux-c7-wayland/Makefile
+++ b/graphics/linux-c7-wayland/Makefile
@@ -4,17 +4,19 @@ PORTNAME= wayland
PORTVERSION= 1.15.0
DISTVERSIONSUFFIX= -1.el7
CATEGORIES= graphics linux
-LIB_DISTNAMES= libwayland-client-${DISTVERSIONFULL} \
- libwayland-cursor-${DISTVERSIONFULL} \
- libwayland-egl-${DISTVERSIONFULL} \
- libwayland-server-${DISTVERSIONFULL}
MAINTAINER= emulation@FreeBSD.org
COMMENT= Wayland compositor libraries (Linux CentOS ${LINUX_DIST_VER})
-DESCR= ${.CURDIR}/../wayland/pkg-descr
USES= linux:c7
USE_LDCONFIG= yes
USE_LINUX_RPM= yes
+LIB_DISTNAMES= libwayland-client-${DISTVERSIONFULL} \
+ libwayland-cursor-${DISTVERSIONFULL} \
+ libwayland-egl-${DISTVERSIONFULL} \
+ libwayland-server-${DISTVERSIONFULL}
+
+DESCR= ${.CURDIR}/../wayland/pkg-descr
+
.include <bsd.port.mk>