summaryrefslogtreecommitdiff
path: root/graphics/ruby-opengl
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-02-25 00:17:28 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-02-25 00:17:28 +0000
commit7df9b2b2b470b4d35404730b1e60f7cf6bbb4327 (patch)
tree0c16f45ccedaa1d5906c3b1a72f0d0a266455672 /graphics/ruby-opengl
parentf7254e2cfb7735d132398eb800f17d82325c3365 (diff)
downloadfreebsd-ports-7df9b2b2b470b4d35404730b1e60f7cf6bbb4327.zip
Disable threads again; it has caused the more troubles. This time, it has
${PTHREAD_CFLAGS} and ${PTHREAD_LIBS} include in the build to kill the headache of old '_r' and can't run with something like ruby-opengl, ruby-sdl, ruby-gtk2 and etc on FreeBSD 4.x or older 5.x. With this commit should solve those issues. It is recommend you to rebuild any apps that depend on lang/ruby18, so see the UPDATING for detail. Remove the 'BROKEN' on the other ports that knu has added them few weeks ago. Some of them have been tested, so if one of them is still broke then please let us know and one of us will re-add the 'BROKEN'. This changes was worked by lofi and me. lofi did everything on FreeBSD 4.x and I did others. lofi, thanks for help! Tested by: many people Tested on: i386 (FreeBSD 4.x, 5.x and 6.x), amd64 (FreeBSD 5.x and 6.x), and sparc64 (FreeBSD 5.x and 6.x) Not test on: ia64 and alpha Approved by: portmgr (kris)
Diffstat (limited to 'graphics/ruby-opengl')
-rw-r--r--graphics/ruby-opengl/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/graphics/ruby-opengl/Makefile b/graphics/ruby-opengl/Makefile
index 9cdac7bdae85..e5aa507add81 100644
--- a/graphics/ruby-opengl/Makefile
+++ b/graphics/ruby-opengl/Makefile
@@ -27,11 +27,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-ruby-dir="${LOCALBASE}" --with-x11-dir="${X11BASE}"
INSTALL_TARGET= site-install
-.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 502102
-BROKEN= "Systems prior to FreeBSD 502102 are out of support"
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
@@ -41,4 +36,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README.EUC ${RUBY_MODDOCDIR}/ja/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>