summaryrefslogtreecommitdiff
path: root/graphics/open3d
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /graphics/open3d
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadfreebsd-ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Diffstat (limited to 'graphics/open3d')
-rw-r--r--graphics/open3d/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/open3d/Makefile b/graphics/open3d/Makefile
index 182c4f188535..3a76627b792d 100644
--- a/graphics/open3d/Makefile
+++ b/graphics/open3d/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libglfw.so:graphics/glfw \
libjsoncpp.so:devel/jsoncpp \
libpng16.so:graphics/png
-USES= cmake:outsource compiler:c++14-lang eigen:3 jpeg localbase:ldflags pkgconfig
+USES= cmake compiler:c++14-lang eigen:3 jpeg localbase:ldflags pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= IntelVCL
USE_GL= gl glew glu