summaryrefslogtreecommitdiff
path: root/graphics/libfpx
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2012-10-05 04:14:40 +0000
committerMikhail Teterin <mi@FreeBSD.org>2012-10-05 04:14:40 +0000
commitb9df91e362a0bb0a0379e158d76e50996b5e49e6 (patch)
tree49cbf8f3ea476cfe48942207463d9f2eb9e174d5 /graphics/libfpx
parent41aaef0cd2dd2ad3a0044e6f6c50baddbfb553ad (diff)
downloadfreebsd-ports-b9df91e362a0bb0a0379e158d76e50996b5e49e6.zip
Upgrade from 1.2.x to 1.3.1-1 now that the upstream finally contains new
code (rather than simply updates to auto- configuration glue): Notified by: Steve Wills via PR: ports/171812 The changes are minor, thus shared-library bump. Fix several of the warnings, which GNU compiler missed, but clang uncovered (which broke the build because of -Werror): Notified by: Andreas Nilsson, Thomas Zander
Diffstat (limited to 'graphics/libfpx')
-rw-r--r--graphics/libfpx/Makefile30
-rw-r--r--graphics/libfpx/distinfo6
-rw-r--r--graphics/libfpx/files/patch-fpxlib63
-rw-r--r--graphics/libfpx/files/patch-ph_image18
4 files changed, 101 insertions, 16 deletions
diff --git a/graphics/libfpx/Makefile b/graphics/libfpx/Makefile
index 6ebbf37a6a2b..21e512be49b0 100644
--- a/graphics/libfpx/Makefile
+++ b/graphics/libfpx/Makefile
@@ -6,28 +6,34 @@
#
PORTNAME= libfpx
-PORTVERSION= 1.2.0.12
-PORTREVISION= 2
+DISTVERSION= 1.3.1-1
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= ehaupt
-
-PATCHFILES= fpx.mega-patch.2007-11-01.bz2
-PATCH_SITES= http://aldan.algebra.com/~mi/
+MASTER_SITES= http://imagemagick.mirrorcatalogs.com/delegates/ \
+ http://www.imagemagick.org/download/delegates/ \
+ ftp://mirror.aarnet.edu.au/pub/imagemagick/delegates/ \
+ ftp://gd.tuwien.ac.at/pub/graphics/ImageMagick/delegates/ \
+ http://servingzone.com/mirrors/ImageMagick/delegates/ \
+ http://mirror.checkdomain.de/imagemagick/delegates/ \
+ ftp://mirror.checkdomain.de/imagemagick/delegates/ \
+ http://image_magick.veidrodis.com/image_magick/delegates/
MAINTAINER= mi@aldan.algebra.com
COMMENT= Library routines for working with Flashpix images
-USE_BZIP2= yes
-
-post-patch:
- ${RM} ${WRKSRC}/ri_image/wchar.c ${WRKSRC}/fpx/fpxlib.h
+USE_XZ= yes
-PLIST_FILES=lib/libfpx.so.2 lib/libfpx.so lib/libfpx.a include/fpxlib.h
+PLIST_FILES= lib/libfpx.so.2 lib/libfpx.so lib/libfpx.a include/fpxlib.h
USE_LDCONFIG= yes
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAKE_JOBS_SAFE= yes
+post-patch:
+ ${SED} -i '' -e '/^#include "fpxlib-config.h"/d' \
+ ${WRKSRC}/basics/filename.cpp \
+ ${WRKSRC}/oless/h/owchar.h \
+ ${WRKSRC}/ole/gen_guid.cpp \
+ ${WRKSRC}/fpxlib.h
+
.include <bsd.port.mk>
# We want the port's Makefile to build compiler-flags from scratch
diff --git a/graphics/libfpx/distinfo b/graphics/libfpx/distinfo
index a0a778229795..9a0b3159e007 100644
--- a/graphics/libfpx/distinfo
+++ b/graphics/libfpx/distinfo
@@ -1,4 +1,2 @@
-SHA256 (libfpx-1.2.0.12.tar.bz2) = c9b5ec94c255cbfebcefa6a045f5c7ca3c8ab9de2ad17b88ba4bfce924b91a97
-SIZE (libfpx-1.2.0.12.tar.bz2) = 2301747
-SHA256 (fpx.mega-patch.2007-11-01.bz2) = 1b71d5178c2b85d673e5fece161834d27942c829918ff2c04840f07ffecfab6d
-SIZE (fpx.mega-patch.2007-11-01.bz2) = 122232
+SHA256 (libfpx-1.3.1-1.tar.xz) = d27700c9215ed0fda0878bda098ed5f19ecb436f76f4a1895cca5e4835c253a1
+SIZE (libfpx-1.3.1-1.tar.xz) = 1899164
diff --git a/graphics/libfpx/files/patch-fpxlib b/graphics/libfpx/files/patch-fpxlib
new file mode 100644
index 000000000000..380417066d90
--- /dev/null
+++ b/graphics/libfpx/files/patch-fpxlib
@@ -0,0 +1,63 @@
+ReadPage() must've been returning int at some point. It is returning
+FPXStatus for, at least, 5 years now, but gcc never warned about us
+checking invalid values. Thanks to clang for finding this redundancy.
+--- fpx/fpxlib.cpp 2007-11-02 03:10:05.000000000 -0400
++++ fpx/fpxlib.cpp 2012-10-04 22:49:40.000000000 -0400
+@@ -825,5 +825,5 @@
+ FPXImageDesc* renderingBuffer)
+ {
+- FPXStatus status = FPX_OK;
++ FPXStatus status;
+ if (!thePage)
+ status = FPX_INVALID_FPX_HANDLE;
+@@ -839,18 +839,7 @@
+ else {
+ GtheSystemToolkit->SetUsedColorSpace(image.GetBaselineColorSpace());
+- switch (thePage->ReadPage (image.Get32BitsBuffer())) {
+- case -2 :
+- status = FPX_FILE_READ_ERROR;
+- break;
+- case -3 :
+- status = FPX_LOW_MEMORY_ERROR;
+- break;
+- case 0:
+- image.UpdateDescriptor();
+- break;
+- default:
+- {
+- }
+- }
++ status = thePage->ReadPage(image.Get32BitsBuffer());
++ if (status == FPX_OK)
++ image.UpdateDescriptor();
+ }
+ }
+@@ -863,5 +852,5 @@
+ FPXImageDesc* renderingBuffer)
+ {
+- FPXStatus status = FPX_OK;
++ FPXStatus status;
+ if (!thePage)
+ status = FPX_INVALID_FPX_HANDLE;
+@@ -877,18 +866,7 @@
+ else {
+ GtheSystemToolkit->SetUsedColorSpace(line.GetBaselineColorSpace());
+- switch (thePage->ReadPageLine (lineNumber, line.Get32BitsBuffer())) {
+- case -2 :
+- status = FPX_FILE_READ_ERROR;
+- break;
+- case -3 :
+- status = FPX_LOW_MEMORY_ERROR;
+- break;
+- case 0:
+- line.UpdateDescriptor();
+- break;
+- default:
+- {
+- }
+- }
++ status = thePage->ReadPageLine (lineNumber, line.Get32BitsBuffer());
++ if (status == FPX_OK)
++ line.UpdateDescriptor();
+ }
+ }
diff --git a/graphics/libfpx/files/patch-ph_image b/graphics/libfpx/files/patch-ph_image
new file mode 100644
index 000000000000..d6a63d80c822
--- /dev/null
+++ b/graphics/libfpx/files/patch-ph_image
@@ -0,0 +1,18 @@
+--- ri_image/ph_image.h 2007-11-02 03:10:05.000000000 -0400
++++ ri_image/ph_image.h 2012-10-04 22:38:52.000000000 -0400
+@@ -173,5 +173,5 @@
+ virtual FPXStatus CreateInitResolutionLevelList(); // Make a sub image list in read or write mode
+ virtual FPXStatus CreateEmptyResolutionLevelList(); // Make a sub image list in create mode
+- virtual PResolutionLevel* CreateEmptyResolutionLevel(int width, int height, long* quelImage); // Make a sub image in create mode
++ virtual PResolutionLevel* CreateEmptyResolutionLevel(int width, int height, int* quelImage); // Make a sub image in create mode
+ virtual PResolutionLevel* CreateInitResolutionLevel(int* offset, long id); // Make a sub image in read or write mode
+
+--- ri_image/ph_image.cpp 2007-11-02 03:10:05.000000000 -0400
++++ ri_image/ph_image.cpp 2012-10-04 22:38:31.000000000 -0400
+@@ -1127,5 +1127,5 @@
+ // ----------------------------------------------------------------------------
+ // Make a sub resolution level in create mode
+-PResolutionLevel* PHierarchicalImage::CreateEmptyResolutionLevel(int , int , long int*)
++PResolutionLevel* PHierarchicalImage::CreateEmptyResolutionLevel(int , int , int*)
+ {
+ return NULL;