summaryrefslogtreecommitdiff
path: root/graphics/instant-meshes
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-06-17 16:52:50 +0000
committerRene Ladan <rene@FreeBSD.org>2019-06-17 16:52:50 +0000
commit7f0d52068c9e909607920ac0fd2239b62f068f18 (patch)
tree9dc45731f469476833bfea07c1d98be8ce4aad3d /graphics/instant-meshes
parent460a92e9ac6124a49b1f8e98ee209f18085c1a3a (diff)
downloadfreebsd-ports-7f0d52068c9e909607920ac0fd2239b62f068f18.zip
graphics/instant-meshes: include dirent.h instead of sys/dir.h which is scheduled for removal.
While here modernize USES PR: 238620 Submitted by: rene Approved by: Greg V (maintainer) Event: Berlin Hackathon 2019 (generating the patch)
Diffstat (limited to 'graphics/instant-meshes')
-rw-r--r--graphics/instant-meshes/Makefile2
-rw-r--r--graphics/instant-meshes/files/patch-ext_nanogui_src_common.cpp11
2 files changed, 11 insertions, 2 deletions
diff --git a/graphics/instant-meshes/Makefile b/graphics/instant-meshes/Makefile
index 6271f1d4e4dc..967dab22413e 100644
--- a/graphics/instant-meshes/Makefile
+++ b/graphics/instant-meshes/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libglfw.so:graphics/glfw \
libtbb.so:devel/tbb
RUN_DEPENDS= zenity:x11/zenity
-USES= cmake compiler:c++14-lang eigen:3 localbase:ldflags pkgconfig
+USES= cmake compiler:c++14-lang eigen:3 gl localbase:ldflags pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= wjakob
GH_TUPLE= wjakob:nanogui:2a61f03:nanogui/ext/nanogui \
diff --git a/graphics/instant-meshes/files/patch-ext_nanogui_src_common.cpp b/graphics/instant-meshes/files/patch-ext_nanogui_src_common.cpp
index 03eda14ec941..212997388699 100644
--- a/graphics/instant-meshes/files/patch-ext_nanogui_src_common.cpp
+++ b/graphics/instant-meshes/files/patch-ext_nanogui_src_common.cpp
@@ -1,6 +1,15 @@
--- ext/nanogui/src/common.cpp.orig 2016-10-15 20:12:12 UTC
+++ ext/nanogui/src/common.cpp
-@@ -248,7 +248,7 @@ std::string file_dialog(const std::vecto
+@@ -24,7 +24,7 @@
+ #if !defined(_WIN32)
+ #include <locale.h>
+ #include <signal.h>
+- #include <sys/dir.h>
++ #include <dirent.h>
+ #endif
+
+ NAMESPACE_BEGIN(nanogui)
+@@ -248,7 +248,7 @@ std::string file_dialog(const std::vector<std::pair<st
return std::string(ofn.lpstrFile);
#else
char buffer[FILE_DIALOG_MAX_BUFFER];