summaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorBarbara Guida <bar@FreeBSD.org>2017-04-17 11:35:39 +0000
committerBarbara Guida <bar@FreeBSD.org>2017-04-17 11:35:39 +0000
commit1838c72449e5ed5bfa5b03cdb728d9d51223b2c0 (patch)
tree89369938ec2c74ae5f017158b49111f5854bca6b /games
parent1240fc9915001e4cbeb7441aa3740b8c3ff7eca7 (diff)
downloadfreebsd-ports-1838c72449e5ed5bfa5b03cdb728d9d51223b2c0.zip
Revert to r437875.
Sorry...it turned out I did the test using my default make.conf, so it was building with default 10-STABLE clang (3.4.1). After testing again, still no luck with llvm40.
Diffstat (limited to 'games')
-rw-r--r--games/vavoom/Makefile23
-rw-r--r--games/vavoom/files/pkg-message.in1
-rw-r--r--games/vavoom/pkg-plist2
3 files changed, 16 insertions, 10 deletions
diff --git a/games/vavoom/Makefile b/games/vavoom/Makefile
index 8c3f82b9018a..f83a7ec58ae6 100644
--- a/games/vavoom/Makefile
+++ b/games/vavoom/Makefile
@@ -15,12 +15,16 @@ LICENSE= GPLv2
LIB_DEPENDS= libpng.so:graphics/png
USES= cmake dos2unix jpeg tar:bzip2
-
+# Force GCC because llvm (starting from 4.0) generates
+# non working binary for vcc
+USE_GCC= yes
DOS2UNIX_REGEX= ((.*\.(c|cpp|h|s|asm|inc|vc|ls|acs|cfg|txt|vs|mak|mgw"))$$|\/(makefile\..*|makefile|Makefile)$$)
-OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
-OPTIONS_DEFAULT= LAUNCHER OPENGL SDL
-LAUNCHER_DESC= Build GUI launcher
+# Removed LAUNCHER because it segfaults
+#OPTIONS_DEFINE= FLAC LAUNCHER MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
+OPTIONS_DEFINE= FLAC MAD MIKMOD OPENAL OPTIMIZED_CFLAGS VORBIS SDL DOCS
+OPTIONS_DEFAULT= OPENGL SDL
+#LAUNCHER_DESC= Build GUI launcher
OPENAL_DESC= Enable OpenAL support
SDL_DESC= Use SDL for OpenGL support
@@ -37,10 +41,13 @@ FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
FLAC_CMAKE_ON= -DWITH_FLAC:BOOL=ON
FLAC_CMAKE_OFF= -DWITH_FLAC:BOOL=OFF
-LAUNCHER_USE= WX=2.8+
-LAUNCHER_CMAKE_ON= -DENABLE_LAUNCHER:BOOL=ON \
- -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
-LAUNCHER_CMAKE_OFF= -DENABLE_LAUNCHER:BOOL=OFF
+# Removed LAUNCHER because it segfaults - check also pkg-plist
+#LAUNCHER_USE= WX=2.8+
+#LAUNCHER_CMAKE_ON= -DENABLE_LAUNCHER:BOOL=ON \
+# -DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}"
+#LAUNCHER_CMAKE_OFF= -DENABLE_LAUNCHER:BOOL=OFF
+# Force disable LAUNCHER
+CMAKE_ARGS+= -DENABLE_LAUNCHER:BOOL=OFF
MAD_LIB_DEPENDS= libmad.so:audio/libmad
MAD_CMAKE_ON= -DWITH_LIBMAD:BOOL=ON
diff --git a/games/vavoom/files/pkg-message.in b/games/vavoom/files/pkg-message.in
index 2eae4f53d349..dae4d5f59f8b 100644
--- a/games/vavoom/files/pkg-message.in
+++ b/games/vavoom/files/pkg-message.in
@@ -16,6 +16,5 @@ need VORBIS (build options).
Refer to %%DOCSDIR%%/vavoom.txt for other options such as
game selection, network options and so on.
-If you enabled LAUNCHER (build option), run "vlaunch" for a launcher GUI.
==============================================================================
diff --git a/games/vavoom/pkg-plist b/games/vavoom/pkg-plist
index e5dc8faeec68..7f4b7c82ef1e 100644
--- a/games/vavoom/pkg-plist
+++ b/games/vavoom/pkg-plist
@@ -2,7 +2,7 @@ bin/vavoom
bin/vavoom.bin
bin/vavoom-dedicated
bin/vavoom-dedicated.bin
-%%LAUNCHER%%bin/vlaunch
+@comment %%LAUNCHER%%bin/vlaunch
%%PORTDOCS%%%%DOCSDIR%%/vavoom.txt
%%DATADIR%%/basev/common/basepak.pk3
%%DATADIR%%/basev/doom/basepak.pk3