summaryrefslogtreecommitdiff
path: root/games/ldmud
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-15 08:20:27 +0000
commit074ea5282a00d556c73d86231bec5444990597dc (patch)
treeeec3d608e84e79f0187985e5a1e29cd4f04f13eb /games/ldmud
parent522c152d1c7b0c92982e310110fa6d59f915ffeb (diff)
downloadfreebsd-ports-074ea5282a00d556c73d86231bec5444990597dc.zip
converters/libiconv:
- Remove const qualifier from iconv(3) to match POSIX: http://pubs.opengroup.org/onlinepubs/9699919799/functions/iconv.html - Patch iconv.h to expose more GNU extensions when LIBICONV_PLUG is defined because the base system iconv supports these extensions too. Add/remove patches to/from ports to call iconv with non-const arguments. This breaks some ports on FreeBSD 10 because base system iconv.h still has the const qualifier. Fix this by letting USES=iconv add a build dependency on converters/libiconv so ports can use its iconv.h (with LIBICONV_PLUG defined) instead of the base system iconv.h. This exposed some ports that link with libiconv when it is available instead of using libc iconv. In these cases one of the following changes has been made: - patch configure scripts to test for libc iconv first - add ac_cv_lib_iconv_libiconv=no or similar to CONFIGURE_ARGS to disable some configure tests - converters/wkhtmltopdf: this includes Qt4 so add a patch from devel/qt4 - lang/gcc5-aux: respect CFLAGS and friends during configure such that LIBICONV_PLUG is defined in the iconv test, also switch to external gettext - mail/gnarwl: replace patches with CPPFLAGS/LIBS - multimedia/ffmpeg2theora: remove iconv test from SConstruct and use ICONV_LIB in port Makefile instead, also fix a bug in subtitles.c - net-im/licq: finish conversion to cmake - net-mgmt/bandwidthd, net-mgmt/icinga, net-mgmt/nagios, net-mgmt/nagios4: don't need iconv - textproc/p5-XML-TinyXML: finish conversion to USES=perl5 Other changes: - databases/qdbm and slaves: respect CFLAGS and friends, also enable bzip2 and lzo support - games/ldmud: respect CFLAGS and friends - graphics/inventor: replace some patches with MAKE_ARGS/MAKE_ENV to respect CFLAGS and friends, also remove FreeBSD/alpha patch and add missing xorg dependencies PR: 199099 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'games/ldmud')
-rw-r--r--games/ldmud/Makefile2
-rw-r--r--games/ldmud/files/patch-Makefile.in22
-rw-r--r--games/ldmud/files/patch-configure75
3 files changed, 95 insertions, 4 deletions
diff --git a/games/ldmud/Makefile b/games/ldmud/Makefile
index 5cb716d12e23..bee0b0c0872e 100644
--- a/games/ldmud/Makefile
+++ b/games/ldmud/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ldmud
PORTVERSION= 3.3.720
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= games net
MASTER_SITES= http://www.bearnip.com/ftp/mud/ \
diff --git a/games/ldmud/files/patch-Makefile.in b/games/ldmud/files/patch-Makefile.in
index 5c043c2a5825..a79cd6647ff7 100644
--- a/games/ldmud/files/patch-Makefile.in
+++ b/games/ldmud/files/patch-Makefile.in
@@ -1,6 +1,22 @@
---- Makefile.in.orig 2013-12-29 15:19:34.000000000 +0100
-+++ Makefile.in 2013-12-29 15:20:35.000000000 +0100
-@@ -135,9 +135,9 @@ install: install-driver
+--- Makefile.in.orig 2011-02-26 21:05:08 UTC
++++ Makefile.in
+@@ -1,6 +1,5 @@
+ # TODO: Add some of the symbols in here to configure
+ # These lines are needed on some machines.
+-MAKE=make
+ SHELL=@CONFIG_SHELL@
+ INSTALL=@INSTALL@
+ mkinstalldirs=$(SHELL) @top_srcdir@/mkinstalldirs
+@@ -83,7 +82,7 @@ SFMT_FLAGS = -fno-strict-aliasing
+ #
+ MPATH=-DMUD_LIB='"$(MUD_LIB)"' -DBINDIR='"$(BINDIR)"' -DERQ_DIR='"$(ERQ_DIR)"'
+ #
+-CFLAGS= @EXTRA_CFLAGS@ $(OPTIMIZE) $(DEBUG) $(WARN) $(MPATH) $(PROFIL)
++CFLAGS= @CPPFLAGS@ @CFLAGS@ @EXTRA_CFLAGS@ $(DEBUG) $(WARN) $(MPATH) $(PROFIL)
+ #
+ LIBS=@LIBS@ @PKGLIBS@
+ #
+@@ -135,9 +134,9 @@ install: install-driver
@echo "To install everything in one go, use 'make install-all'."
install-driver: ldmud@EXEEXT@ docs
diff --git a/games/ldmud/files/patch-configure b/games/ldmud/files/patch-configure
new file mode 100644
index 000000000000..d54d1cf11ac1
--- /dev/null
+++ b/games/ldmud/files/patch-configure
@@ -0,0 +1,75 @@
+--- configure.orig 2011-02-26 21:05:08 UTC
++++ configure
+@@ -13600,7 +13600,7 @@ for TESTFLAG in -O; do
+ #the [e]grep option -v will not give a failure exit status on the atari
+ else
+ if eval $tcomp; then
+- CFLAGS=$TESTFLAG
++ LCFLAGS=$TESTFLAG
+ break
+ fi
+ fi
+@@ -13608,10 +13608,9 @@ for TESTFLAG in -O; do
+ done
+ for TESTFLAG in -g; do
+ if eval $tcomp; then
+- CFLAGS="$CFLAGS $TESTFLAG"
++ LCFLAGS="$LCFLAGS $TESTFLAG"
+ fi
+ done
+-LCFLAGS=$CFLAGS
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $LCFLAGS" >&5
+ $as_echo "$LCFLAGS" >&6; }
+
+@@ -13624,7 +13623,7 @@ for TESTFLAG in -O2 -O; do
+ #the [e]grep option -v will not give a failure exit status on the atari
+ else
+ if eval $tcomp; then
+- CFLAGS=$TESTFLAG
++ MCFLAGS=$TESTFLAG
+ break
+ fi
+ fi
+@@ -13633,10 +13632,9 @@ done
+ for TESTFLAG in -g; do
+ if eval $tcomp; then
+ OPTFLAGS="$OPTFLAGS $TESTFLAG"
+- CFLAGS="$CFLAGS $TESTFLAG"
++ MCFLAGS="$MCFLAGS $TESTFLAG"
+ fi
+ done
+-MCFLAGS=$CFLAGS
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $MCFLAGS" >&5
+ $as_echo "$MCFLAGS" >&6; }
+
+@@ -13649,7 +13647,7 @@ for TESTFLAG in -O4 -O3 -O2 -O; do
+ #the [e]grep option -v will not give a failure exit status on the atari
+ else
+ if eval $tcomp; then
+- CFLAGS=$TESTFLAG
++ OCFLAGS=$TESTFLAG
+ break
+ fi
+ fi
+@@ -13663,7 +13661,7 @@ if test "$ac_cv_c_compiler_gnu" = "no";
+ #the [e]grep option -v will not give a failure exit status on the atari
+ else
+ if eval $tcomp; then
+- CFLAGS="$CFLAGS $TESTFLAG"
++ OCFLAGS="$OCFLAGS $TESTFLAG"
+ break
+ fi
+ fi
+@@ -13673,10 +13671,10 @@ fi
+ # -funroll-all-loops causes some versions of gcc to produce buggy code
+ for TESTFLAG in -fomit-frame-pointer; do
+ if eval $tcomp; then
+- CFLAGS="$CFLAGS $TESTFLAG"
++ OCFLAGS="$OCFLAGS $TESTFLAG"
+ fi
+ done
+-OCFLAGS="$CFLAGS $OPTFLAGS"
++OCFLAGS="$OCFLAGS $OPTFLAGS"
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: $OCFLAGS" >&5
+ $as_echo "$OCFLAGS" >&6; }
+ if ${CC-cc} -g -c conftest.c ; then