summaryrefslogtreecommitdiff
path: root/games/alienarena/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 02:44:22 +0200
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-26 02:48:20 +0200
commit95274bf4f99c71fc056013d966aec239161dfd74 (patch)
treebc1e95977678cb5b6b00b33e333b28161885e706 /games/alienarena/Makefile
parentdbe06d2da8c38d9d058f7939a7c6af36a2c0f1c7 (diff)
downloadfreebsd-ports-95274bf4f99c71fc056013d966aec239161dfd74.zip
*/*: Fix build with llvm16 on 13.2-STABLE
As like as HEAD(14.0-RELEASE) llvm16 was merged in base for 13.2-STABLE with the OSVERSION 1302507. - Utilize USE_CXXSTD=c++14 or similar solution where applicable - Update conditionals to addtionally check for OSVERSION greater than 1302507 and less than 1400000 Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'games/alienarena/Makefile')
-rw-r--r--games/alienarena/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/games/alienarena/Makefile b/games/alienarena/Makefile
index 5446bb523df7..0d0b49d9e9ee 100644
--- a/games/alienarena/Makefile
+++ b/games/alienarena/Makefile
@@ -57,9 +57,9 @@ CLIENT_USE= GL=glu XORG=x11,xxf86dga,xxf86vm
LIBDIR= ${PREFIX}/lib/${PORTNAME}
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
@@ -91,4 +91,4 @@ do-install-DEDICATED-on:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}-ded \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}-ded
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>