summaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-09-18 21:12:53 +0200
committerAdriaan de Groot <adridg@FreeBSD.org>2023-09-18 22:24:13 +0200
commitc75e8803b5ff85b592f425bb754860b51b1ac4cc (patch)
tree17085e3a2d7ec9f241502c0cf552fe42a98d3afd /ftp
parent12434f9d5dfb6fca8fec491661f3ff2738cd167b (diff)
downloadfreebsd-ports-c75e8803b5ff85b592f425bb754860b51b1ac4cc.zip
ftp/coeurl: fix build with {fmt} 10
- add fmt as a dependency, make it build by pulling in upstream commit 831e2ee8e9cf08ea1ee9736cde8370f9d0312abc PR: 273875 Provided by: diizzy@
Diffstat (limited to 'ftp')
-rw-r--r--ftp/coeurl/Makefile8
-rw-r--r--ftp/coeurl/files/patch-lib_client.cpp19
2 files changed, 23 insertions, 4 deletions
diff --git a/ftp/coeurl/Makefile b/ftp/coeurl/Makefile
index fd2e1535413d..b5e712acc127 100644
--- a/ftp/coeurl/Makefile
+++ b/ftp/coeurl/Makefile
@@ -1,6 +1,7 @@
PORTNAME= coeurl
DISTVERSIONPREFIX=v
DISTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= ftp www
MAINTAINER= adridg@FreeBSD.org
@@ -10,13 +11,12 @@ WWW= https://nheko.im/nheko-reborn/coeurl
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= \
- libcurl.so:ftp/curl \
+LIB_DEPENDS= libcurl.so:ftp/curl \
libevent.so:devel/libevent \
+ libfmt.so:devel/libfmt \
libspdlog.so:devel/spdlog
-USES= compiler:c++17-lang pkgconfig \
- meson tar:xz
+USES= compiler:c++17-lang meson pkgconfig tar:xz
USE_GITLAB= yes
GL_SITE= https://nheko.im/
diff --git a/ftp/coeurl/files/patch-lib_client.cpp b/ftp/coeurl/files/patch-lib_client.cpp
new file mode 100644
index 000000000000..e8e50673879e
--- /dev/null
+++ b/ftp/coeurl/files/patch-lib_client.cpp
@@ -0,0 +1,19 @@
+--- lib/client.cpp.orig 2023-01-10 04:14:36 UTC
++++ lib/client.cpp
+@@ -6,6 +6,7 @@
+ #include <thread>
+
+ #include "coeurl/request.hpp"
++#include "coeurl/errors.hpp"
+
+ namespace coeurl {
+ std::shared_ptr<spdlog::logger> Client::log = spdlog::null_logger_mt("coeurl_null");
+@@ -352,7 +353,7 @@ void Client::remove_request(Request *r) {
+ long http_code;
+ curl_easy_getinfo(req->easy, CURLINFO_RESPONSE_CODE, &http_code);
+
+- Client::log->trace("DONE: {} => {} ({}) http: {}", req->url_, req->curl_error, req->error, http_code);
++ Client::log->trace("DONE: {} => {} ({}) http: {}", req->url_, coeurl::to_string(req->curl_error), req->error, http_code);
+
+ if (req->on_complete_)
+ req->on_complete_(*req.get());