summaryrefslogtreecommitdiff
path: root/ftp
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-03-13 16:15:36 +0000
commitb59621d3ae883bef429a8fae6073bfa293a55222 (patch)
treeb415c7b2903cf47ada68c5557c3c6ac33a25fc41 /ftp
parente93c09b8f3675471a176b72ae1e6f085f7a607ad (diff)
downloadfreebsd-ports-b59621d3ae883bef429a8fae6073bfa293a55222.zip
- Revert ports/165605 as requested by portmgr@
Note: devel/p5-B-Size and devel/p5-Devel-Arena where intentionally not restored. PR: ports/165605 Approved by: portmgr (bapt) Feature safe: yes (I sure hope so)
Diffstat (limited to 'ftp')
-rw-r--r--ftp/p5-File-Fetch/Makefile12
-rw-r--r--ftp/p5-Net-FTPServer/Makefile10
-rw-r--r--ftp/p5-SOAP-Transport-FTP/Makefile8
3 files changed, 26 insertions, 4 deletions
diff --git a/ftp/p5-File-Fetch/Makefile b/ftp/p5-File-Fetch/Makefile
index 3ae8c481055e..05612aedd9b8 100644
--- a/ftp/p5-File-Fetch/Makefile
+++ b/ftp/p5-File-Fetch/Makefile
@@ -18,4 +18,14 @@ PERL_CONFIGURE= yes
MAN3= File::Fetch.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501001
+RUN_DEPENDS+= p5-IPC-Cmd>=0.42:${PORTSDIR}/devel/p5-IPC-Cmd \
+ p5-Locale-Maketext-Simple>=0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
+ p5-Module-Load-Conditional>=0.04:${PORTSDIR}/devel/p5-Module-Load-Conditional \
+ p5-Params-Check>=0.07:${PORTSDIR}/devel/p5-Params-Check
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/ftp/p5-Net-FTPServer/Makefile b/ftp/p5-Net-FTPServer/Makefile
index 6c1480cc6982..9d564d795bd3 100644
--- a/ftp/p5-Net-FTPServer/Makefile
+++ b/ftp/p5-Net-FTPServer/Makefile
@@ -22,7 +22,7 @@ RUN_DEPENDS= p5-Archive-Zip>=0:${PORTSDIR}/archivers/p5-Archive-Zip \
p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-File-Sync>=0:${PORTSDIR}/devel/p5-File-Sync \
p5-IO-stringy>=1.126:${PORTSDIR}/devel/p5-IO-stringy
-BUILD_DEPENDS:= ${RUN_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
MAKE_ENV+= NOCONF=1
PERL_CONFIGURE= yes
@@ -55,6 +55,12 @@ DOCS= FAQ README TODO doc/*
PORTDOCS= *
PORTEXAMPLES= ftpd.conf
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s/root,root/root,wheel/" \
-e "s,/usr/sbin,${PREFIX}/sbin," \
@@ -75,4 +81,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/ftp/p5-SOAP-Transport-FTP/Makefile b/ftp/p5-SOAP-Transport-FTP/Makefile
index 19b282213f9c..2e8b1de36165 100644
--- a/ftp/p5-SOAP-Transport-FTP/Makefile
+++ b/ftp/p5-SOAP-Transport-FTP/Makefile
@@ -21,4 +21,10 @@ PERL_CONFIGURE= yes
MAN3= SOAP::Transport::FTP.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501200
+BUILD_DEPENDS+= p5-Module-Build>=0.3600:${PORTSDIR}/devel/p5-Module-Build
+.endif
+
+.include <bsd.port.post.mk>