summaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-05-17 01:36:32 +0200
committerRobert Clausecker <fuz@FreeBSD.org>2023-05-18 10:19:48 +0200
commit9fb2d7b2e7473d6bf8bb18d5e457ed4c7ac933df (patch)
tree7328cd7d997f3a84cd4072b7c0ae0cf3f86fc2de /emulators
parentbc6e8c0e283fcec28796a874d6280a2081bc801d (diff)
downloadfreebsd-ports-9fb2d7b2e7473d6bf8bb18d5e457ed4c7ac933df.zip
emulators/mame: fix build on armv7
Mame fails to link on armv7 due to an address space exhaustion in lld. As a bandaid, tell lld to not generate symbols. This frees up enough address space to make mame link. PR: 271374 MFH: 2023Q2 Approved by: agh@riseup.net (maintainer)
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mame/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index aebdb69da8a3..d13f1e2cc8dd 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -84,6 +84,9 @@ MAKE_ENV+= DEBUG="1" \
OPTIMIZE="0" \
PROFILER="1" \
SYMBOLS="1"
+.else
+# avoid address space exhaustion in linker on armv7
+LDFLAGS+= -s
.endif
.if ${ARCH} == amd64 || ${ARCH:Mpowerpc64*}
@@ -160,11 +163,11 @@ post-patch:
s| .(ARCH)||g' \
${WRKSRC}/makefile \
${GENIE}/build/gmake.bsd/genie.make
- @${REINPLACE_CMD} -e 's|gcc|cc|; s|g++|c++|' \
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|; s|g++|${CXX}|' \
${GENIE}/src/tools/gcc.lua \
${GENIE}/src/tools/snc.lua \
${GENIE}/tests/test_gmake_cpp.lua
- @${REINPLACE_CMD} -e 's|= \"gcc|= \"cc|; s|= \"g++|= \"c++|' \
+ @${REINPLACE_CMD} -e 's|= \"gcc|= \"${CC}|; s|= \"g++|= \"${CXX}|' \
-e "s|'CXX =|'#CXX =|; s|'CC =|'#CC =|; s| .(ARCH)| |g" \
${GENIE}/src/host/scripts.c
@${GREP} -rl '"png.h"' ${WRKSRC}/src | \