summaryrefslogtreecommitdiff
path: root/emulators/qemu-devel
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-04-14 17:54:45 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-04-14 17:54:45 +0000
commitf1cc948f902f9fde68dcceb58bc4e94151ce4e81 (patch)
tree0dbc000b2f465f728feba28f9b5f427712a72763 /emulators/qemu-devel
parent728d2f9803772e9863d62c914d3ba92d457999e4 (diff)
downloadfreebsd-ports-f1cc948f902f9fde68dcceb58bc4e94151ce4e81.zip
emulators/qemu-devel: Remove OPTIONS GNS3
- Since 2.5.0 GNS3 patch iis no longer required - Fix noX and noOpenGL builds [1] PR: 237283 [1] Submitted by: sbruno [1]
Diffstat (limited to 'emulators/qemu-devel')
-rw-r--r--emulators/qemu-devel/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index d126766cc61f..7a44c4e8c7e9 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libnettle.so:security/nettle \
libepoxy.so:graphics/libepoxy \
libpcre2-8.so:devel/pcre2
-USES= cpe gl gmake gnome pkgconfig bison perl5 python:2.7,build tar:xz
+USES= cpe gmake gnome pkgconfig bison perl5 python:2.7,build tar:xz
USE_GNOME= cairo glib20 libxml2
USE_PERL5= build
USE_XORG= pixman
@@ -35,7 +35,7 @@ HAS_CONFIGURE= yes
MAKE_ENV+= BSD_MAKE="${MAKE}" V=1
OPTIONS_DEFINE= SAMBA X11 GTK3 OPENGL GNUTLS SASL JPEG PNG CURL \
- VDE CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
+ VDE CDROM_DMA PCAP USBREDIR X86_TARGETS \
STATIC_LINK DOCS NCURSES
SAMBA_DESC= samba dependency (for -smb)
GNUTLS_DESC= gnutls dependency (vnc encryption)
@@ -45,11 +45,10 @@ PNG_DESC= png dependency (vnc compression)
CDROM_DMA_DESC= IDE CDROM DMA
PCAP_DESC= pcap dependency (networking with bpf)
USBREDIR_DESC= usb device network redirection (experimental!)
-GNS3_DESC= gns3 patches (promiscuous multicast)
X86_TARGETS_DESC= Build only x86 system targets
STATIC_LINK_DESC= Statically link the executables
VDE_DESC= vde dependency (for vde networking)
-OPTIONS_DEFAULT=X11 GTK3 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP GNS3 NCURSES VDE
+OPTIONS_DEFAULT=X11 GTK3 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP NCURSES VDE
OPTIONS_SUB= yes
X11_USE= SDL=sdl XORG=x11,xext GNOME=gdkpixbuf2
X11_USES= sdl
@@ -149,10 +148,6 @@ post-patch:
post-patch-CDROM_DMA-off:
@${REINPLACE_CMD} -e '/USE_DMA_CDROM/d' ${WRKSRC}/include/hw/ide/internal.h
-post-patch-GNS3-on:
- @${REINPLACE_CMD} -e 's|(buf\[0\] & 1) && (rctl & E1000_RCTL_MPE)|buf[0] \& 1|' \
- ${WRKSRC}/hw/net/e1000.c
-
# XXX need to disable usb host code on head while it's not ported to the
# new usb stack yet
post-configure: