summaryrefslogtreecommitdiff
path: root/emulators/mupen64plus/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-05-20 19:11:55 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-05-20 19:11:55 +0000
commit6d563d0ab273e71af8a12a844f1e0da12b830791 (patch)
tree9149c94e5d5e39315ff5d488c44a4926d89e805f /emulators/mupen64plus/Makefile
parent21eff32876e438f9766081073d2f249d9237bdcf (diff)
downloadfreebsd-ports-6d563d0ab273e71af8a12a844f1e0da12b830791.zip
New port: emulators/mupen64plus
This is the metaport to install the mupen64plus emulator and all graphics, input and audio plugins. WWW: http://code.google.com/p/mupen64plus/
Diffstat (limited to 'emulators/mupen64plus/Makefile')
-rw-r--r--emulators/mupen64plus/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/emulators/mupen64plus/Makefile b/emulators/mupen64plus/Makefile
new file mode 100644
index 000000000000..ea122172ceac
--- /dev/null
+++ b/emulators/mupen64plus/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: mupen64plus
+# Date created: 2008-05-17
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mupen64plus
+PORTVERSION= 1.3
+CATEGORIES= emulators
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER?= acm@FreeBSD.org
+COMMENT= A fork of Mupen64 Nintendo 64 emulator with plugins (meta port)
+
+# Mupen64 Emulator gui and no-gui
+RUN_DEPENDS+= ${LOCALBASE}/bin/mupen64plus:${PORTSDIR}/emulators/mupen64plus-base
+
+# Audio plugins
+RUN_DEPENDS+= ${PLUGINDIR}/dummyaudio.so:${PORTSDIR}/emulators/mupen64plus-dummyaudio
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_audio.so:${PORTSDIR}/emulators/mupen64plus-sound
+RUN_DEPENDS+= ${PLUGINDIR}/jttl_audio.so:${PORTSDIR}/emulators/mupen64plus-sdlaudio
+
+# Input plugins
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_input.so:${PORTSDIR}/emulators/mupen64plus-input
+RUN_DEPENDS+= ${PLUGINDIR}/blight_input.so:${PORTSDIR}/emulators/mupen64plus-sdlinput
+RUN_DEPENDS+= ${PLUGINDIR}/mupen64_hle_rsp_azimer.so:${PORTSDIR}/emulators/mupen64plus-rsp
+
+# Graphics plugins
+RUN_DEPENDS+= ${PLUGINDIR}/ricevideo.so:${PORTSDIR}/emulators/mupen64plus-rice
+RUN_DEPENDS+= ${PLUGINDIR}/glide64.so:${PORTSDIR}/emulators/mupen64plus-glide
+RUN_DEPENDS+= ${PLUGINDIR}/glN64.so:${PORTSDIR}/emulators/mupen64plus-gln64
+
+NO_MTREE= yes
+NO_BUILD= yes
+SUB_FILES= pkg-message
+
+PLUGINDIR= ${LOCALBASE}/share/mupen64plus/plugins
+
+do-install: # empty
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>