summaryrefslogtreecommitdiff
path: root/emulators/cingb
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-02-24 13:39:55 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-02-24 13:39:55 +0000
commit93e4f1510956918f4f8a8d0ac31db42972a01891 (patch)
tree8ae2e41d46b618edd52cd3abb1f757fbfd462fe4 /emulators/cingb
parent3899cb3c0239ae9de772011d1af6fc6ee6c0b283 (diff)
downloadfreebsd-ports-93e4f1510956918f4f8a8d0ac31db42972a01891.zip
emulators/cingb: Update to v0.32
- Pick MAINTAINER'ship - Install additional documentation - Switch upstream to GitHub - Update WWW Reviewed by: krion Approved by: krion (mentor) Differential Revision: https://reviews.freebsd.org/D19321
Diffstat (limited to 'emulators/cingb')
-rw-r--r--emulators/cingb/Makefile32
-rw-r--r--emulators/cingb/distinfo5
-rw-r--r--emulators/cingb/pkg-descr2
3 files changed, 28 insertions, 11 deletions
diff --git a/emulators/cingb/Makefile b/emulators/cingb/Makefile
index f4592914f00c..1d4f0cc6fb4a 100644
--- a/emulators/cingb/Makefile
+++ b/emulators/cingb/Makefile
@@ -2,26 +2,36 @@
# $FreeBSD$
PORTNAME= cingb
-PORTVERSION= 0.31
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.32
CATEGORIES= emulators
-MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Yet another Nintendo GameBoy(tm) emulator
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Yet another Nintendo Game Boy emulator
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
USES= tar:bzip2
USE_XORG= x11 xext xv
+USE_GITHUB= yes
+GH_ACCOUNT= nakal
+
MAKE_ENV= X11BASE="${LOCALBASE}"
ALL_TARGET= standard
-PORTDOCS= README README.FAQ
-PLIST_FILES= bin/cingb bin/cingb_conf
LDFLAGS+= -lpthread
-OPTIONS_DEFINE= DOCS
+PLIST_FILES= bin/cingb \
+ bin/cingb_conf \
+ man/man6/cingb.6.gz
+PORTDOCS= README.FAQ README.md
+
+OPTIONS_DEFINE= DEBUG DOCS
+OPTIONS_SUB= yes
+DEBUG_ALL_TARGET+= debug
+DEBUG_PLIST_FILES= bin/cingb_deb
+DEBUG_PORTDOCS= DEBUGGER
.include <bsd.port.pre.mk>
@@ -53,10 +63,16 @@ do-configure:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cingb ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/cingb_conf ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/freebsd/cingb.6 ${STAGEDIR}${MANPREFIX}/man/man6/
+
+do-install-DEBUG-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/DEBUGGER ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/cingb_deb ${STAGEDIR}${PREFIX}/bin
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.FAQ ${STAGEDIR}${DOCSDIR}
.include <bsd.port.post.mk>
diff --git a/emulators/cingb/distinfo b/emulators/cingb/distinfo
index fe79431408d8..fc076c3089ec 100644
--- a/emulators/cingb/distinfo
+++ b/emulators/cingb/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cingb-0.31.tar.bz2) = a6e2f89c870c696d7d68c3d8be7910feecee4c9ad9742f7ed9244f64d4d2e4d5
-SIZE (cingb-0.31.tar.bz2) = 53831
+TIMESTAMP = 1544352683
+SHA256 (nakal-cingb-v0.32_GH0.tar.gz) = aca08f6eba7d94c10195c2f04cf64b6a5fa742dff893b8f8d23c9eac5f8cb39c
+SIZE (nakal-cingb-v0.32_GH0.tar.gz) = 60309
diff --git a/emulators/cingb/pkg-descr b/emulators/cingb/pkg-descr
index 622d7f15c009..d941b8207ed7 100644
--- a/emulators/cingb/pkg-descr
+++ b/emulators/cingb/pkg-descr
@@ -3,4 +3,4 @@ It plays Gameboy and Gameboy Color ROMs, includes a debugger for step-by-step
analysis of Gameboy programs and might be also interesting for educational
purposes.
-WWW: http://cingb.sourceforge.net/
+WWW: https://github.com/nakal/cingb