summaryrefslogtreecommitdiff
path: root/editors/treeform
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-07-06 03:43:08 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-07-06 03:43:08 +0000
commit31292c71a024996f473057498a20c16ff2a6dee2 (patch)
treed99acf9b8f96c844d51305f7a5c744d139823b61 /editors/treeform
parent3530e1a1bfb4bf1941ba87a0cd15da5236892194 (diff)
downloadfreebsd-ports-31292c71a024996f473057498a20c16ff2a6dee2.zip
add treeform 0.9.10
A Linguistic Syntax/Semantics tree drawing editor PR: 114236 Submitted by: Kuan-Chung Chiu <buganini@gmail.com>
Diffstat (limited to 'editors/treeform')
-rw-r--r--editors/treeform/Makefile36
-rw-r--r--editors/treeform/distinfo3
-rw-r--r--editors/treeform/files/treeform.in6
-rw-r--r--editors/treeform/pkg-descr5
-rw-r--r--editors/treeform/pkg-message5
-rw-r--r--editors/treeform/pkg-plist169
6 files changed, 224 insertions, 0 deletions
diff --git a/editors/treeform/Makefile b/editors/treeform/Makefile
new file mode 100644
index 000000000000..7fa3b52b5d33
--- /dev/null
+++ b/editors/treeform/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: treeform
+# Date created: 3 July 2007
+# Whom: buganini@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= treeform
+PORTVERSION= 0.9.10
+CATEGORIES= editors java
+MASTER_SITES= SF
+DISTNAME= TreeForm_9_10
+
+MAINTAINER= buganini@gmail.com
+COMMENT= A Linguistic Syntax/Semantics tree drawing editor
+
+USE_ZIP= yes
+NO_BUILD= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5+
+SUB_FILES= treeform
+
+WRKSRC= ${WRKDIR}/TreeForm
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/treeform ${PREFIX}/bin
+ cd ${WRKSRC} \
+ && ${INSTALL_DATA} TreeForm.jar ${JAVAJARDIR} \
+ && ${COPYTREE_SHARE} about.htm ${DATADIR} \
+ && ${COPYTREE_SHARE} help ${DATADIR} \
+ && ${COPYTREE_SHARE} image ${DATADIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/editors/treeform/distinfo b/editors/treeform/distinfo
new file mode 100644
index 000000000000..ffad098c9a96
--- /dev/null
+++ b/editors/treeform/distinfo
@@ -0,0 +1,3 @@
+MD5 (TreeForm_9_10.zip) = cd17d1c3cecc0818deb68035958f63fd
+SHA256 (TreeForm_9_10.zip) = 085363dc8fdfe60143122b1e9260d21f0cf0d0f76ea02e5a4319d7e8d47e5d9e
+SIZE (TreeForm_9_10.zip) = 5232545
diff --git a/editors/treeform/files/treeform.in b/editors/treeform/files/treeform.in
new file mode 100644
index 000000000000..967a4ee26e25
--- /dev/null
+++ b/editors/treeform/files/treeform.in
@@ -0,0 +1,6 @@
+#!/bin/sh
+LANG=C
+LC_ALL=C
+VM_ARGS="-Xmx256m -Xms64m"
+cd "%%DATADIR%%"
+java ${VM_ARGS} -jar "%%JAVAJARDIR%%/TreeForm.jar"
diff --git a/editors/treeform/pkg-descr b/editors/treeform/pkg-descr
new file mode 100644
index 000000000000..171aff237000
--- /dev/null
+++ b/editors/treeform/pkg-descr
@@ -0,0 +1,5 @@
+TreeForm Syntax tree drawing software is a Linguistic Syntax/Semantics tree
+drawing editor. Designed for graphical n-ary tree drawing. More improvements
+to come. Recently added Japanese and Chinese language keyboard support.
+
+WWW: http://treeform.blogspot.com/
diff --git a/editors/treeform/pkg-message b/editors/treeform/pkg-message
new file mode 100644
index 000000000000..9800d20fab09
--- /dev/null
+++ b/editors/treeform/pkg-message
@@ -0,0 +1,5 @@
+*******************************************************************************
+TreeForm works best if you have the DOULOS SIL font installed from:
+
+http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&item_id=DoulosSIL_download#dc835487
+*******************************************************************************
diff --git a/editors/treeform/pkg-plist b/editors/treeform/pkg-plist
new file mode 100644
index 000000000000..7841dda59ed2
--- /dev/null
+++ b/editors/treeform/pkg-plist
@@ -0,0 +1,169 @@
+bin/treeform
+%%JAVAJARDIR%%/TreeForm.jar
+%%DATADIR%%/help/.DS_Store
+%%DATADIR%%/help/help.htm
+%%DATADIR%%/image/.DS_Store
+%%DATADIR%%/image/bold16.gif
+%%DATADIR%%/image/bold24.gif
+%%DATADIR%%/image/copy_clipboard16.gif
+%%DATADIR%%/image/copy_clipboard16_d.gif
+%%DATADIR%%/image/copy_clipboard16_h.gif
+%%DATADIR%%/image/copy_clipboard24.gif
+%%DATADIR%%/image/copy_clipboard24_d.gif
+%%DATADIR%%/image/copy_clipboard24_h.gif
+%%DATADIR%%/image/copy_tree16.gif
+%%DATADIR%%/image/copy_tree16_d.gif
+%%DATADIR%%/image/copy_tree16_h.gif
+%%DATADIR%%/image/copy_tree24.gif
+%%DATADIR%%/image/copy_tree24_d.gif
+%%DATADIR%%/image/copy_tree24_d_low.gif
+%%DATADIR%%/image/copy_tree24_h.gif
+%%DATADIR%%/image/cut_clipboard16.gif
+%%DATADIR%%/image/cut_clipboard16_d.gif
+%%DATADIR%%/image/cut_clipboard16_h.gif
+%%DATADIR%%/image/cut_clipboard24.gif
+%%DATADIR%%/image/cut_clipboard24_d.gif
+%%DATADIR%%/image/cut_clipboard24_h.gif
+%%DATADIR%%/image/deep_structure16.gif
+%%DATADIR%%/image/deep_structure16_d.gif
+%%DATADIR%%/image/deep_structure16_h.gif
+%%DATADIR%%/image/deep_structure24.gif
+%%DATADIR%%/image/deep_structure24_d.gif
+%%DATADIR%%/image/deep_structure24_h.gif
+%%DATADIR%%/image/delete_x16.gif
+%%DATADIR%%/image/delete_x16_d.gif
+%%DATADIR%%/image/delete_x16_h.gif
+%%DATADIR%%/image/delete_x24.gif
+%%DATADIR%%/image/delete_x24_d.gif
+%%DATADIR%%/image/delete_x24_h.gif
+%%DATADIR%%/image/export16.gif
+%%DATADIR%%/image/export16_d.gif
+%%DATADIR%%/image/export16_h.gif
+%%DATADIR%%/image/export24.gif
+%%DATADIR%%/image/export24_d.gif
+%%DATADIR%%/image/export24_h.gif
+%%DATADIR%%/image/italics16.gif
+%%DATADIR%%/image/italics24.gif
+%%DATADIR%%/image/labelled_bracket16.gif
+%%DATADIR%%/image/labelled_bracket16_h.gif
+%%DATADIR%%/image/labelled_bracket16_p.gif
+%%DATADIR%%/image/labelled_bracket24.gif
+%%DATADIR%%/image/labelled_bracket24_h.gif
+%%DATADIR%%/image/labelled_bracket24_p.gif
+%%DATADIR%%/image/logical_form16.gif
+%%DATADIR%%/image/logical_form16_d.gif
+%%DATADIR%%/image/logical_form16_h.gif
+%%DATADIR%%/image/print16.gif
+%%DATADIR%%/image/logical_form24.gif
+%%DATADIR%%/image/logical_form24_d.gif
+%%DATADIR%%/image/logical_form24_h.gif
+%%DATADIR%%/image/new_document16.gif
+%%DATADIR%%/image/new_document16_d.gif
+%%DATADIR%%/image/new_document16_h.gif
+%%DATADIR%%/image/new_document24.gif
+%%DATADIR%%/image/new_document24_d.gif
+%%DATADIR%%/image/new_document24_h.gif
+%%DATADIR%%/image/open_document16.gif
+%%DATADIR%%/image/open_document16_d.gif
+%%DATADIR%%/image/open_document16_h.gif
+%%DATADIR%%/image/open_document24.gif
+%%DATADIR%%/image/open_document24_d.gif
+%%DATADIR%%/image/open_document24_h.gif
+%%DATADIR%%/image/paste_clipboard16.gif
+%%DATADIR%%/image/print24.gif
+%%DATADIR%%/image/paste_clipboard16_d.gif
+%%DATADIR%%/image/paste_clipboard16_h.gif
+%%DATADIR%%/image/paste_clipboard24.gif
+%%DATADIR%%/image/paste_clipboard24_d.gif
+%%DATADIR%%/image/paste_clipboard24_h.gif
+%%DATADIR%%/image/print16_d.gif
+%%DATADIR%%/image/print16_h.gif
+%%DATADIR%%/image/print24_d.gif
+%%DATADIR%%/image/print24_h.gif
+%%DATADIR%%/image/print_preview16.gif
+%%DATADIR%%/image/print_preview16_d.gif
+%%DATADIR%%/image/print_preview16_h.gif
+%%DATADIR%%/image/print_preview24.gif
+%%DATADIR%%/image/print_preview24_d.gif
+%%DATADIR%%/image/print_preview24_h.gif
+%%DATADIR%%/image/properties_doc16.gif
+%%DATADIR%%/image/properties_doc16_d.gif
+%%DATADIR%%/image/properties_doc16_h.gif
+%%DATADIR%%/image/properties_doc24b.gif
+%%DATADIR%%/image/properties_doc24b_d.gif
+%%DATADIR%%/image/properties_doc24b_h.gif
+%%DATADIR%%/image/redo16.gif
+%%DATADIR%%/image/redo16_d.gif
+%%DATADIR%%/image/redo16_h.gif
+%%DATADIR%%/image/redo24.gif
+%%DATADIR%%/image/redo24_d.gif
+%%DATADIR%%/image/redo24_h.gif
+%%DATADIR%%/image/save16.gif
+%%DATADIR%%/image/save16_d.gif
+%%DATADIR%%/image/save16_h.gif
+%%DATADIR%%/image/save24.gif
+%%DATADIR%%/image/save24_d.gif
+%%DATADIR%%/image/save24_h.gif
+%%DATADIR%%/image/saveall16.gif
+%%DATADIR%%/image/saveall16_d.gif
+%%DATADIR%%/image/saveall16_h.gif
+%%DATADIR%%/image/saveall24.gif
+%%DATADIR%%/image/saveall24_d.gif
+%%DATADIR%%/image/saveall24_h.gif
+%%DATADIR%%/image/saveas16.gif
+%%DATADIR%%/image/saveas16_d.gif
+%%DATADIR%%/image/saveas16_h.gif
+%%DATADIR%%/image/saveas24.gif
+%%DATADIR%%/image/saveas24_d.gif
+%%DATADIR%%/image/saveas24_h.gif
+%%DATADIR%%/image/strikethrough16.gif
+%%DATADIR%%/image/strikethrough24.gif
+%%DATADIR%%/image/subscript16.gif
+%%DATADIR%%/image/subscript24.gif
+%%DATADIR%%/image/sunset800.jpg
+%%DATADIR%%/image/superscript16.gif
+%%DATADIR%%/image/superscript24.gif
+%%DATADIR%%/image/surface_structure16.gif
+%%DATADIR%%/image/surface_structure16_d.gif
+%%DATADIR%%/image/surface_structure16_h.gif
+%%DATADIR%%/image/surface_structure24.gif
+%%DATADIR%%/image/surface_structure24_d.gif
+%%DATADIR%%/image/surface_structure24_h.gif
+%%DATADIR%%/image/Thumbs.db
+%%DATADIR%%/image/TreeForm.jpg
+%%DATADIR%%/image/treeform.PNG
+%%DATADIR%%/image/TreeForm128.icns
+%%DATADIR%%/image/TreeForm128.ico
+%%DATADIR%%/image/TreeForm256.icns
+%%DATADIR%%/image/TreeForm256.ico
+%%DATADIR%%/image/TreeFormBig
+%%DATADIR%%/image/treeformbig.gif
+%%DATADIR%%/image/TreeFormBig.ico
+%%DATADIR%%/image/TreeFormBigNew.gif
+%%DATADIR%%/image/TreeFormNew.gif
+%%DATADIR%%/image/TreeFormSmall
+%%DATADIR%%/image/TreeFormSmall.icns
+%%DATADIR%%/image/underline16.gif
+%%DATADIR%%/image/underline24.gif
+%%DATADIR%%/image/undo16.gif
+%%DATADIR%%/image/undo16_d.gif
+%%DATADIR%%/image/undo16_h.gif
+%%DATADIR%%/image/undo24.gif
+%%DATADIR%%/image/undo24_d.gif
+%%DATADIR%%/image/undo24_h.gif
+%%DATADIR%%/image/zoomminus16.gif
+%%DATADIR%%/image/zoomminus16_d.gif
+%%DATADIR%%/image/zoomminus16_h.gif
+%%DATADIR%%/image/zoomminus24.gif
+%%DATADIR%%/image/zoomminus24_d.gif
+%%DATADIR%%/image/zoomminus24_h.gif
+%%DATADIR%%/image/zoomplus16.gif
+%%DATADIR%%/image/zoomplus16_d.gif
+%%DATADIR%%/image/zoomplus16_h.gif
+%%DATADIR%%/image/zoomplus24.gif
+%%DATADIR%%/image/zoomplus24_d.gif
+%%DATADIR%%/image/zoomplus24_h.gif
+%%DATADIR%%/about.htm
+@dirrm %%DATADIR%%/help
+@dirrm %%DATADIR%%/image
+@dirrm %%DATADIR%%