summaryrefslogtreecommitdiff
path: root/editors/texworks/Makefile
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2012-12-06 15:06:39 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2012-12-06 15:06:39 +0000
commita2d15ac732c6365ced0f245e6b6cde6d98f6f165 (patch)
tree24f6da022b11868f7095cf6f7f65201e8ad09569 /editors/texworks/Makefile
parent7e06c048aab2cd22780f9d77aa5a7f2dcfad5947 (diff)
downloadfreebsd-ports-a2d15ac732c6365ced0f245e6b6cde6d98f6f165.zip
- Update to 0.4.4
Release announcement: http://tug.org/pipermail/texworks/2012q2/005468.html - Fix DESKTOP entry - Install MAN1 page - Respect NOPORTDOCS Feature safe: yes
Diffstat (limited to 'editors/texworks/Makefile')
-rw-r--r--editors/texworks/Makefile38
1 files changed, 26 insertions, 12 deletions
diff --git a/editors/texworks/Makefile b/editors/texworks/Makefile
index 0cdff0da76ac..ce1470854138 100644
--- a/editors/texworks/Makefile
+++ b/editors/texworks/Makefile
@@ -2,41 +2,55 @@
# $FreeBSD$
PORTNAME= texworks
-PORTVERSION= 0.2.2
-PORTREVISION= 6
+PORTVERSION= 0.4.4
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-r${VCS_REVISION}
MAINTAINER= gahr@FreeBSD.org
COMMENT= Simple TeX front-end program
+LICENSE= GPLv2
+
BUILD_DEPENDS= hunspell:${PORTSDIR}/textproc/hunspell
LIB_DEPENDS= poppler-qt4:${PORTSDIR}/graphics/poppler-qt4
-USE_GMAKE= yes
+USE_GNOME= pkgconfig
MAKE_JOBS_SAFE= yes
USE_QT4= qmake_build gui corelib rcc_build moc_build uic_build \
dbus xml
-
-MAKE_ENV+= QTDIR=${QT_PREFIX}
+QMAKE_ARGS+= INSTALL_PREFIX=${PREFIX} \
+ DATA_DIR=${DATADIR} \
+ DOCS_DIR=${DOCSDIR} \
+ ICON_DIR=${PREFIX}/share/pixmaps \
+ DESKTOP_DIR=${PREFIX}/share/applications \
+ MAN_DIR=${MAN1PREFIX}/man/man1 \
+ TW_DICPATH=${LOCALBASE}/hunspell \
+ TW_HELPPATH=${DOCSDIR}
+
+VCS_REVISION= 1004
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
DESKTOP_ENTRIES="TexWorks" \
"Lowering the entry barrier to the TeX world" \
- "TeXworks.png" \
+ "TeXworks" \
"texworks" \
- "Application;Utility;" \
+ "Utility;" \
false
+
+MAN1= texworks.1
PLIST_FILES= bin/texworks \
share/pixmaps/TeXworks.png
+PORTDOCS= *
post-patch:
+ @${REINPLACE_CMD} -e '/zlib/d; s|COPYING ||' ${WRKSRC}/TeXworks.pro
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e '/INSTALLS/s|documentation manual ||' ${WRKSRC}/TeXworks.pro
+.endif
@${REINPLACE_CMD} -e 's|\/usr\/share|\${LOCALBASE}\/share|g' ${WRKSRC}/src/TWUtils.cpp
do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} TeXworks.pro
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/texworks ${PREFIX}/bin/
- ${INSTALL_DATA} ${WRKSRC}/res/images/TeXworks.png ${PREFIX}/share/pixmaps/TeXworks.png
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKE_ARGS} TeXworks.pro
.include <bsd.port.mk>