summaryrefslogtreecommitdiff
path: root/editors/tamago
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
commita3cc513bfc69ef10d52ed310dd9a6e6bb8c57491 (patch)
tree4a6b8513515fb032f2183d945863a1d39dbcd0c1 /editors/tamago
parent7a6d87cd185d39c7023ee32da472cca4f391e7f2 (diff)
downloadfreebsd-ports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.zip
Flavorize and modernize Emacs ports
- Convert USE_EMACS to USES=emacs - Remove editors/emacs-nox11 (refer to nox flavors of editors/emacs and editors/emacs-devel) - Permit default Emacs flavor to be specified in make.conf - Rename japanese/migemo-emacs23 to japanese/migemo-emacs - Update and simplify audio/emms and fix build on FreeBSD 10 [1] - Update databases/bbdd and fix build on FreeBSD 10 [1] - Update editors/emacs-devel - Ensure Makefile shell commands that change directory are executed in a subshell - Silence some portlint warnings [1] By not depending on base texinfo PR: 225404 Reviewed by: antoine Approved by: portmgr (mat) ashish (maintainer) Differential Revision: https://reviews.freebsd.org/D13506
Diffstat (limited to 'editors/tamago')
-rw-r--r--editors/tamago/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/editors/tamago/Makefile b/editors/tamago/Makefile
index 5757cbba3d57..64bb067b13c5 100644
--- a/editors/tamago/Makefile
+++ b/editors/tamago/Makefile
@@ -3,19 +3,21 @@
PORTNAME= tamago
PORTVERSION= 4.0.6.0.20041122.19.14
-PORTREVISION= 2
DISTVERSIONPREFIX= v
+PORTREVISION= 3
CATEGORIES= editors elisp
-PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Egg V4, Multilingual Input Method for Emacsen
LICENSE= GPLv2
-USE_EMACS= yes
+USES= emacs
+EMACS_FLAVORS_EXCLUDE= devel_full # fails to build
USE_GITHUB= yes
GH_ACCOUNT= hrs-allbsd
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-lispdir="${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}"
CONFIGURE_ENV= EMACS="${EMACS_CMD}"