summaryrefslogtreecommitdiff
path: root/editors/pdfedit
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-08-25 05:00:37 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-08-25 05:00:37 +0000
commit3f41789a406f58c24ce83a474c3cc198665b7c7d (patch)
tree0f95ff5fb446e0b4e5409ffd6bbae6ead0a09140 /editors/pdfedit
parent12dd761ab2525359af93ca2101e33effde609f61 (diff)
downloadfreebsd-ports-3f41789a406f58c24ce83a474c3cc198665b7c7d.zip
editors/pdfedit: Fix build with Clang 6
/wrkdirs/usr/ports/editors/pdfedit/work/pdfedit-0.4.5/src/kernel/cxref.h:422:18: error: non-constant-expression cannot be narrowed from type 'pdfobjects::IndiRef::ObjNum' (aka 'unsigned int') to 'int' in initializer list [-Wc++11-narrowing] ::Ref xpdfRef={ref.num, ref.gen}; ^~~~~~~ /wrkdirs/usr/ports/editors/pdfedit/work/pdfedit-0.4.5/src/kernel/cxref.h:422:18: note: insert an explicit cast to silence this issue ::Ref xpdfRef={ref.num, ref.gen}; ^~~~~~~ static_cast<int>( ) http://beefy11.nyi.freebsd.org/data/head-i386-default/p477696_s338122/logs/errors/pdfedit-0.4.5_11.log PR: 225295 Reported by: O. Hartmann <ohartmann@walstatt.org>
Diffstat (limited to 'editors/pdfedit')
-rw-r--r--editors/pdfedit/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/editors/pdfedit/Makefile b/editors/pdfedit/Makefile
index 5eea7af8c181..694c5cd00482 100644
--- a/editors/pdfedit/Makefile
+++ b/editors/pdfedit/Makefile
@@ -21,6 +21,7 @@ LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
libt1.so:devel/t1lib
USES= gmake perl5 tar:bzip2
+USE_CXXSTD= c++98
USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-root-dir=${STAGEDIR} \