summaryrefslogtreecommitdiff
path: root/editors/pdfedit
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2009-02-28 20:22:16 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2009-02-28 20:22:16 +0000
commit10812caef78d14cb9b79a1813eaafd9f28ea93d5 (patch)
tree4483b11842ef0b8708ebf0ca542e19ec9024ec7b /editors/pdfedit
parentd8e569231ab31c5408cf61c01c3877bd91ddadf5 (diff)
downloadfreebsd-ports-10812caef78d14cb9b79a1813eaafd9f28ea93d5.zip
- Fix for upcoming Boost 1.37 update.
PR: ports/132186 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru>
Diffstat (limited to 'editors/pdfedit')
-rw-r--r--editors/pdfedit/Makefile2
-rw-r--r--editors/pdfedit/files/patch-src-kernel-cpdf.cc29
2 files changed, 30 insertions, 1 deletions
diff --git a/editors/pdfedit/Makefile b/editors/pdfedit/Makefile
index 61d3868ceed2..190284d5cbc3 100644
--- a/editors/pdfedit/Makefile
+++ b/editors/pdfedit/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pdfedit
PORTVERSION= 0.4.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= editors
MASTER_SITES= SF
diff --git a/editors/pdfedit/files/patch-src-kernel-cpdf.cc b/editors/pdfedit/files/patch-src-kernel-cpdf.cc
new file mode 100644
index 000000000000..e1229d55d18b
--- /dev/null
+++ b/editors/pdfedit/files/patch-src-kernel-cpdf.cc
@@ -0,0 +1,29 @@
+--- src/kernel/cpdf.cc.orig 2008-02-22 11:42:07.000000000 +0300
++++ src/kernel/cpdf.cc 2009-02-28 05:38:20.000000000 +0300
+@@ -2347,7 +2347,7 @@
+ instance->file = file;
+ kernelPrintDbg(debug::DBG_INFO, "Instance created successfully openMode=" << openMode);
+ return instance;
+- }catch(exception &e)
++ }catch(std::exception &e)
+ {
+ kernelPrintDbg(DBG_CRIT, "Pdf instance creation failed. cause="<<e.what());
+ string what=string("CPdf open failed. reason=")+e.what();
+@@ -2631,7 +2631,7 @@
+ try
+ {
+ minPos = getNodePosition(*this, newValue, &nodeCountCache);
+- }catch(exception &e)
++ }catch(std::exception &e)
+ {
+ // position can't be determined
+ // no special handling is needed, minPos keeps its value
+@@ -2690,7 +2690,7 @@
+ kernelPrintDbg(DBG_WARN, "page with original position="<<i->first<<" is ambiguous. Invalidating.");
+ // page position is ambiguous and so it has to be invalidate
+ i->second->invalidate();
+- }catch(exception & e)
++ }catch(std::exception & e)
+ {
+ kernelPrintDbg(DBG_CRIT, "Unexpected error. cause="<<e.what());
+ assert(!"Possibly bug.");