summaryrefslogtreecommitdiff
path: root/editors/nano
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-11-24 02:01:42 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-11-24 02:01:42 +0000
commitae9961ddce68beecd049827f7abb071cff309e9d (patch)
tree1a09c232b8f6ff0579bfaea86cf759eef2ddf17c /editors/nano
parente0ae4b3dc35324166983d24028e1452f73748832 (diff)
downloadfreebsd-ports-ae9961ddce68beecd049827f7abb071cff309e9d.zip
- Use options helpers
- Simplify Makefile - Take maintainership
Diffstat (limited to 'editors/nano')
-rw-r--r--editors/nano/Makefile29
1 files changed, 7 insertions, 22 deletions
diff --git a/editors/nano/Makefile b/editors/nano/Makefile
index 2a87932abdf6..f11da47852f6 100644
--- a/editors/nano/Makefile
+++ b/editors/nano/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= http://www.nano-editor.org/dist/v2.2/ \
${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danilo@FreeBSD.org
COMMENT= Nano's ANOther editor, an enhanced free Pico clone
LICENSE= GPLv3
@@ -17,36 +17,21 @@ CONFLICTS= nano-devel-2*
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --docdir=${DOCSDIR}
+CONFIGURE_ARGS= --docdir=${DOCSDIR} --enable-utf8
+MAKE_ARGS+= install_htmlmanDATA=install-htmlmanDATA
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDOCS}
-MAKE_ARGS+= install_htmlmanDATA=install-htmlmanDATA
-.else
-MAKE_ARGS+= install_htmlmanDATA=""
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
INFO= nano
PORTSCOUT= limitw:1,even
-.include <bsd.port.pre.mk>
-
-CONFIGURE_ARGS+=--enable-utf8
-
post-build:
cd ${WRKSRC}/doc/man; ${REINPLACE_CMD} \
-e 's:SYSCONFDIR:${PREFIX}/etc:g' \
@@ -59,4 +44,4 @@ post-install:
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/nanorc.sample ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>