summaryrefslogtreecommitdiff
path: root/editors/calligra
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-09-03 15:44:13 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-09-03 15:44:13 +0000
commitf358732b18188c53c785bb25749c9e2546a6efe9 (patch)
tree05f83f4626cc97a41e5a29dca71409286f46ae35 /editors/calligra
parentf8ac405eb53d03a5b0bb00134ceb82a6474b6743 (diff)
downloadfreebsd-ports-f358732b18188c53c785bb25749c9e2546a6efe9.zip
Uses/iconv.mk: Set iconv-related CMake variables.
The way we deal with iconv in base and ports across different FreeBSD releases is complicated: 9.x does not have iconv.h in base, 10.1 has it with a different prototype for iconv(3) and later versions have the right iconv(3) prototype. And, in some cases (USES=iconv:{translit,wchar_t}), we must always use the libiconv port. This is why there are so many checks in Uses/iconv.mk: we need to know the situation we currently have in order to decide whether to pull iconv from converters/libiconv, whether to just use its header (and pull the library from base) or whether to use everything from base. r384038 adjusted several CMake-based ports, but did so in a way that was not very scalable and required a few intrusive patches to some ports. Most ports that have both USES=cmake and USES=iconv use variations of FindIconv.cmake that behave similarly. This change passes the header and library values we really want to use to CMake using the most common variable names, bypassing the calls to find_path() and find_library() that would sometimes end up finding the wrong file. The few ports that use different variable names have had their Makefiles adjusted (we manually pass the values we want via CMAKE_ARGS). Other changes: - chinese/fcitx: Explicitly set LIBICONV_LIBC_HAS_ICONV_OPEN=OFF as we always want the version from ports because of USES=iconv:wchar_t. - editors/calligra: Explicitly use iconv:translit because Kexi needs it. - irc/weechat and irc/weechat-devel: The FindIconv.cmake patches could not be entirely removed because the check_library_exists() calls are wrong. Sent upstream: https://github.com/weechat/weechat/pull/513 - textproc/ctpp2: Use iconv:translit when the TRANSLITERATE option is used. PORTREVISION has been bumped in editors/calligra and textproc/ctpp2 because their dependency list has changed in 10.2 and later as the ports version is always used now. PR: 202798 Reviewed by: antoine, tijl Approved by: portmgr (antoine)
Diffstat (limited to 'editors/calligra')
-rw-r--r--editors/calligra/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index 76001990f411..b5dc8211c37a 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -2,7 +2,7 @@
PORTNAME= calligra
PORTVERSION= ${CALLIGRA_VERSION}
-PORTREVISION= 17
+PORTREVISION= 18
CATEGORIES= editors kde
MASTER_SITES= KDE/${CALLIGRA_BRANCH}/${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= KDE
@@ -42,8 +42,8 @@ USE_QT4= corelib dbus designer_build gui opengl phonon porting_build \
qt3support qtestlib_build script sql svg webkit xml xmlpatterns \
moc_build qmake_build rcc_build uic_build uic3_build
USE_SQLITE= 3
-USES= cmake:outsource cpe compiler:c++11-lang iconv jpeg perl5 pkgconfig tar:xz\
- shared-mime-info
+USES= cmake:outsource cpe compiler:c++11-lang iconv:translit jpeg \
+ perl5 pkgconfig shared-mime-info tar:xz
CMAKE_ARGS= -DCMAKE_INCLUDE_PATH:STRING="${QT_INCDIR} ${LOCALBASE}/include" \
-DPRODUCTSET:STRING="DESKTOP"
USE_LDCONFIG= yes