summaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2020-03-24 21:43:36 +0000
committerMatthias Andree <mandree@FreeBSD.org>2020-03-24 21:43:36 +0000
commitd44b399a7cec019bcc47619881174dc3c1539e39 (patch)
treec7e99bb94b20b45d6d5461f66a4f4ea4576d590e /dns
parent119ff61bcaae81fe12f7c76a4b4e0dc35ccaf6f0 (diff)
downloadfreebsd-ports-d44b399a7cec019bcc47619881174dc3c1539e39.zip
dns/inadyn: Update to 2.6
Note that the UIDs/GIDs were meaning to add 455 as the ID, but typed 445 in the patch. I've corrected the IDs to 455. I've also elided one blank line between the _DEPENDS lines to please portlint. Other than that, test builds succeeded on 11.3 (i386, amd64), 12.1 (i386, amd64, mips64, aarch64). PR: 241426 Submitted by: Colin T. <bugzilla@nulldir.e4ward.com> Reviewed by: Daniel Engberg Approved by: samm@ (maintainer timeout, >4 months)
Diffstat (limited to 'dns')
-rw-r--r--dns/inadyn/Makefile56
-rw-r--r--dns/inadyn/distinfo5
-rw-r--r--dns/inadyn/files/inadyn.in35
-rw-r--r--dns/inadyn/files/patch-examples_README.md29
-rw-r--r--dns/inadyn/files/patch-examples_inadyn.conf8
-rw-r--r--dns/inadyn/files/patch-man__inadyn.836
-rw-r--r--dns/inadyn/files/patch-man_inadyn.829
-rw-r--r--dns/inadyn/files/patch-man_inadyn.conf.511
-rw-r--r--dns/inadyn/files/patch-readme.html39
-rw-r--r--dns/inadyn/files/patch-src__dyndns.h12
-rw-r--r--dns/inadyn/pkg-plist15
11 files changed, 150 insertions, 125 deletions
diff --git a/dns/inadyn/Makefile b/dns/inadyn/Makefile
index d12e5c936946..290c09c7284c 100644
--- a/dns/inadyn/Makefile
+++ b/dns/inadyn/Makefile
@@ -2,41 +2,47 @@
# $FreeBSD$
PORTNAME= inadyn
-PORTVERSION= 1.96.2
-PORTREVISION= 3
+PORTVERSION= 2.6
CATEGORIES= dns
-MASTER_SITES= http://www.inatech.eu/inadyn/ \
- LOCAL/dhn
-DISTNAME= ${PORTNAME}.v${PORTVERSION}
+MASTER_SITES= https://github.com/troglobit/inadyn/releases/download/v${PORTVERSION}/
MAINTAINER= samm@FreeBSD.org
COMMENT= Dynamic DNS update client
-USES= dos2unix gmake zip
-USE_RC_SUBR= inadyn
-MAKEFILE= makefile
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libconfuse.so:devel/libconfuse
+RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss
+
+USES= pkgconfig
-PORTDOCS= readme.html
-PLIST_FILES= bin/inadyn man/man5/inadyn.conf.5.gz man/man8/inadyn.8.gz
+GNU_CONFIGURE= yes
+
+USERS= inadyn
+GROUPS= inadyn
+
+USE_RC_SUBR= inadyn
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFAULT= OPENSSL
+OPTIONS_SINGLE= TLS
+OPTIONS_SINGLE_TLS= GNUTLS OPENSSL
-post-extract:
- @${MV} ${WRKDIR}/${PORTNAME} ${WRKSRC}
- @${RM} ${WRKSRC}/bin/linux/inadyn
+GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
+OPENSSL_USES= ssl
+OPENSSL_CONFIGURE_ENABLE= openssl
+OPENSSL_CONFIGURE_ON= OpenSSL_CFLAGS=-I${OPENSSLINC} OpenSSL_LIBS="-L${OPENSSLLIB} -lssl"
post-patch:
- @${REINPLACE_CMD} -e 's|gcc|$$\(CC\)|g' ${WRKSRC}/makefile
@${REINPLACE_CMD} -e "s,%%PREFIX%%,${PREFIX},g" \
- ${WRKSRC}/man/inadyn.8 ${WRKSRC}/readme.html \
- ${WRKSRC}/src/dyndns.h
-
-do-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} -p ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/linux/inadyn ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/man/inadyn.8 ${STAGEDIR}${MANPREFIX}/man/man8
- ${INSTALL_MAN} ${WRKSRC}/man/inadyn.conf.5 \
- ${STAGEDIR}${MANPREFIX}/man/man5
+ ${WRKSRC}/man/inadyn.8 ${WRKSRC}/man/inadyn.conf.5 \
+ ${WRKSRC}/examples/README.md ${WRKSRC}/examples/inadyn.conf
+
+post-install:
+ ${MV} ${STAGEDIR}${DOCSDIR}/examples ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${STAGEDIR}${EXAMPLESDIR}/inadyn.conf ${STAGEDIR}${PREFIX}/etc/inadyn.conf.sample
+ ${MKDIR} ${STAGEDIR}/var/cache/inadyn
+ ${MKDIR} ${STAGEDIR}/var/run/inadyn
.include <bsd.port.mk>
diff --git a/dns/inadyn/distinfo b/dns/inadyn/distinfo
index 115109836baa..cef371f0a063 100644
--- a/dns/inadyn/distinfo
+++ b/dns/inadyn/distinfo
@@ -1,2 +1,3 @@
-SHA256 (inadyn.v1.96.2.zip) = 981f29d12415637c8e3ad747c204a599ddb900360d04a9b4c351d54db3d2321c
-SIZE (inadyn.v1.96.2.zip) = 110170
+TIMESTAMP = 1584452320
+SHA256 (inadyn-2.6.tar.gz) = 01eb4736423b329729ec5852a357966589127325521ab6508ceacf7470e3ea6d
+SIZE (inadyn-2.6.tar.gz) = 588726
diff --git a/dns/inadyn/files/inadyn.in b/dns/inadyn/files/inadyn.in
index 8f70254405ea..e8ba9ce841c0 100644
--- a/dns/inadyn/files/inadyn.in
+++ b/dns/inadyn/files/inadyn.in
@@ -9,15 +9,12 @@
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
# to enable this service:
#
-# inadyn_enable="YES"
-#
-# Reccomend using the inadyn.conf over inadyn_flags. However, inadyn_flags will
-# take priority the configuration file by upstream's design. Any command
-# line arguement (and thus inadyn_flags) will cause inadyn.conf to be ignored
-# completely.
-# See inadyn(8) for inadyn_flags and inadyn.conf syntax.
-#
-# Don't forget to include --background in either method!
+# inadyn_enable (bool): Set it to "YES" to enable inadyn
+# Default is "NO"
+# inadyn_config (str): Set full path to configuration file.
+# Default is "%%PREFIX%%/etc/inadyn.conf"
+# inadyn_pidfile (str): Set full path to pid file.
+# Default is "/var/run/inadyn/inadyn.pid"
#
. /etc/rc.subr
@@ -25,10 +22,26 @@
name="inadyn"
rcvar=inadyn_enable
-command=%%PREFIX%%/bin/${name}
+start_precmd="inadyn_checkconfig"
+restart_precmd="inadyn_checkconfig"
+configtest_precmd="inadyn_checkconfig"
+extra_commands="configtest"
load_rc_config $name
-: ${inadyn_enable="NO"}
+: ${inadyn_enable:="NO"}
+: ${inadyn_config:="%%PREFIX%%/etc/inadyn.conf"}
+: ${inadyn_pidfile:="/var/run/inadyn/inadyn.pid"}
+
+command=%%PREFIX%%/sbin/inadyn
+command_args="-p inadyn:inadyn -f ${inadyn_config} -P ${inadyn_pidfile}"
+pidfile=${inadyn_pidfile}
+required_files=${inadyn_config}
+
+inadyn_checkconfig()
+{
+ echo "Performing sanity check on ${name} configuration:"
+ eval ${command} ${command_args} --check-config
+}
run_rc_command "$1"
diff --git a/dns/inadyn/files/patch-examples_README.md b/dns/inadyn/files/patch-examples_README.md
new file mode 100644
index 000000000000..21e801df3efa
--- /dev/null
+++ b/dns/inadyn/files/patch-examples_README.md
@@ -0,0 +1,29 @@
+--- examples/README.md.orig 2019-10-21 13:57:28 UTC
++++ examples/README.md
+@@ -1,4 +1,4 @@
+-Example /etc/inadyn.conf files
++Example %%PREFIX%%/etc/inadyn.conf files
+ ==============================
+
+ This directory holds a few example configuration files for common
+@@ -11,16 +11,16 @@ https://gitub.com/troglobit/inadyn
+ Usage
+ -----
+
+-Simply copy the desired example to /etc/inadyn.conf, edit it with
++Simply copy the desired example to %%PREFIX%%/etc/inadyn.conf, edit it with
+ your hostname, username, and password and then start Inadyn.
+
+
+ Example
+ -------
+
+- user@example:~$ sudo cp freedns.conf /etc/inadyn.conf
+- user@example:~$ sudo chmod 600 /etc/inadyn.conf
+- user@example:~$ sudo vim /etc/inadyn.conf
++ user@example:~$ sudo cp freedns.conf %%PREFIX%%/etc/inadyn.conf
++ user@example:~$ sudo chmod 600 %%PREFIX%%/etc/inadyn.conf
++ user@example:~$ sudo vim %%PREFIX%%/etc/inadyn.conf
+ [Change username, password and hostname]
+ user@example:~$ sudo inadyn
+ user@example:~$
diff --git a/dns/inadyn/files/patch-examples_inadyn.conf b/dns/inadyn/files/patch-examples_inadyn.conf
new file mode 100644
index 000000000000..4e205be7b0ff
--- /dev/null
+++ b/dns/inadyn/files/patch-examples_inadyn.conf
@@ -0,0 +1,8 @@
+--- examples/inadyn.conf.orig 2019-10-21 13:57:31 UTC
++++ examples/inadyn.conf
+@@ -1,4 +1,4 @@
+-# /etc/inadyn.conf :: v2 configuration file format
++# %%PREFIX%%/etc/inadyn.conf :: v2 configuration file format
+ #
+ # 1. Select a matching DDNS provider to uncomment, this file lists a few
+ # common ones, including a custom one, see inadyn(8) for the full list
diff --git a/dns/inadyn/files/patch-man__inadyn.8 b/dns/inadyn/files/patch-man__inadyn.8
deleted file mode 100644
index 1cf8714108ca..000000000000
--- a/dns/inadyn/files/patch-man__inadyn.8
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naur man/inadyn.8.orig man/inadyn.8
---- man/inadyn.8.orig 2007-08-21 18:48:17.000000000 +0000
-+++ man/inadyn.8 2007-08-21 21:32:49.000000000 +0000
-@@ -88,7 +88,7 @@
- .I \-\-input_file
- The file name that contains inadyn command options exactly as specified in
- the command line syntax (adds to those already present in the cmd
--line). The default configuration file name is '/etc/inadyn.conf'. It is
-+line). The default configuration file name is '%%PREFIX%%/etc/inadyn.conf'. It is
- looked at automatically if
- .B inadyn
- is called without any command line options. The format is as expected
-@@ -204,8 +204,7 @@
- When the user has several names then each name should be followed with
- that name hash string.
- .SH OUTPUT
--.B
--inadyn
-+.B inadyn
- prints a message when the IP is updated. If no update is needed then by
- default it prints a single '.' character, unless \-\-verbose is set to 0.
- Therefore, unless \-\-verbose is set to 0, the log file will contains lot
-@@ -214,9 +213,12 @@
- will print some error messages. Those are harmless and should be
- followed by 'OK' messages after the connection is back up.
-
--.SH Signals
-+.SH SIGNALS
- Any of the SIG_HUP, SIG_INT, SIG_QUIT will cause inadyn to terminate gracefully.
-
-+.SH FILES
-+%%PREFIX%%/etc/inadyn.conf
-+
- .SH "SEE ALSO"
- .SS "Other manual pages"
- The syntax of the optional configuration file is given by
diff --git a/dns/inadyn/files/patch-man_inadyn.8 b/dns/inadyn/files/patch-man_inadyn.8
new file mode 100644
index 000000000000..562087a6a1bb
--- /dev/null
+++ b/dns/inadyn/files/patch-man_inadyn.8
@@ -0,0 +1,29 @@
+--- man/inadyn.8.orig 2019-10-21 13:56:52 UTC
++++ man/inadyn.8
+@@ -140,7 +140,7 @@ supported more command line options, from v2.0
+ has been greatly simplified. See
+ .Xr inadyn.conf 5
+ for details of the
+-.Pa /etc/inadyn.conf
++.Pa %%PREFIX%%/etc/inadyn.conf
+ configuration file format.
+ .Pp
+ .Bl -tag -width Ds
+@@ -207,7 +207,7 @@ is given.
+ Use
+ .Ar FILE
+ for configuration. By default
+-.Pa /etc/inadyn.conf ,
++.Pa %%PREFIX%%/etc/inadyn.conf ,
+ is used. See
+ .Xr inadyn.conf 5
+ for examples.
+@@ -343,7 +343,7 @@ writes its process ID to
+ .Pa /var/run/inadyn.pid
+ .Sh FILES
+ .Bl -tag -width /var/cache/inadyn/freedns.afraid.org.cache -compact
+-.It Pa /etc/inadyn.conf
++.It Pa %%PREFIX%%/etc/inadyn.conf
+ .It Pa /run/inadyn.pid
+ .It Pa /var/cache/inadyn/dyndns.org.cache
+ .It Pa /var/cache/inadyn/freedns.afraid.org.cache
diff --git a/dns/inadyn/files/patch-man_inadyn.conf.5 b/dns/inadyn/files/patch-man_inadyn.conf.5
new file mode 100644
index 000000000000..c716bd3536d3
--- /dev/null
+++ b/dns/inadyn/files/patch-man_inadyn.conf.5
@@ -0,0 +1,11 @@
+--- man/inadyn.conf.5.orig 2019-10-21 13:57:00 UTC
++++ man/inadyn.conf.5
+@@ -16,7 +16,7 @@
+ .Nm inadyn.conf
+ .Nd inadyn DDNS client configuration file
+ .Sh SYNOPSIS
+-.Nm /etc/inadyn.conf
++.Nm %%PREFIX%%/etc/inadyn.conf
+ .Sh DESCRIPTION
+ .Nm inadyn
+ is configured using a simple configuration file. The
diff --git a/dns/inadyn/files/patch-readme.html b/dns/inadyn/files/patch-readme.html
deleted file mode 100644
index 64676dc82e1d..000000000000
--- a/dns/inadyn/files/patch-readme.html
+++ /dev/null
@@ -1,39 +0,0 @@
-diff -Naur readme.html.orig readme.html
---- readme.html.orig 2007-08-21 18:43:09.000000000 +0000
-+++ readme.html 2007-08-21 18:43:22.000000000 +0000
-@@ -195,7 +195,7 @@
- mode, with configuration read from file of an address from
- freedns.afraid.org </span><br>
- Config file (can be placed anywhere, but in linux is convenient in
--default location: /etc/inadyn.conf<br>
-+default location: %%PREFIX%%/etc/inadyn.conf<br>
- Content of cfg file:<br>
- --update_period 60000 <br>
- --alias test.homeip.net,hash_for_host1 <br>
-@@ -204,7 +204,7 @@
- rights, more secure)
- <br>
- Launching of inadyn does not need any params. It looks for
--/etc/inadyn.config
-+%%PREFIX%%/etc/inadyn.config
- <br>
- <br>
- <span style="font-weight: bold;">4. Freedns update in console </span><br>
-@@ -230,7 +230,7 @@
- can be present in the
- command line from a configuration file. This feature allows the user to
- write the options only once, and avoids frequent retyping.<br>
--<i>Default configuration file</i> is /etc/inadyn.conf under Unix
-+<i>Default configuration file</i> is %%PREFIX%%/etc/inadyn.conf under Unix
- systems. <br>
- The location of the config file can be given ot inadyn via --input_file
- option <br>
-@@ -314,7 +314,7 @@
- input file name that
- contains
- inadyn command options (adds to those already present in the cmd line).
--The default configuration file name is '/etc/inadyn.conf'. It is only
-+The default configuration file name is '%%PREFIX%%/etc/inadyn.conf'. It is only
- used if inadyn is called without any command line options. This allows
- inadyn to be called without any arguments. The format is as expected
- for a **NIX config&nbsp; file. See below for details.<br>
diff --git a/dns/inadyn/files/patch-src__dyndns.h b/dns/inadyn/files/patch-src__dyndns.h
deleted file mode 100644
index 0dbd9a7f74c3..000000000000
--- a/dns/inadyn/files/patch-src__dyndns.h
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur src/dyndns.h.orig src/dyndns.h
---- src/dyndns.h.orig 2007-08-21 18:42:48.000000000 +0000
-+++ src/dyndns.h 2007-08-21 18:42:57.000000000 +0000
-@@ -44,7 +44,7 @@
-
- /*test values*/
- #define DYNDNS_DEFAULT_DEBUG_LEVEL 1
--#define DYNDNS_DEFAULT_CONFIG_FILE "/etc/inadyn.conf"
-+#define DYNDNS_DEFAULT_CONFIG_FILE "%%PREFIX%%/etc/inadyn.conf"
-
- #define DYNDNS_MY_USERNAME "test"
- #define DYNDNS_MY_PASSWD "test"
diff --git a/dns/inadyn/pkg-plist b/dns/inadyn/pkg-plist
new file mode 100644
index 000000000000..1a9ba46b5b63
--- /dev/null
+++ b/dns/inadyn/pkg-plist
@@ -0,0 +1,15 @@
+@sample(inadyn,inadyn,640) etc/inadyn.conf.sample
+man/man5/inadyn.conf.5.gz
+man/man8/inadyn.8.gz
+sbin/inadyn
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog.md
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README.md
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/custom.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dyndns.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/freedns.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/freemyip.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inadyn.conf
+@dir(inadyn,inadyn,) /var/cache/inadyn
+@dir(inadyn,inadyn,) /var/run/inadyn