summaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-04-19 06:30:26 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-04-19 06:30:26 +0000
commit6d601a2137ef21d3e6e64d589beea3f99f9f5247 (patch)
tree0125cd966dc0472102612fae950ee6b1cac7e70e /dns
parent31b7d0a959442e25ec8b978c85af05c3783b82f6 (diff)
downloadfreebsd-ports-6d601a2137ef21d3e6e64d589beea3f99f9f5247.zip
dns/nsd: update 4.3.0 -> 4.3.1
BUG FIXES: - Fix #70: error: 'fd_set' undeclared. - Fix #71: error: 'for' loop initial declaration used outside C99 mode. - Fix to move declarations out of for loops in event test too. - Fix #76: cpuid typedef for Hurd, DragonflyBSD compile. - Fix #75: configure test for sched_setaffinity, and use cpuset_setaffinity otherwise. Also test for presence of sysconf. - Fix #74: GNU Hurd fix cast from pointer to integer of different size. - Fix for #74, #75: cpuset test for header contents and provide code. - Fix #78: Fix SO_SETFIB error on FreeBSD. - Merge PR #83 from noloader: Fix GNU HURD sched_setaffinity compile. - Fix #80: NetBSD and implicit declaration of reallocarray. - Fix unknown u_long in util.c for Issue #80 . - Merge PR #86 from noloader: Use precious variables for GREP, EGREP, SED, AWK, LEX and YACC. - For PR #86: Fix that programs loaded after CFLAGS and stuff is set, specifically the compiler, so that it can work if it needs special flags from that. Fix that lex only needs to support -i if actually defined, otherwise the output included in the source tarball can be used. - Merge PR #90 by phicoh: O_CLOEXEC should be FD_CLOEXEC. - Merge PR #92 by tonysgi: Fix typo. - Merge PR #91 by gearnode: nsd-control-setup recreate certificates. The '-r' option recreates certificates. Without it it creates them if they do not exist, and does not modify them otherwise. PR: 245666 Submitted by: Jaap Akkerhuis <jaap@NLnetLabs.nl> (maintainer)
Diffstat (limited to 'dns')
-rw-r--r--dns/nsd/Makefile3
-rw-r--r--dns/nsd/distinfo6
-rw-r--r--dns/nsd/files/patch-server.c11
3 files changed, 4 insertions, 16 deletions
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index 19fa7ad10f00..20d00e791444 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= nsd
-PORTVERSION= 4.3.0
-PORTREVISION= 1
+PORTVERSION= 4.3.1
CATEGORIES= dns
MASTER_SITES= http://www.nlnetlabs.nl/downloads/nsd/ \
ftp://ftp.rhnet.is/pub/nsd/
diff --git a/dns/nsd/distinfo b/dns/nsd/distinfo
index 4badaa71bdf0..c4885fa22d2c 100644
--- a/dns/nsd/distinfo
+++ b/dns/nsd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1584440239
-SHA256 (nsd-4.3.0.tar.gz) = 7a007d655d30f1edd001206839107e651966e1e519d53ba2c036491044111e97
-SIZE (nsd-4.3.0.tar.gz) = 1168198
+TIMESTAMP = 1587237972
+SHA256 (nsd-4.3.1.tar.gz) = f4b34ace6651a81386464cc990f046e7328aa2485274fe8743086997129d8987
+SIZE (nsd-4.3.1.tar.gz) = 1173582
diff --git a/dns/nsd/files/patch-server.c b/dns/nsd/files/patch-server.c
deleted file mode 100644
index b33dbd53131b..000000000000
--- a/dns/nsd/files/patch-server.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- server.c.orig 2020-03-17 10:00:17 UTC
-+++ server.c
-@@ -1104,7 +1104,7 @@ set_setfib(struct nsd_socket *sock)
- {
- #if defined(SO_SETFIB)
- if(setsockopt(sock->s, SOL_SOCKET, SO_SETFIB,
-- (const void *)(uintptr_t)sock->fib, sizeof(sock->fib)) == -1)
-+ (const void *)(uintptr_t)&sock->fib, sizeof(sock->fib)) == -1)
- {
- log_msg(LOG_ERR, "setsockopt(..., %s, %d, ...) failed: %s",
- "SO_SETFIB", sock->fib, strerror(errno));