summaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-06-15 00:00:28 +0200
committerRene Ladan <rene@FreeBSD.org>2023-06-27 21:34:34 +0200
commit3d9a815d9c5acbb71f4bb07738bdeab4879feacb (patch)
treeeb093f22197a2c68a88dd2372ec1922c3f6d3c10 /dns
parentc58ef91e06e8edc4fd8579837f1453b562da3fbb (diff)
downloadfreebsd-ports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.zip
all: remove explicit versions in USES=python for "3.x+"
The logic in USES=python will automatically convert this to 3.8+ by itself. Adjust two ports that only had Python 3.7 mentioned but build fine on Python 3.8 too. finance/quickfix: mark BROKEN with PYTHON libtool: compile: c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++ -DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable -Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi -Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings -Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x -MT _quickfix_la-QuickfixPython.lo -MD -MP -MF .deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp -fPIC -DPIC -o .libs/_quickfix_la-QuickfixPython.o warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean '-Wno-uninitialized'? [-Wunknown-warning-option] QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found ^~~~~~~~~~ 1 warning and 1 error generated. Reviewed by: portmgr, vishwin, yuri Differential Revision: <https://reviews.freebsd.org/D40568>
Diffstat (limited to 'dns')
-rw-r--r--dns/dnsviz/Makefile2
-rw-r--r--dns/dsc/Makefile2
-rw-r--r--dns/knot-resolver/Makefile2
-rw-r--r--dns/ldns/Makefile2
-rw-r--r--dns/py-adns/Makefile2
-rw-r--r--dns/py-aiodns/Makefile2
-rw-r--r--dns/py-cloudflare/Makefile2
-rw-r--r--dns/py-dns-crawler/Makefile2
-rw-r--r--dns/py-dns-lexicon/Makefile2
-rw-r--r--dns/py-dnslib/Makefile2
-rw-r--r--dns/py-dnspython/Makefile2
-rw-r--r--dns/py-easyzone/Makefile2
-rw-r--r--dns/py-idna/Makefile2
-rw-r--r--dns/py-idna_ssl/Makefile2
-rw-r--r--dns/py-localzone/Makefile2
-rw-r--r--dns/py-ns1-python/Makefile2
-rw-r--r--dns/py-publicsuffix/Makefile2
-rw-r--r--dns/py-publicsuffix2/Makefile2
-rw-r--r--dns/py-publicsuffixlist/Makefile2
-rw-r--r--dns/py-py3dns/Makefile2
-rw-r--r--dns/py-pybonjour/Makefile2
-rw-r--r--dns/py-pycares/Makefile2
-rw-r--r--dns/py-pydnstable/Makefile2
-rw-r--r--dns/py-pywdns/Makefile2
-rw-r--r--dns/py-tld/Makefile2
-rw-r--r--dns/py-tldextract/Makefile2
26 files changed, 26 insertions, 26 deletions
diff --git a/dns/dnsviz/Makefile b/dns/dnsviz/Makefile
index 8d3827926a47..b602d0cd0f38 100644
--- a/dns/dnsviz/Makefile
+++ b/dns/dnsviz/Makefile
@@ -14,7 +14,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pygraphviz>=1.1:graphics/py-pygraphviz@${PY_
${PYTHON_PKGNAMEPREFIX}dnspython>=1.11.0:dns/py-dnspython@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}libnacl>=1.5.2:security/py-libnacl@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist distutils concurrent optsuffix
USE_GITHUB= yes
PYDISTUTILS_INSTALLNOSINGLE= yes
diff --git a/dns/dsc/Makefile b/dns/dsc/Makefile
index 4a9e259a4a42..7ce6b094cda1 100644
--- a/dns/dsc/Makefile
+++ b/dns/dsc/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= libpcap>=1.8.1:net/libpcap \
p5-Proc-PID-File>=1.28:devel/p5-Proc-PID-File \
p5-XML-Simple>=2.24:textproc/p5-XML-Simple
-USES= gmake localbase perl5 python:3.6+ shebangfix
+USES= gmake localbase perl5 python shebangfix
USE_RC_SUBR= dsc
SHEBANG_FILES= src/dsc-psl-convert
diff --git a/dns/knot-resolver/Makefile b/dns/knot-resolver/Makefile
index d779f058afbe..a88226c3fdfd 100644
--- a/dns/knot-resolver/Makefile
+++ b/dns/knot-resolver/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= libdnssec.so:dns/knot3-lib \
RUN_DEPENDS= lua51-cqueues>=20200726_1:devel/lua-cqueues@lua51
USES= compiler:c11 libedit libtool luajit meson ncurses ninja \
- pkgconfig python:3.5+,build shebangfix tar:xz
+ pkgconfig python:build shebangfix tar:xz
USE_CXXSTD= c++11
USE_RC_SUBR= krescachegc kresd
diff --git a/dns/ldns/Makefile b/dns/ldns/Makefile
index ea7467407381..95d929869e8b 100644
--- a/dns/ldns/Makefile
+++ b/dns/ldns/Makefile
@@ -59,7 +59,7 @@ DRILL_INSTALL_TARGET= install-drill
EXAMPLES_INSTALL_TARGET= install-examples
.if defined(BUILD_PYLDNS)
-USES+= python:3.6+
+USES+= python
USE_PYTHON= flavors
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
ALL_TARGET= pyldns
diff --git a/dns/py-adns/Makefile b/dns/py-adns/Makefile
index 6a94f0331885..5310d593ed5d 100644
--- a/dns/py-adns/Makefile
+++ b/dns/py-adns/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/GPL
LIB_DEPENDS= libadns.so:dns/adns
-USES= localbase python:3.4+
+USES= localbase python
USE_PYTHON= autoplist distutils
post-patch:
diff --git a/dns/py-aiodns/Makefile b/dns/py-aiodns/Makefile
index 7b2cf16376ae..1532ab44e865 100644
--- a/dns/py-aiodns/Makefile
+++ b/dns/py-aiodns/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycares>4.0.0:dns/py-pycares@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/dns/py-cloudflare/Makefile b/dns/py-cloudflare/Makefile
index 3fdf4bbb3e5f..b4e9b867a4f5 100644
--- a/dns/py-cloudflare/Makefile
+++ b/dns/py-cloudflare/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_F
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>=0:devel/py-yaml@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/dns/py-dns-crawler/Makefile b/dns/py-dns-crawler/Makefile
index d9231fe84bef..78bd7713a3a1 100644
--- a/dns/py-dns-crawler/Makefile
+++ b/dns/py-dns-crawler/Makefile
@@ -31,7 +31,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>=1.3.0:devel/py-asn1crypto@${PY_F
${PYTHON_PKGNAMEPREFIX}requests-toolbelt>=0.9.1:www/py-requests-toolbelt@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rq>=1.2.2:devel/py-rq@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/dns/py-dns-lexicon/Makefile b/dns/py-dns-lexicon/Makefile
index 7f1851f453c8..e384f7ff9bc2 100644
--- a/dns/py-dns-lexicon/Makefile
+++ b/dns/py-dns-lexicon/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4:www/py-beautifulsoup@${PY_F
${PYTHON_PKGNAMEPREFIX}requests>=2:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tldextract>=2:dns/py-tldextract@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/dns/py-dnslib/Makefile b/dns/py-dnslib/Makefile
index 23ca0a5415fb..793291ea4f0f 100644
--- a/dns/py-dnslib/Makefile
+++ b/dns/py-dnslib/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/paulc/dnslib
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/dns/py-dnspython/Makefile b/dns/py-dnspython/Makefile
index f1c6a39bce80..fcdb308fa18f 100644
--- a/dns/py-dnspython/Makefile
+++ b/dns/py-dnspython/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.3:devel/py-setuptools_scm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist concurrent cython distutils
NO_ARCH= yes
diff --git a/dns/py-easyzone/Makefile b/dns/py-easyzone/Makefile
index 4430b83cd5cd..e5b26215fdd3 100644
--- a/dns/py-easyzone/Makefile
+++ b/dns/py-easyzone/Makefile
@@ -14,7 +14,7 @@ LICENSE= MIT
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=1.9.4:dns/py-dnspython@${PY_FLAVOR}
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= python:3.6+
+USES= python
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
diff --git a/dns/py-idna/Makefile b/dns/py-idna/Makefile
index 791de5899395..b130731e3889 100644
--- a/dns/py-idna/Makefile
+++ b/dns/py-idna/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flit-core>=3.2<4:devel/py-flit-core@${PY_FLAVOR}
-USES= python:3.5+
+USES= python
USE_PYTHON= autoplist concurrent pep517 unittest
NO_ARCH= yes
diff --git a/dns/py-idna_ssl/Makefile b/dns/py-idna_ssl/Makefile
index f751887cb860..59246927644c 100644
--- a/dns/py-idna_ssl/Makefile
+++ b/dns/py-idna_ssl/Makefile
@@ -18,7 +18,7 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=2.3:www/py-aiohttp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-asyncio>=0:devel/py-pytest-asyncio@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-cov>=0:devel/py-pytest-cov@${PY_FLAVOR}
-USES= python:3.3+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/dns/py-localzone/Makefile b/dns/py-localzone/Makefile
index f2e3a6869224..4405c39251a3 100644
--- a/dns/py-localzone/Makefile
+++ b/dns/py-localzone/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=0,1:dns/py-dnspython@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/dns/py-ns1-python/Makefile b/dns/py-ns1-python/Makefile
index 9e35d9db0282..f8e165c1d998 100644
--- a/dns/py-ns1-python/Makefile
+++ b/dns/py-ns1-python/Makefile
@@ -14,7 +14,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${P
${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/dns/py-publicsuffix/Makefile b/dns/py-publicsuffix/Makefile
index fc958a0d30f7..71c772cf920f 100644
--- a/dns/py-publicsuffix/Makefile
+++ b/dns/py-publicsuffix/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PATCH_DEPENDS= public_suffix_list>=0:dns/public_suffix_list
NO_ARCH= yes
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist distutils
post-patch:
diff --git a/dns/py-publicsuffix2/Makefile b/dns/py-publicsuffix2/Makefile
index bbeebca9ce59..8d153aa73981 100644
--- a/dns/py-publicsuffix2/Makefile
+++ b/dns/py-publicsuffix2/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/publicsuffix2.LICENSE
PATCH_DEPENDS= public_suffix_list>=0:dns/public_suffix_list
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/dns/py-publicsuffixlist/Makefile b/dns/py-publicsuffixlist/Makefile
index 952d7757d274..b9e59a3ad574 100644
--- a/dns/py-publicsuffixlist/Makefile
+++ b/dns/py-publicsuffixlist/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
PATCH_DEPENDS= public_suffix_list>=0:dns/public_suffix_list
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
diff --git a/dns/py-py3dns/Makefile b/dns/py-py3dns/Makefile
index 59a2fe901412..550922439fc8 100644
--- a/dns/py-py3dns/Makefile
+++ b/dns/py-py3dns/Makefile
@@ -13,7 +13,7 @@ LICENSE_NAME= CNRI LICENSE AGREEMENT
LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= python:3.3+
+USES= python
USE_PYTHON= autoplist concurrent distutils pytest
NO_ARCH= yes
diff --git a/dns/py-pybonjour/Makefile b/dns/py-pybonjour/Makefile
index 89f040247748..70e022cd308b 100644
--- a/dns/py-pybonjour/Makefile
+++ b/dns/py-pybonjour/Makefile
@@ -11,7 +11,7 @@ LICENSE= MIT
LIB_DEPENDS= libdns_sd.so.1:net/mDNSResponder
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist distutils
USE_GITHUB= yes
GH_ACCOUNT= depl0y
diff --git a/dns/py-pycares/Makefile b/dns/py-pycares/Makefile
index 3a7c2556b0f2..dc20b97ac8a8 100644
--- a/dns/py-pycares/Makefile
+++ b/dns/py-pycares/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.5.0:devel/py-cffi@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.5.0:devel/py-cffi@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= IDNA
diff --git a/dns/py-pydnstable/Makefile b/dns/py-pydnstable/Makefile
index 22a1398e21d6..d4e122dc8058 100644
--- a/dns/py-pydnstable/Makefile
+++ b/dns/py-pydnstable/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libmtbl.so:devel/mtbl \
libdnstable.so:dns/dnstable
-USES= pkgconfig python:3.6+
+USES= pkgconfig python
USE_PYTHON= autoplist cython distutils
post-install:
diff --git a/dns/py-pywdns/Makefile b/dns/py-pywdns/Makefile
index 0f1545099c81..c8b357583e1a 100644
--- a/dns/py-pywdns/Makefile
+++ b/dns/py-pywdns/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libwdns.so:dns/wdns
-USES= pkgconfig python:3.6+
+USES= pkgconfig python
USE_PYTHON= autoplist cython distutils
post-patch:
diff --git a/dns/py-tld/Makefile b/dns/py-tld/Makefile
index aa4f5dcbeb49..0f212423f109 100644
--- a/dns/py-tld/Makefile
+++ b/dns/py-tld/Makefile
@@ -12,7 +12,7 @@ LICENSE= MPL11 GPLv2 LGPL21
LICENSE_COMB= multi
NO_ARCH= yes
-USES= python:3.6+
+USES= python
USE_PYTHON= autoplist concurrent distutils
.include <bsd.port.mk>
diff --git a/dns/py-tldextract/Makefile b/dns/py-tldextract/Makefile
index b0bceefbd57d..a90d62cb64fb 100644
--- a/dns/py-tldextract/Makefile
+++ b/dns/py-tldextract/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}idna>=2.0:dns/py-idna@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests-file>=1.4:www/py-requests-file@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}filelock>0:sysutils/py-filelock@${PY_FLAVOR}
-USES= python:3.7+
+USES= python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes