summaryrefslogtreecommitdiff
path: root/dns/nsd
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-07-28 11:23:59 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-07-28 11:23:59 +0000
commit0c47b7db4238ec9a9baf24e07c767fac653ef200 (patch)
treeb4ce9d89e79fd98a3b4de5690e91e144e2976ff2 /dns/nsd
parenta9ad2299ecdfbdb92dce5ba4ed9c4ba5f63c31e6 (diff)
downloadfreebsd-ports-0c47b7db4238ec9a9baf24e07c767fac653ef200.zip
dns/nsd: Remove IPv6 option, fixes build
Remove the IPv6 option that is causing builds to fail when it is disabled. The issue does not affect package users, as it was a default option. The issue has been fixed upstream [1] and will be included/renabled in the next version update. While I'm here: * Switch to USES=ssl * Add --enable-ipv6 in CONNFIGURE_ARGS to ensure it's explicitly enabled [1] https://www.nlnetlabs.nl/bugs-script/show_bug.cgi?id=800 PR: 211303 Reported by: <vfx9as gmail com> Approved by: maintainer <jaap NLnetLabs nl> MFH: 2016Q3
Diffstat (limited to 'dns/nsd')
-rw-r--r--dns/nsd/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/dns/nsd/Makefile b/dns/nsd/Makefile
index a9ba8af65206..13834c3315e4 100644
--- a/dns/nsd/Makefile
+++ b/dns/nsd/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
CONFLICTS= nsd-[0-3]* nsd3-[0-9]*
-USES= cpe
+USES= cpe ssl
CPE_VENDOR= nlnetlabs
USE_RC_SUBR= nsd
@@ -34,7 +34,8 @@ CONFIGURE_ARGS= --with-libevent=${LOCALBASE} \
--localstatedir=${NSDLSDIR} \
--with-dbfile=${NSDDBDIR}/nsd.db \
--with-ssl=${OPENSSLBASE} \
- --with-pidfile=${NSDRUNDIR}/nsd.pid
+ --with-pidfile=${NSDRUNDIR}/nsd.pid \
+ --enable-ipv6
PLIST_SUB= NSDUSER=${NSDUSER} \
NSDGROUP=${NSDGROUP} \
@@ -44,16 +45,14 @@ PLIST_SUB= NSDUSER=${NSDUSER} \
USERS= ${NSDUSER}
GROUPS= ${NSDGROUP}
-USE_OPENSSL= yes
-
PORTDOCS= CREDITS ChangeLog LICENSE NSD-DATABASE NSD-DIFFFILE \
NSD-4-features NSD-FOR-BIND-USERS README README.icc RELNOTES \
REQUIREMENTS TESTPLAN TODO UPGRADING coding-style \
differences.tex
-OPTIONS_DEFINE= ROOT_SERVER LARGEFILE IPV6 BIND8_STATS CHECKING \
+OPTIONS_DEFINE= ROOT_SERVER LARGEFILE BIND8_STATS CHECKING \
MINRESPSIZE NSEC3 MMAP DOCS RRL ZONE_STATS MUNIN_PLUGIN
-OPTIONS_DEFAULT= LARGEFILE IPV6 NSEC3 MINRESPSIZE RRL
+OPTIONS_DEFAULT= LARGEFILE NSEC3 MINRESPSIZE RRL
OPTIONS_SUB= yes
MUNIN_PLUGIN_IMPLIES= BIND8_STATS
@@ -73,7 +72,6 @@ LIB_DEPENDS+= libevent.so:devel/libevent2
ROOT_SERVER_CONFIGURE_ENABLE= root-server
LARGEFILE_CONFIGURE_ENABLE= largefile
-IPV6_CONFIGURE_ENABLE= ipv6
BIND8_STATS_CONFIGURE_ENABLE= bind8-stats
CHECKING_CONFIGURE_ENABLE= checking
NSEC3_CONFIGURE_ENABLE= nsec3